summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-06-25 20:15:33 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-06-25 20:15:33 +0000
commitc72e9ed5715f8e9207e622b29735a3aaf7bb187b (patch)
treefc9556e552dc35cf6e2f2563125e692864558ef1 /app-editors
parentmarked x86 per bug 418409 (diff)
downloadhistorical-c72e9ed5715f8e9207e622b29735a3aaf7bb187b.tar.gz
historical-c72e9ed5715f8e9207e622b29735a3aaf7bb187b.tar.bz2
historical-c72e9ed5715f8e9207e622b29735a3aaf7bb187b.zip
Version bump. Thanks to Alexander van der Mey <alexvandermey@gmail.com>
Package-Manager: portage-2.1.11/cvs/Linux x86_64
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gummi/ChangeLog8
-rw-r--r--app-editors/gummi/gummi-0.6.4.ebuild44
2 files changed, 50 insertions, 2 deletions
diff --git a/app-editors/gummi/ChangeLog b/app-editors/gummi/ChangeLog
index 68110ae39ae0..31098c24c6b9 100644
--- a/app-editors/gummi/ChangeLog
+++ b/app-editors/gummi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/gummi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gummi/ChangeLog,v 1.36 2012/05/02 08:40:26 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gummi/ChangeLog,v 1.37 2012/06/25 20:15:33 hwoarang Exp $
+
+*gummi-0.6.4 (25 Jun 2012)
+
+ 25 Jun 2012; Markos Chandras <hwoarang@gentoo.org> +gummi-0.6.4.ebuild:
+ Version bump. Thanks to Alexander van der Mey <alexvandermey@gmail.com>
02 May 2012; Jeff Horelick <jdhore@gentoo.org> gummi-0.6.3.ebuild:
marked x86 per bug 413841
@@ -150,4 +155,3 @@
+metadata.xml:
Moved from sunrise overlay. Bug #282876. Thanks to Alexander van der Mey
<alexvandermey@gmail.com> for the ebuild
-
diff --git a/app-editors/gummi/gummi-0.6.4.ebuild b/app-editors/gummi/gummi-0.6.4.ebuild
new file mode 100644
index 000000000000..9141372cdfab
--- /dev/null
+++ b/app-editors/gummi/gummi-0.6.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gummi/gummi-0.6.4.ebuild,v 1.1 2012/06/25 20:15:33 hwoarang Exp $
+
+EAPI=4
+inherit base eutils
+
+DESCRIPTION="Simple LaTeX editor for GTK+"
+HOMEPAGE="http://gummi.midnightcoding.org"
+SRC_URI="http://dev.midnightcoding.org/attachments/download/298/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+LANGS="ar ca cs da de el es fr it nl pl pt pt_BR ro ru sv zh_CN zh_TW"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND="app-text/gtkspell:2
+ >=dev-libs/glib-2.28.6
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/gtksourceview:2.0"
+DEPEND="${RDEPEND}
+ app-text/poppler[cairo]
+ x11-libs/gtksourceview:2.0
+ x11-libs/pango"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_prepare() {
+ strip-linguas ${LANGS}
+}
+
+pkg_postinst() {
+ elog "Gummi >=0.4.8 supports spell-checking through gtkspell. Support for"
+ elog "additional languages can be added by installing myspell-** packages"
+ elog "for your language of choice."
+}