summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-07-12 16:30:43 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-07-12 16:30:43 +0000
commit41c9674230e793ba01314441eb43c76c9a5bb44b (patch)
treedddcc34133a846c6057cd713523022e4e6203ec2 /app-editors
parentSCSH is just as-is/BSD (diff)
downloadhistorical-41c9674230e793ba01314441eb43c76c9a5bb44b.tar.gz
historical-41c9674230e793ba01314441eb43c76c9a5bb44b.tar.bz2
historical-41c9674230e793ba01314441eb43c76c9a5bb44b.zip
should install documentation now
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/jedit/ChangeLog8
-rw-r--r--app-editors/jedit/files/digest-jedit-4.0.3-r11
-rw-r--r--app-editors/jedit/jedit-4.0.3-r1.ebuild54
3 files changed, 62 insertions, 1 deletions
diff --git a/app-editors/jedit/ChangeLog b/app-editors/jedit/ChangeLog
index 3015d50d38d1..64fb80a104e8 100644
--- a/app-editors/jedit/ChangeLog
+++ b/app-editors/jedit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/jedit
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/ChangeLog,v 1.3 2002/07/08 20:58:44 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/ChangeLog,v 1.4 2002/07/12 16:30:43 rphillips Exp $
+
+*jedit-4.0.3-r1 (12 Jul 2002)
+
+ 12 Jul 2002; Ryan Phillips <rphillips@gentoo.org> jedit-4.0.3-r1.ebuild :
+
+ Should install the docs now...
*jedit-4.0.3 (02 Jul 2002)
diff --git a/app-editors/jedit/files/digest-jedit-4.0.3-r1 b/app-editors/jedit/files/digest-jedit-4.0.3-r1
new file mode 100644
index 000000000000..05e5e28f8719
--- /dev/null
+++ b/app-editors/jedit/files/digest-jedit-4.0.3-r1
@@ -0,0 +1 @@
+MD5 95a26ccc1ab89257a467ef159f5dad05 jedit403source.tar.gz 1283199
diff --git a/app-editors/jedit/jedit-4.0.3-r1.ebuild b/app-editors/jedit/jedit-4.0.3-r1.ebuild
new file mode 100644
index 000000000000..52c4a7a5193a
--- /dev/null
+++ b/app-editors/jedit/jedit-4.0.3-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author: Maik Schreiber <bZ@iq-computing.de>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.0.3-r1.ebuild,v 1.1 2002/07/12 16:30:43 rphillips Exp $
+
+S="${WORKDIR}/jEdit"
+DESCRIPTION="Programmer's editor written in Java"
+HOMEPAGE="http://www.jedit.org"
+LICENSE="GPL-2"
+DEPEND=">=dev-java/ant-1.4.1 >=dev-java/jikes-1.15"
+RDEPEND=">=virtual/jdk-1.3"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/jedit/jedit403source.tar.gz"
+
+src_compile() {
+ einfo "Please ignore the following compiler warnings."
+ einfo "Jikes is just too pedantic..."
+ ant -Dbuild.compiler=jikes || die "compile problem"
+}
+
+src_install () {
+ mkdir -m 755 -p ${D}/usr/share/jedit
+ mkdir -m 755 ${D}/usr/bin
+
+ cp -R jedit.jar jars macros doc modes properties startup ${D}/usr/share/jedit
+ cd ${D}/usr/share/jedit
+ chmod -R u+rw,ug-s,go+u,go-w \
+ jedit.jar jars macros modes properties startup
+
+ cat >${D}/usr/share/jedit/jedit.sh <<-EOF
+ #!/bin/bash
+
+ cd /usr/share/jedit
+ java -jar /usr/share/jedit/jedit.jar $@
+ EOF
+ chmod 755 ${D}/usr/share/jedit/jedit.sh
+
+ ln -s ../share/jedit/jedit.sh ${D}/usr/bin/jedit
+}
+
+pkg_postinst() {
+ touch /usr/share/jedit/jars/.keep
+
+ einfo "The system directory for jEdit plugins is"
+ einfo "/usr/share/jedit/jars"
+}
+
+pkg_postrm() {
+ einfo "jEdit plugins installed into /usr/share/jedit/jars"
+ einfo "(after installation of jEdit itself) haven't been"
+ einfo "removed. To get rid of jEdit completely, you may"
+ einfo "want to run"
+ einfo ""
+ einfo "\trm -r /usr/share/jedit"
+}