summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-09-24 19:21:57 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-09-24 19:21:57 +0000
commitd28eb86c89496e1e4e3eea37fab03272e47ff180 (patch)
treec78a9305632aafb4633e0e15fcfae0e4d6804282 /app-editors/mp
parentVersion bumped. Closes #24699 (diff)
downloadhistorical-d28eb86c89496e1e4e3eea37fab03272e47ff180.tar.gz
historical-d28eb86c89496e1e4e3eea37fab03272e47ff180.tar.bz2
historical-d28eb86c89496e1e4e3eea37fab03272e47ff180.zip
Version bumped. Closes #24699
Diffstat (limited to 'app-editors/mp')
-rw-r--r--app-editors/mp/Manifest4
-rw-r--r--app-editors/mp/files/digest-mp-3.2.81
-rw-r--r--app-editors/mp/mp-3.2.8.ebuild34
3 files changed, 37 insertions, 2 deletions
diff --git a/app-editors/mp/Manifest b/app-editors/mp/Manifest
index 1fab647d593f..4dc1c8dae0ed 100644
--- a/app-editors/mp/Manifest
+++ b/app-editors/mp/Manifest
@@ -1,7 +1,7 @@
-MD5 0a6881f557b21ae136e570be18f7be7b ChangeLog 633
+MD5 2f155a67d514bdc56cf6cc80c02bc1a9 ChangeLog 759
MD5 f8960c09f9b4a97feeb5bc94a2b63943 mp-3.1.9.ebuild 706
MD5 46488628aab9f7e846431a6655784507 mp-3.2.7.ebuild 697
-MD5 7ce0c2f7b84d7aebb875bae2c6c69216 mp-3.2.8.ebuild 902
+MD5 5cf35f20896525f30326708163959818 mp-3.2.8.ebuild 996
MD5 135880e17116622cd1cfff6f0b370a29 files/digest-mp-3.1.9 59
MD5 11b6a12f8308d146aabfd13282344f19 files/digest-mp-3.2.7 60
MD5 d88c1d60541aab07f3b63a78d903c2de files/digest-mp-3.2.8 60
diff --git a/app-editors/mp/files/digest-mp-3.2.8 b/app-editors/mp/files/digest-mp-3.2.8
new file mode 100644
index 000000000000..31d1cb01d378
--- /dev/null
+++ b/app-editors/mp/files/digest-mp-3.2.8
@@ -0,0 +1 @@
+MD5 994198e4735b0b348bfe35f2f20d6070 mp-3.2.8.tar.gz 176453
diff --git a/app-editors/mp/mp-3.2.8.ebuild b/app-editors/mp/mp-3.2.8.ebuild
new file mode 100644
index 000000000000..0341d397de1e
--- /dev/null
+++ b/app-editors/mp/mp-3.2.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.2.8.ebuild,v 1.1 2003/09/24 19:21:52 mholzer Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="mp, the definitive text editor"
+SRC_URI="http://www.triptico.com/download/${P}.tar.gz"
+HOMEPAGE="http://www.triptico.com/software/mp.html"
+
+DEPEND="virtual/glibc
+ ncurses? ( sys-libs/ncurses )
+ gtk? ( =x11-libs/gtk+-1.2* )"
+
+RDEPEND="${DEPEND}
+ dev-lang/perl"
+IUSE="ncurses gtk"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+src_compile() {
+ if [ -n "`use ncurses`" ] && [ -n "`use gtk`" ]; then emake || die;
+ elif [ -n "`use ncurses`" ]; then emake mp || die;
+ elif [ -n "`use gtk`" ]; then emake gmp || die;
+ else die "You need ncurses and/or gtk in your USE variables";
+ fi
+}
+
+src_install () {
+ dodir /usr/bin
+ make install PREFIX=${D}/usr || die "install failed"
+ dodoc AUTHORS Changelog COPYING README
+ dohtml README.html doc/mp_api.html
+}