summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-11-27 08:55:35 +0000
committerMike Frysinger <vapier@gentoo.org>2009-11-27 08:55:35 +0000
commitee6fed5cec79ca2274f70452035b0e3b9b54c14e (patch)
tree39047ed75c05c31cd45145e52eb45f45a756dad0 /app-crypt
parentClean debugging statements (diff)
downloadhistorical-ee6fed5cec79ca2274f70452035b0e3b9b54c14e.tar.gz
historical-ee6fed5cec79ca2274f70452035b0e3b9b54c14e.tar.bz2
historical-ee6fed5cec79ca2274f70452035b0e3b9b54c14e.zip
Initial ebuild by me.
Package-Manager: portage-2.2_rc51/cvs/Linux x86_64
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/xor-analyze/ChangeLog10
-rw-r--r--app-crypt/xor-analyze/Manifest14
-rw-r--r--app-crypt/xor-analyze/metadata.xml5
-rw-r--r--app-crypt/xor-analyze/xor-analyze-0.5.ebuild25
4 files changed, 54 insertions, 0 deletions
diff --git a/app-crypt/xor-analyze/ChangeLog b/app-crypt/xor-analyze/ChangeLog
new file mode 100644
index 000000000000..cf90ea111644
--- /dev/null
+++ b/app-crypt/xor-analyze/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-crypt/xor-analyze
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/xor-analyze/ChangeLog,v 1.1 2009/11/27 08:55:35 vapier Exp $
+
+*xor-analyze-0.5 (27 Nov 2009)
+
+ 27 Nov 2009; Mike Frysinger <vapier@gentoo.org> +xor-analyze-0.5.ebuild,
+ +metadata.xml:
+ Initial ebuild by me.
+
diff --git a/app-crypt/xor-analyze/Manifest b/app-crypt/xor-analyze/Manifest
new file mode 100644
index 000000000000..3cece11fb594
--- /dev/null
+++ b/app-crypt/xor-analyze/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST xor-analyze-0.5.tar.gz 26635 RMD160 94955d8606eea8f6c9f8e180174be110c9f57631 SHA1 899819a89a1a0c9bfa9fc2bab8339cc3883f75c7 SHA256 5f66b0f11fd284335780781aa0b18abef4d03fae7808d5e99053ee5f05d41ce9
+EBUILD xor-analyze-0.5.ebuild 734 RMD160 7f72f1c5ddc817a98d4cb1994228b8883dd82d25 SHA1 5089dfd2f1d2514cc0860112f54b75eaae8cc14f SHA256 3bc7657156dd31d542f7a2311a1b3ed9cd589a162c6e0015c39be78809e5d861
+MISC ChangeLog 364 RMD160 f42ad66d4ea25cf90682f3939f12a6d54178f092 SHA1 9cb9dccd4c371a1af0e147bcf20db2efa4c07ebd SHA256 aa4f2cbcec91d25846b7855b715049913867f7a08ac5ad5b5197178c00f4493f
+MISC metadata.xml 160 RMD160 d86217bb48cf4283e08e43bcaabbc919101ad795 SHA1 d6147d00f16e8cfeef893d0764b0675a93d62849 SHA256 56fca1e06f6dcbe3bc12e7d3962998c7cb79d74f218ce8a17b07771b3e06f49e
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.13 (GNU/Linux)
+
+iEYEARECAAYFAksPlQwACgkQlPl3HsVfCDqW6gCffAYfovYSUZJwLvl/nunC07XX
+S7MAn0K55RnLQY94Zb2oVpXjW2oj0/DS
+=AYe/
+-----END PGP SIGNATURE-----
diff --git a/app-crypt/xor-analyze/metadata.xml b/app-crypt/xor-analyze/metadata.xml
new file mode 100644
index 000000000000..20ce219711a2
--- /dev/null
+++ b/app-crypt/xor-analyze/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+</pkgmetadata>
diff --git a/app-crypt/xor-analyze/xor-analyze-0.5.ebuild b/app-crypt/xor-analyze/xor-analyze-0.5.ebuild
new file mode 100644
index 000000000000..93615d867305
--- /dev/null
+++ b/app-crypt/xor-analyze/xor-analyze-0.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/xor-analyze/xor-analyze-0.5.ebuild,v 1.1 2009/11/27 08:55:35 vapier Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="program for cryptanalyzing xor 'encryption' with variable key length"
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=xor-analyze"
+SRC_URI="http://www.habets.pp.se/synscan/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_compile() {
+ rm -f Makefile
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" xor-analyze xor-enc || die
+}
+
+src_install() {
+ dobin xor-analyze xor-enc || die
+ dosym xor-enc /usr/bin/xor-dec
+ dodoc README TODO
+}