summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 02:38:31 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 02:38:31 +0000
commit8a5980132f20ed31f853867ed4a29d786a50f400 (patch)
tree1d72e8ae7a5d9cd09f30ba0c74ac27c83450914b /app-crypt
parentChanged mkdir ${D} to dodir ${D} (diff)
downloadhistorical-8a5980132f20ed31f853867ed4a29d786a50f400.tar.gz
historical-8a5980132f20ed31f853867ed4a29d786a50f400.tar.bz2
historical-8a5980132f20ed31f853867ed4a29d786a50f400.zip
Changed econf||die to econf
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/cryptoapi/cryptoapi-2.4.7.0.ebuild9
-rw-r--r--app-crypt/gnupg/gnupg-1.2.0.ebuild12
-rw-r--r--app-crypt/gnupg/gnupg-1.2.1.ebuild12
-rw-r--r--app-crypt/gpa/gpa-0.4.3.ebuild18
-rw-r--r--app-crypt/gpgme/gpgme-0.3.12.ebuild7
-rw-r--r--app-crypt/gpgme/gpgme-0.3.13.ebuild7
-rw-r--r--app-crypt/gpgsm/gpgsm-0.3.10.ebuild8
-rw-r--r--app-crypt/gringotts/gringotts-0.5.9.ebuild7
-rw-r--r--app-crypt/gringotts/gringotts-0.6.1.ebuild8
-rw-r--r--app-crypt/gringotts/gringotts-0.6.2.ebuild8
-rw-r--r--app-crypt/mhash/mhash-0.8.16.ebuild12
-rw-r--r--app-crypt/mhash/mhash-0.8.9.ebuild12
-rw-r--r--app-crypt/seahorse/seahorse-0.5.0.ebuild5
13 files changed, 49 insertions, 76 deletions
diff --git a/app-crypt/cryptoapi/cryptoapi-2.4.7.0.ebuild b/app-crypt/cryptoapi/cryptoapi-2.4.7.0.ebuild
index 97310fa6cd05..08cd19ca800e 100644
--- a/app-crypt/cryptoapi/cryptoapi-2.4.7.0.ebuild
+++ b/app-crypt/cryptoapi/cryptoapi-2.4.7.0.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/cryptoapi/cryptoapi-2.4.7.0.ebuild,v 1.12 2002/10/04 03:57:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/cryptoapi/cryptoapi-2.4.7.0.ebuild,v 1.13 2002/11/30 02:28:22 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Modules that add encryption ability at the kernel level."
SRC_URI="mirror://sourceforge/cryptoapi/${P}.tar.gz"
HOMEPAGE="http://www.sourceforge.net/projects/cryptoapi"
@@ -12,12 +11,12 @@ LICENSE="GPL-2"
KEYWORDS="x86 -ppc"
DEPEND=">=sys-apps/util-linux-2.11o-r2
- virtual/linux-sources
- >=sys-apps/portage-1.9.10"
+ virtual/linux-sources
+ >=sys-apps/portage-1.9.10"
src_compile() {
check_KV
- econf --enable-iv-mode-sector || die
+ econf --enable-iv-mode-sector
cd ${S}/api
cp Makefile Makefile.orig
sed -e "s:-DMODVERSIONS:-DMODVERSIONS -DEXPORT_SYMTAB:g" \
diff --git a/app-crypt/gnupg/gnupg-1.2.0.ebuild b/app-crypt/gnupg/gnupg-1.2.0.ebuild
index 900be9a41e48..aaaa58c7c5fa 100644
--- a/app-crypt/gnupg/gnupg-1.2.0.ebuild
+++ b/app-crypt/gnupg/gnupg-1.2.0.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.2.0.ebuild,v 1.2 2002/10/21 06:34:54 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.2.0.ebuild,v 1.3 2002/11/30 02:29:01 vapier Exp $
-IUSE="zlib ldap nls"
-
-S="${WORKDIR}/${P}"
DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
HOMEPAGE="http://www.gnupg.org/"
SRC_URI="ftp://ftp.gnupg.org/gcrypt/gnupg/${P}.tar.bz2"
@@ -12,6 +9,7 @@ SRC_URI="ftp://ftp.gnupg.org/gcrypt/gnupg/${P}.tar.bz2"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+IUSE="zlib ldap nls"
DEPEND="sys-devel/perl
zlib? ( sys-libs/zlib )
@@ -30,11 +28,11 @@ src_compile() {
myconf="${myconf} --enable-m-guard"
fi
- econf ${myconf} || die
- emake || make || die
+ econf ${myconf}
+ make || die
}
-src_install () {
+src_install() {
make DESTDIR="${D}" install || die
dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS README THANKS TODO VERSION
docinto doc
diff --git a/app-crypt/gnupg/gnupg-1.2.1.ebuild b/app-crypt/gnupg/gnupg-1.2.1.ebuild
index df1739e11042..7c6039b0a056 100644
--- a/app-crypt/gnupg/gnupg-1.2.1.ebuild
+++ b/app-crypt/gnupg/gnupg-1.2.1.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.2.1.ebuild,v 1.5 2002/11/10 15:29:29 doctomoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.2.1.ebuild,v 1.6 2002/11/30 02:29:47 vapier Exp $
-IUSE="X zlib ldap nls"
-
-S="${WORKDIR}/${P}"
DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
HOMEPAGE="http://www.gnupg.org/"
SRC_URI="ftp://ftp.gnupg.org/gcrypt/gnupg/${P}.tar.bz2"
@@ -12,6 +9,7 @@ SRC_URI="ftp://ftp.gnupg.org/gcrypt/gnupg/${P}.tar.bz2"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ppc ~sparc ~sparc64"
+IUSE="X zlib ldap nls"
DEPEND="sys-devel/perl
X? ( x11-misc/xloadimage )
@@ -32,11 +30,11 @@ src_compile() {
myconf="${myconf} --enable-m-guard"
fi
- econf ${myconf} || die
- emake || make || die
+ econf ${myconf}
+ make || die
}
-src_install () {
+src_install() {
make DESTDIR="${D}" install || die
dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS README THANKS TODO VERSION
docinto doc
diff --git a/app-crypt/gpa/gpa-0.4.3.ebuild b/app-crypt/gpa/gpa-0.4.3.ebuild
index 787929b04859..d0342e1166ba 100644
--- a/app-crypt/gpa/gpa-0.4.3.ebuild
+++ b/app-crypt/gpa/gpa-0.4.3.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpa/gpa-0.4.3.ebuild,v 1.10 2002/10/20 18:37:02 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpa/gpa-0.4.3.ebuild,v 1.11 2002/11/30 02:30:33 vapier Exp $
-IUSE="nls"
-
-S=${WORKDIR}/${P}
DESCRIPTION="Standard GUI for GnuPG"
SRC_URI="ftp://ftp.gnupg.org/gcrypt/alpha/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.gnupg.org/gpa.html"
@@ -12,22 +9,23 @@ HOMEPAGE="http://www.gnupg.org/gpa.html"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc sparc64"
+IUSE="nls"
-DEPEND="=x11-libs/gtk+-1.2* app-crypt/gnupg nls? ( sys-devel/gettext )"
-
+DEPEND="=x11-libs/gtk+-1.2*
+ app-crypt/gnupg
+ nls? ( sys-devel/gettext )"
src_compile() {
local myconf
-
use nls || myconf="--disable-nls"
+ econf ${myconf}
- econf ${myconf} || die
#didn't work as of 0.4.3 (drobbins, 30 Sep 2002)
#emake || die
make || die
}
-src_install () {
- einstall || die
+src_install() {
+ einstall
dodoc AUTHORS COPYING ChangeLog README NEWS TODO
}
diff --git a/app-crypt/gpgme/gpgme-0.3.12.ebuild b/app-crypt/gpgme/gpgme-0.3.12.ebuild
index 153a5ad86e05..a2a589073f46 100644
--- a/app-crypt/gpgme/gpgme-0.3.12.ebuild
+++ b/app-crypt/gpgme/gpgme-0.3.12.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/gpgme-0.3.12.ebuild,v 1.1 2002/10/18 08:45:42 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/gpgme-0.3.12.ebuild,v 1.2 2002/11/30 02:31:03 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications."
SRC_URI="ftp://ftp.gnupg.org/gcrypt/alpha/gpgme/${P}.tar.gz"
HOMEPAGE="http://www.gnupg.org/gpgme.html"
@@ -25,11 +24,11 @@ src_compile() {
use doc \
&& myconf="${myconf} --enable-maintainer-mode"
- econf ${myconf} || die
+ econf ${myconf}
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README README-alpha THANKS TODO VERSION
}
diff --git a/app-crypt/gpgme/gpgme-0.3.13.ebuild b/app-crypt/gpgme/gpgme-0.3.13.ebuild
index 89d326b45ee5..7ef01dfb1168 100644
--- a/app-crypt/gpgme/gpgme-0.3.13.ebuild
+++ b/app-crypt/gpgme/gpgme-0.3.13.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/gpgme-0.3.13.ebuild,v 1.1 2002/11/27 04:34:52 jrray Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/gpgme-0.3.13.ebuild,v 1.2 2002/11/30 02:32:51 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications."
SRC_URI="ftp://ftp.gnupg.org/gcrypt/gpgme/${P}.tar.gz"
HOMEPAGE="http://www.gnupg.org/gpgme.html"
@@ -25,11 +24,11 @@ src_compile() {
use doc \
&& myconf="${myconf} --enable-maintainer-mode"
- econf ${myconf} || die
+ econf ${myconf}
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README README-alpha THANKS TODO VERSION
}
diff --git a/app-crypt/gpgsm/gpgsm-0.3.10.ebuild b/app-crypt/gpgsm/gpgsm-0.3.10.ebuild
index aac12818130d..a455c777f8af 100644
--- a/app-crypt/gpgsm/gpgsm-0.3.10.ebuild
+++ b/app-crypt/gpgsm/gpgsm-0.3.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgsm/gpgsm-0.3.10.ebuild,v 1.1 2002/11/01 10:29:43 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgsm/gpgsm-0.3.10.ebuild,v 1.2 2002/11/30 02:36:47 vapier Exp $
S="${WORKDIR}/newpg-${PV}"
DESCRIPTION="GnuPG Cryptographic message syntax and temporary project for gnupg extensions. Will be merged into gnupg for the gnupg-2.0 release."
@@ -24,13 +24,13 @@ RDEPEND="nls? ( sys-devel/gettext )"
src_compile(){
local myconf
use nls \
+ && myconf="--enable-nls" \
|| myconf="--disable-nls"
-
- econf ${myconf} || die
+ econf ${myconf}
emake || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc ABOUT-NLS AUTHORS ChangeLog COPYING INSTALL NEWS README README-alpha THANKS TODO VERSION
}
diff --git a/app-crypt/gringotts/gringotts-0.5.9.ebuild b/app-crypt/gringotts/gringotts-0.5.9.ebuild
index 545bc8687d90..f745adebf4cb 100644
--- a/app-crypt/gringotts/gringotts-0.5.9.ebuild
+++ b/app-crypt/gringotts/gringotts-0.5.9.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gringotts/gringotts-0.5.9.ebuild,v 1.4 2002/10/04 03:57:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gringotts/gringotts-0.5.9.ebuild,v 1.5 2002/11/30 02:33:21 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Gringotts is a utility that allows you to jot down sensitive data"
SRC_URI="http://devel.pluto.linux.it/projects/Gringotts/current/${P}.tar.bz2"
HOMEPAGE="http://devel.pluto.linux.it/projects/Gringotts/"
@@ -17,14 +16,12 @@ RDEPEND=">=dev-libs/glib-2.0.3
>=x11-libs/gtk+-2.0.5
>=dev-libs/libmcrypt-2.4.19-r1
>=app-crypt/mhash-0.8.16"
-
DEPEND="${RDEPEND}
>=dev-util/intltool-0.17
>=dev-util/pkgconfig-0.12.0"
src_compile() {
- econf || die
-
+ econf
emake || die
}
diff --git a/app-crypt/gringotts/gringotts-0.6.1.ebuild b/app-crypt/gringotts/gringotts-0.6.1.ebuild
index 9bd7357004de..c80c7acf58f2 100644
--- a/app-crypt/gringotts/gringotts-0.6.1.ebuild
+++ b/app-crypt/gringotts/gringotts-0.6.1.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gringotts/gringotts-0.6.1.ebuild,v 1.2 2002/10/04 03:57:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gringotts/gringotts-0.6.1.ebuild,v 1.3 2002/11/30 02:33:50 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Gringotts is a utility that allows you to jot down sensitive data"
SRC_URI="http://devel.pluto.linux.it/projects/Gringotts/current/${P}.tar.bz2"
HOMEPAGE="http://devel.pluto.linux.it/projects/Gringotts/"
@@ -15,19 +14,16 @@ RDEPEND=">=dev-libs/glib-2.0.6-r1
>=x11-libs/gtk+-2.0.6-r1
>=dev-libs/libmcrypt-2.5.1
>=app-crypt/mhash-0.8.16"
-
DEPEND="${RDEPEND}
>=dev-util/intltool-0.17
>=dev-util/pkgconfig-0.12.0"
src_compile() {
- econf || die
-
+ econf
emake || die
}
src_install() {
make DESTDIR=${D} install || die
-
dodoc COPYING ChangeLog README AUTHORS
}
diff --git a/app-crypt/gringotts/gringotts-0.6.2.ebuild b/app-crypt/gringotts/gringotts-0.6.2.ebuild
index 1922677d829e..8a7bb1531b7a 100644
--- a/app-crypt/gringotts/gringotts-0.6.2.ebuild
+++ b/app-crypt/gringotts/gringotts-0.6.2.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gringotts/gringotts-0.6.2.ebuild,v 1.2 2002/10/04 03:57:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gringotts/gringotts-0.6.2.ebuild,v 1.3 2002/11/30 02:34:11 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="Gringotts is a utility that allows you to jot down sensitive data"
SRC_URI="http://devel.pluto.linux.it/projects/Gringotts/current/${P}.tar.bz2"
HOMEPAGE="http://devel.pluto.linux.it/projects/Gringotts/"
@@ -15,19 +14,16 @@ RDEPEND=">=dev-libs/glib-2.0.6-r1
>=x11-libs/gtk+-2.0.6-r1
>=dev-libs/libmcrypt-2.5.1
>=app-crypt/mhash-0.8.16"
-
DEPEND="${RDEPEND}
>=dev-util/intltool-0.17
>=dev-util/pkgconfig-0.12.0"
src_compile() {
- econf || die
-
+ econf
emake || die
}
src_install() {
make DESTDIR=${D} install || die
-
dodoc COPYING ChangeLog README AUTHORS
}
diff --git a/app-crypt/mhash/mhash-0.8.16.ebuild b/app-crypt/mhash/mhash-0.8.16.ebuild
index 987acbe8f046..26d97292242b 100644
--- a/app-crypt/mhash/mhash-0.8.16.ebuild
+++ b/app-crypt/mhash/mhash-0.8.16.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mhash/mhash-0.8.16.ebuild,v 1.8 2002/10/18 20:56:40 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mhash/mhash-0.8.16.ebuild,v 1.9 2002/11/30 02:35:30 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="mhash is a library providing a uniform interface to a large number of hash algorithms."
SRC_URI="mirror://sourceforge/mhash/${P}.tar.gz"
HOMEPAGE="http://mhash.sourceforge.net/"
@@ -12,18 +11,17 @@ LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc sparc64"
DEPEND="virtual/glibc"
-
RDEPEND=""
src_compile() {
- econf || die
+ econf
emake || die
}
-src_install () {
+src_install() {
dodir /usr/{bin,include,lib}
-
- einstall || die
+
+ einstall
dodoc AUTHORS COPYING INSTALL NEWS README TODO
dodoc doc/*.txt doc/skid*
diff --git a/app-crypt/mhash/mhash-0.8.9.ebuild b/app-crypt/mhash/mhash-0.8.9.ebuild
index 176820a88b18..956b8ea3abb6 100644
--- a/app-crypt/mhash/mhash-0.8.9.ebuild
+++ b/app-crypt/mhash/mhash-0.8.9.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mhash/mhash-0.8.9.ebuild,v 1.7 2002/10/04 03:58:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mhash/mhash-0.8.9.ebuild,v 1.8 2002/11/30 02:35:53 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="mhash is a library providing a uniform interface to a large number of hash algorithms."
SRC_URI="http://mhash.sourceforge.net/dl/${P}.tar.gz"
HOMEPAGE="http://mhash.sourceforge.net/"
@@ -14,16 +13,13 @@ KEYWORDS="x86 sparc sparc64"
DEPEND="virtual/glibc"
src_compile() {
-
- econf || die
+ econf
emake || die
}
-src_install () {
-
+src_install() {
dodir /usr/{bin,include,lib}
-
- einstall || die
+ einstall
dodoc AUTHORS COPYING INSTALL NEWS README TODO
dodoc doc/*.txt doc/skid*
diff --git a/app-crypt/seahorse/seahorse-0.5.0.ebuild b/app-crypt/seahorse/seahorse-0.5.0.ebuild
index 227d8134c123..474bad6af922 100644
--- a/app-crypt/seahorse/seahorse-0.5.0.ebuild
+++ b/app-crypt/seahorse/seahorse-0.5.0.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-0.5.0.ebuild,v 1.16 2002/10/18 20:56:40 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-0.5.0.ebuild,v 1.17 2002/11/30 02:38:31 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="gnome front end to gnupg"
SRC_URI="mirror://sourceforge/seahorse/${P}.tar.gz"
HOMEPAGE="http://seahorse.sourceforge.net/"
@@ -16,7 +15,7 @@ DEPEND="virtual/x11
>=gnome-base/gnome-libs-1.4.1.2-r1"
src_compile() {
- econf || die
+ econf
emake || die
}