summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2003-04-07 20:22:39 +0000
committerDan Armak <danarmak@gentoo.org>2003-04-07 20:22:39 +0000
commit2d2f69efdc591120dc36b02f5a8d406bf0bd02b6 (patch)
treeacfd64fc7e42220f5276c1a64eaacb91963334bc /app-crypt/pinentry
parentnew version that is needed for kmail (diff)
downloadhistorical-2d2f69efdc591120dc36b02f5a8d406bf0bd02b6.tar.gz
historical-2d2f69efdc591120dc36b02f5a8d406bf0bd02b6.tar.bz2
historical-2d2f69efdc591120dc36b02f5a8d406bf0bd02b6.zip
new version that is needed for kmail
Diffstat (limited to 'app-crypt/pinentry')
-rw-r--r--app-crypt/pinentry/files/digest-pinentry-0.6.82
-rw-r--r--app-crypt/pinentry/pinentry-0.6.8.ebuild45
2 files changed, 46 insertions, 1 deletions
diff --git a/app-crypt/pinentry/files/digest-pinentry-0.6.8 b/app-crypt/pinentry/files/digest-pinentry-0.6.8
index 8da6004e189b..e4ebd8224fd1 100644
--- a/app-crypt/pinentry/files/digest-pinentry-0.6.8
+++ b/app-crypt/pinentry/files/digest-pinentry-0.6.8
@@ -1,2 +1,2 @@
-MD5 9b0430597b521f0e8c5560b56f9a1e80 /pinentry-0.6.8.ebuild 1548
+MD5 e70ec93ba3f6bbc0487e5216b8290e2f /pinentry-0.6.8.ebuild 1542
MD5 be8460bc1ecc2596fabea931a48c5080 pinentry-0.6.8.tar.gz 320849
diff --git a/app-crypt/pinentry/pinentry-0.6.8.ebuild b/app-crypt/pinentry/pinentry-0.6.8.ebuild
new file mode 100644
index 000000000000..a2e2219bed9d
--- /dev/null
+++ b/app-crypt/pinentry/pinentry-0.6.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.6.8.ebuild,v 1.1 2003/04/07 20:22:17 danarmak Exp $
+
+DESCRIPTION="This is a collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol as described by the aegypten project."
+HOMEPAGE="http://www.gnupg.org/aegypten/"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+IUSE="qt gtk ncurses"
+
+DEPEND="gtk? ( x11-libs/gtk+ )
+ ncurses? ( sys-libs/ncurses )
+ qt? ( x11-libs/qt )"
+
+pkg_setup() {
+ use qt || use gtk || use ncurses || die "You must have at least one of 'qt', 'gtk', or 'ncurses' in your USE"
+}
+
+src_compile() {
+ econf $(use_enable qt pinentry-qt) \
+ $(use_enable gtk pinentry-gtk) \
+ $(use_enable ncurses pinentry-curses) \
+ $(use_enable ncurses fallback-curses) \
+ --disable-dependency-tracking
+ make || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO
+
+ # The other two pinentries don't spit out an insecure memory warning when
+ # not suid root, and gtk refuses to start if pinentry-gtk is suid root.
+ chmod +s "${D}"/usr/bin/pinentry-qt
+}
+
+pkg_postinst() {
+ einfo "pinentry-qt is installed SUID root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your passphrases,"
+ einfo "etc. at runtime but may make some sysadmins nervous"
+}