summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Farina <zerochaos@gentoo.org>2012-10-06 23:28:17 +0000
committerRichard Farina <zerochaos@gentoo.org>2012-10-06 23:28:17 +0000
commit016aa3336a2d612247d9e3b7847aa79219b6bcad (patch)
treeaa95928497b48a14ee4111807c3ebc1972de4e52 /app-crypt/johntheripper/johntheripper-1.7.9-r5.ebuild
parentVersion bump. (diff)
downloadhistorical-016aa3336a2d612247d9e3b7847aa79219b6bcad.tar.gz
historical-016aa3336a2d612247d9e3b7847aa79219b6bcad.tar.bz2
historical-016aa3336a2d612247d9e3b7847aa79219b6bcad.zip
restricting test per 437426, happy to add it back if it ever works right
Package-Manager: portage-2.1.11.24/cvs/Linux x86_64
Diffstat (limited to 'app-crypt/johntheripper/johntheripper-1.7.9-r5.ebuild')
-rw-r--r--app-crypt/johntheripper/johntheripper-1.7.9-r5.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/app-crypt/johntheripper/johntheripper-1.7.9-r5.ebuild b/app-crypt/johntheripper/johntheripper-1.7.9-r5.ebuild
index 2e61c353892d..373d5f29d57b 100644
--- a/app-crypt/johntheripper/johntheripper-1.7.9-r5.ebuild
+++ b/app-crypt/johntheripper/johntheripper-1.7.9-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/johntheripper-1.7.9-r5.ebuild,v 1.1 2012/10/05 17:43:57 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/johntheripper-1.7.9-r5.ebuild,v 1.2 2012/10/06 23:28:17 zerochaos Exp $
EAPI="4"
@@ -33,6 +33,9 @@ RDEPEND="!minimal? ( >=dev-libs/openssl-0.9.7:0 )
opencl? ( virtual/opencl )"
DEPEND="${RDEPEND}"
+#per bug #437426
+RESTRICT="test"
+
S="${WORKDIR}/${MY_P}"
has_xop() {
@@ -190,20 +193,21 @@ src_compile() {
$(get_target)
}
-src_test() {
- cd run
- if [[ -f "${EPREFIX}/etc/john/john.conf" || -f "${EPREFIX}/etc/john/john.ini" ]] ; then
+#src_test() {
+# cd run
+# if [[ -f "${EPREFIX}/etc/john/john.conf" || -f "${EPREFIX}/etc/john/john.ini" ]] ; then
# This requires that MPI is actually 100% online on your system, which might not
# be the case, depending on which MPI implementation you are using.
#if use mpi; then
# mpirun -np 2 ./john --test || die "self test failed"
#else
- ./john --test || die 'self test failed'
- else
- ewarn "Tests require '${EPREFIX}/etc/john/john.conf' or '${EPREFIX}/etc/john/john.ini'"
- fi
-}
+# pax-mark -mr john
+# ./john --test || die 'self test failed'
+# else
+# ewarn "Tests require '${EPREFIX}/etc/john/john.conf' or '${EPREFIX}/etc/john/john.ini'"
+# fi
+#}
src_install() {
# executables