summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2003-09-11 02:20:54 +0000
committerLars Weiler <pylon@gentoo.org>2003-09-11 02:20:54 +0000
commit140df0641bddfaa8b5cdbd0855954e73ec616dcc (patch)
tree9e86c4eccd7fa5be53c620ea8c14d6e27e985085 /app-cdr/xcdroast
parentmake use of the dvdr USE-flag (diff)
downloadhistorical-140df0641bddfaa8b5cdbd0855954e73ec616dcc.tar.gz
historical-140df0641bddfaa8b5cdbd0855954e73ec616dcc.tar.bz2
historical-140df0641bddfaa8b5cdbd0855954e73ec616dcc.zip
make use of the dvdr USE-flag
Diffstat (limited to 'app-cdr/xcdroast')
-rw-r--r--app-cdr/xcdroast/Manifest2
-rw-r--r--app-cdr/xcdroast/xcdroast-0.98_alpha14-r2.ebuild30
2 files changed, 20 insertions, 12 deletions
diff --git a/app-cdr/xcdroast/Manifest b/app-cdr/xcdroast/Manifest
index 4edd9e1ef9a7..7b5dee886157 100644
--- a/app-cdr/xcdroast/Manifest
+++ b/app-cdr/xcdroast/Manifest
@@ -2,7 +2,7 @@ MD5 3d7d3e986a0f3cfece3e389575f9387f ChangeLog 3955
MD5 af9852b249b8e0fab9bd0d55dbea4455 metadata.xml 400
MD5 a9919266035f49883684f4124186a035 xcdroast-0.98_alpha13.ebuild 1036
MD5 70ad5f1d00b2979b61744c11cb01ed20 xcdroast-0.98_alpha14-r1.ebuild 1447
-MD5 06584cd4e579535cb97c083439d97abe xcdroast-0.98_alpha14-r2.ebuild 2174
+MD5 218c86f8fb27c6304980cdf948bbed5d xcdroast-0.98_alpha14-r2.ebuild 2174
MD5 81d2a239119f3ee928aa0f3fce67529c files/digest-xcdroast-0.98_alpha14-r1 195
MD5 fd211bcdb0aa941e5ae0cea66cbbebfe files/digest-xcdroast-0.98_alpha13 73
MD5 0120b1d769ff87b3ad382bbde206bc8c files/digest-xcdroast-0.98_alpha14-r2 316
diff --git a/app-cdr/xcdroast/xcdroast-0.98_alpha14-r2.ebuild b/app-cdr/xcdroast/xcdroast-0.98_alpha14-r2.ebuild
index 4badc19ad525..6359cb417f93 100644
--- a/app-cdr/xcdroast/xcdroast-0.98_alpha14-r2.ebuild
+++ b/app-cdr/xcdroast/xcdroast-0.98_alpha14-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/xcdroast/xcdroast-0.98_alpha14-r2.ebuild,v 1.1 2003/09/04 00:17:33 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/xcdroast/xcdroast-0.98_alpha14-r2.ebuild,v 1.2 2003/09/11 02:20:50 pylon Exp $
inherit eutils
@@ -16,14 +16,13 @@ SRC_URI="mirror://sourceforge/xcdroast/${P/_/}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc"
-IUSE="nls dvd"
+IUSE="nls dvd dvdr"
DEPEND="=x11-libs/gtk+-1.2*
=dev-libs/glib-1.2*
>=media-libs/gdk-pixbuf-0.16.0
>=media-libs/giflib-3.0
- >=app-cdr/cdrtools-2.01_alpha17
- dvd? ( >=app-cdr/cdrtools-dvdr-2.0 )"
+ >=app-cdr/cdrtools-2.01_alpha17"
RDEPEND="${DEPEND}"
@@ -40,14 +39,11 @@ src_unpack() {
# Patch to fix startup problem with cdrools >=2.01alpha17
epatch ${DISTDIR}/cdrtools201a17.patch
- # Patches for DVD writing
- if use dvd; then
- # Patch to fix fixes the display of ATIP information of DVD-media.
- epatch ${DISTDIR}/dvd_atip.patch
+ # Patch to fix fixes the display of ATIP information of DVD-media.
+ use dvd && epatch ${DISTDIR}/dvd_atip.patch
- #Patch to enable DVD-Writing
- epatch ${FILESDIR}/${P/_/}-dvd.patch
- fi
+ #Patch to enable DVD-writing
+ use dvdr && epatch ${FILESDIR}/${P/_/}-dvd.patch
}
src_compile() {
@@ -71,3 +67,15 @@ src_install() {
#remove extraneous directory
rm ${D}/usr/etc -rf
}
+
+pkg_postinst() {
+ if use dvdr; then
+ echo
+ einfo "You are now using X-CD-Roast with the cdrtools patches for several"
+ einfo "DVD writers. You can also use cdrecord-ProDVD, which has to be"
+ einfo "installed manually."
+ einfo "See http://www.xcdroast.org/xcdr098/README.ProDVD.txt for further"
+ einfo "instructions."
+ echo
+ fi
+}