summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-03-06 06:05:34 +0000
committerAchim Gottinger <achim@gentoo.org>2001-03-06 06:05:34 +0000
commit5f8ec88fd90caf83853b8b5857fdf138ae75ad24 (patch)
tree3ff649abcd01e5f57a32beffa4fce1f21195d2f6 /app-arch
parent*** empty log message *** (diff)
downloadhistorical-5f8ec88fd90caf83853b8b5857fdf138ae75ad24.tar.gz
historical-5f8ec88fd90caf83853b8b5857fdf138ae75ad24.tar.bz2
historical-5f8ec88fd90caf83853b8b5857fdf138ae75ad24.zip
Updates
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/rpm/rpm-3.0.6-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-arch/rpm/rpm-3.0.6-r1.ebuild b/app-arch/rpm/rpm-3.0.6-r1.ebuild
new file mode 100644
index 000000000000..822ecbb01aee
--- /dev/null
+++ b/app-arch/rpm/rpm-3.0.6-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-3.0.6-r1.ebuild,v 1.1 2001/03/06 06:05:34 achim Exp $
+
+A="${P}.tar.gz"
+S=${WORKDIR}/${P}
+DESCRIPTION="Red Hat Package Management Utils"
+SRC_URI="ftp://ftp.rpm.org/pub/rpm/dist/rpm-3.0.x/${A}"
+HOMEPAGE="http://www.rpm.org/"
+
+DEPEND="nls? ( sys-devel/gettext )
+ sys-libs/db
+ >=sys-libs/zlib-1.1.3
+ >=sys-apps/bzip2-1.0.1"
+
+REPEND=">=sys-libs/zlib-1.1.3
+ sys-libs/db
+ sys-devel/perl"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-popt-popt.c-gentoo.diff
+ # Suppress pointer warnings
+ cp configure configure.orig
+ sed -e "s:-Wpointer-arith::" configure.orig > configure
+
+}
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+ try ./configure --prefix=/usr --mandir=/usr/share/man ${myconf}
+ try make
+}
+
+src_install() {
+
+ try make DESTDIR=${D} install
+ mv ${D}/bin/rpm ${D}/usr/bin
+ rm -rf ${D}/bin
+
+ dodoc CHANGES COPYING CREDITS GROUPS README* RPM* TODO
+}
+
+pkg_postinst() {
+
+ ${ROOT}/usr/bin/rpm --initdb --root=${ROOT}
+
+}
+
+
+