summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-06-01 00:05:46 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-06-01 00:05:46 +0000
commit7b0aa8a3cc2b8779f9601c658ee6fca2beb3247d (patch)
tree5704d1f0a521dace0391cf90d16e082cb7f0c170 /app-arch/unadf/unadf-0.7.9b.ebuild
parentFix digests for USE=kdexdeltas. (diff)
downloadhistorical-7b0aa8a3cc2b8779f9601c658ee6fca2beb3247d.tar.gz
historical-7b0aa8a3cc2b8779f9601c658ee6fca2beb3247d.tar.bz2
historical-7b0aa8a3cc2b8779f9601c658ee6fca2beb3247d.zip
Bug #61643, ebuild submitted by Jonathan Adamczewski <jadamcze@utas.edu.au>.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'app-arch/unadf/unadf-0.7.9b.ebuild')
-rw-r--r--app-arch/unadf/unadf-0.7.9b.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-arch/unadf/unadf-0.7.9b.ebuild b/app-arch/unadf/unadf-0.7.9b.ebuild
new file mode 100644
index 000000000000..1454ae2100d5
--- /dev/null
+++ b/app-arch/unadf/unadf-0.7.9b.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unadf/unadf-0.7.9b.ebuild,v 1.1 2005/06/01 00:05:46 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Extract files from Amiga adf disk images"
+SRC_URI="http://perso.club-internet.fr/lclevy/adflib/adflib.zip"
+HOMEPAGE="http://perso.club-internet.fr/lclevy/adflib/adflib.html"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unzip ${DISTDIR}/adflib.zip
+ epatch ${FILESDIR}/no.in_path.patch
+}
+
+src_compile() {
+ cd ${S}/Lib && make depend || die "make failed"
+ cd ${S}/Demo && make depend || die "make failed"
+ cd ${S} && emake lib demo || die "emake failed"
+}
+
+src_install() {
+ dobin Demo/unadf
+ dodoc README CHANGES Faq/adf_info.txt
+ docinto Docs
+ dodoc Docs/*
+ docinto Faq
+ dodoc Faq/*
+ docinto Faq/image
+ dodoc Faq/image/*
+}