summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-07-05 09:31:06 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-07-05 09:31:06 +0000
commitb9fa5f2a532fc97baef9369cfdfe64f4222dafdf (patch)
treef3bf74fc711b335f40471c025c3faede2a98bb90 /app-admin
parentFound a cleaner fix for the package (diff)
downloadhistorical-b9fa5f2a532fc97baef9369cfdfe64f4222dafdf.tar.gz
historical-b9fa5f2a532fc97baef9369cfdfe64f4222dafdf.tar.bz2
historical-b9fa5f2a532fc97baef9369cfdfe64f4222dafdf.zip
Found a cleaner fix for the package
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/cpu/Manifest4
-rw-r--r--app-admin/cpu/cpu-1.3.100-r1.ebuild51
-rw-r--r--app-admin/cpu/files/cpu-1.3.100-fixup.patch47
-rw-r--r--app-admin/cpu/files/digest-cpu-1.3.100-r11
4 files changed, 54 insertions, 49 deletions
diff --git a/app-admin/cpu/Manifest b/app-admin/cpu/Manifest
index 4b29f42931b4..4113e20f87d8 100644
--- a/app-admin/cpu/Manifest
+++ b/app-admin/cpu/Manifest
@@ -1,5 +1,5 @@
MD5 79fcd8b7fad82858088229fdd56c15a8 cpu-1.3.100.ebuild 1375
-MD5 b77c2c1dde8fef7dd8a583a3a9253fcc cpu-1.3.100-r1.ebuild 1262
-MD5 8dec3c92abeeea8ce525bdb0d084c657 ChangeLog 654
+MD5 a89ea8c1bfebf0080be4a603b2cbf427 cpu-1.3.100-r1.ebuild 1265
+MD5 a2af537b36daa2d8e4601426da66d0ae ChangeLog 654
MD5 021b5afd2ac0d086a3400da75c9ce5db files/digest-cpu-1.3.100 64
MD5 021b5afd2ac0d086a3400da75c9ce5db files/digest-cpu-1.3.100-r1 64
diff --git a/app-admin/cpu/cpu-1.3.100-r1.ebuild b/app-admin/cpu/cpu-1.3.100-r1.ebuild
new file mode 100644
index 000000000000..20339b3d3da1
--- /dev/null
+++ b/app-admin/cpu/cpu-1.3.100-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/cpu/cpu-1.3.100-r1.ebuild,v 1.1 2003/07/05 09:31:03 robbat2 Exp $
+
+DESCRIPTION="CPU is an LDAP user management tool written in C and loosely based on FreeBSD's pw(8)."
+HOMEPAGE="http://cpu.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND="net-nds/openldap
+ sys-libs/cracklib"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.54"
+
+S=${WORKDIR}/${P}
+
+WANT_AUTOCONF_2_5=1
+
+src_compile() {
+
+ if use static; then
+ MSG="Sorry, the package does NOT support static building."
+ eerror "${MSG}"
+ fi
+
+ local myconf
+
+ # provide PASSWD support as well
+ # It's broken in the application at the moment, so lets not...
+ # myconf="${myconf} --with-passwd"
+
+ # Tell it where to find LDAP
+ myconf="${myconf} --with-ldap"
+ # Tell it where to find CRACKLIB
+ myconf="${myconf} --with-libcrack"
+
+ # cache our config!
+ #myconf="${myconf} --cache-file=${S}/config.cache"
+
+ econf ${myconf} || die "Configure failure"
+
+ emake || die "Make failure"
+}
+
+src_install() {
+ einstall || die "Einstall failure"
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}
diff --git a/app-admin/cpu/files/cpu-1.3.100-fixup.patch b/app-admin/cpu/files/cpu-1.3.100-fixup.patch
deleted file mode 100644
index c0ca4d174d61..000000000000
--- a/app-admin/cpu/files/cpu-1.3.100-fixup.patch
+++ /dev/null
@@ -1,47 +0,0 @@
---- cpu-1.3.100.orig/configure.ac 2003-07-05 01:23:05.000000000 -0700
-+++ cpu-1.3.100/configure.ac 2003-07-05 01:24:27.000000000 -0700
-@@ -63,7 +63,7 @@
- AC_MSG_CHECKING(whether to compile with debugging malloc)
- AC_ARG_WITH(dmalloc,
- [ --with-dmalloc Debug using dmalloc (default is no)],
-- [AC_MSG_RESULT("$with_dmalloc")
-+ [AC_MSG_RESULT($with_dmalloc)
- AC_CHECK_LIB(dmalloc, dmalloc_debug)],
- [AC_MSG_RESULT(no)]
- )
-@@ -71,7 +71,7 @@
- AC_MSG_CHECKING(whether builder is a developer)
- AC_ARG_WITH(developer,
- [ --with-developer Developers should use this],
-- [AC_MSG_RESULT("$with_developer")
-+ [AC_MSG_RESULT($with_developer)
- AC_DEFINE_UNQUOTED(DEVELOPER, 1, [Are you in?])],
- [AC_MSG_RESULT(no)]
- )
-@@ -79,7 +79,7 @@
- AC_MSG_CHECKING(whether to compile with cracklib)
- AC_ARG_WITH(libcrack,
- [ --with-libcrack=Prefix Try to use libcrack],
-- [AC_MSG_RESULT("$with_libcrack")
-+ [AC_MSG_RESULT($with_libcrack)
- AC_CHECK_LIB(crack, FascistCheck)
- AC_CHECK_HEADERS(crack.h,,AC_MSG_ERROR(Could not find crack.h))],
- [AC_MSG_RESULT(no)]
-@@ -88,7 +88,7 @@
- AC_MSG_CHECKING(where ldap development files are)
- AC_ARG_WITH(ldap,
- [ --with-ldap=Prefix Base of ldap files],
-- [AC_MSG_RESULT("$with_ldap")
-+ [AC_MSG_RESULT($with_ldap)
- if test "$with_ldap" != "yes"; then
- LDFLAGS="$LDFLAGS -L$with_ldap/lib"
- CPPFLAGS="$CPPFLAGS -I$with_ldap/include"
-@@ -104,7 +104,7 @@
- AC_MSG_CHECKING(whether to build passwd plugin)
- AC_ARG_WITH(passwd,
- [ --with-passwd Compile passwd plugin],
-- [AC_MSG_RESULT("$with_passwd")],
-+ [AC_MSG_RESULT($with_passwd)],
- [AC_MSG_RESULT(no)
- without_passwd=true]
- )
diff --git a/app-admin/cpu/files/digest-cpu-1.3.100-r1 b/app-admin/cpu/files/digest-cpu-1.3.100-r1
new file mode 100644
index 000000000000..f404819397a9
--- /dev/null
+++ b/app-admin/cpu/files/digest-cpu-1.3.100-r1
@@ -0,0 +1 @@
+MD5 c3edaade7f975779b40ae80e40fccb98 cpu-1.3.100.tar.bz2 214614