summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2006-06-23 19:10:28 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2006-06-23 19:10:28 +0000
commit72e8c5da5d7ffd05de86c92d7009209229ae02e7 (patch)
treea0741d12cd6fce2817b2dbff0a107dbeed50f83a /app-admin
parentRevbump (diff)
downloadhistorical-72e8c5da5d7ffd05de86c92d7009209229ae02e7.tar.gz
historical-72e8c5da5d7ffd05de86c92d7009209229ae02e7.tar.bz2
historical-72e8c5da5d7ffd05de86c92d7009209229ae02e7.zip
Version Bump.
Package-Manager: portage-2.1.1_pre1-r1
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/usermin/ChangeLog8
-rw-r--r--app-admin/usermin/files/digest-usermin-1.2103
-rw-r--r--app-admin/usermin/usermin-1.210.ebuild90
-rw-r--r--app-admin/webmin/files/digest-webmin-1.2809
-rw-r--r--app-admin/webmin/webmin-1.280.ebuild146
5 files changed, 255 insertions, 1 deletions
diff --git a/app-admin/usermin/ChangeLog b/app-admin/usermin/ChangeLog
index b44c7e745eee..73f373f3da4a 100644
--- a/app-admin/usermin/ChangeLog
+++ b/app-admin/usermin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/usermin
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/usermin/ChangeLog,v 1.87 2006/06/09 06:45:33 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/usermin/ChangeLog,v 1.88 2006/06/23 19:10:28 eradicator Exp $
+
+*usermin-1.210 (23 Jun 2006)
+
+ 23 Jun 2006; Jeremy Huddleston <eradicator@gentoo.org>
+ +usermin-1.210.ebuild:
+ Version Bump.
09 Jun 2006; Jeremy Huddleston <eradicator@gentoo.org>
usermin-1.200.ebuild:
diff --git a/app-admin/usermin/files/digest-usermin-1.210 b/app-admin/usermin/files/digest-usermin-1.210
new file mode 100644
index 000000000000..99a1fb365560
--- /dev/null
+++ b/app-admin/usermin/files/digest-usermin-1.210
@@ -0,0 +1,3 @@
+MD5 4ed6b8458058c861d3e95566d88d5c92 usermin-1.210.tar.gz 3153595
+RMD160 793efc49ea9947a0a66a42e997550f3bfa8ea5bc usermin-1.210.tar.gz 3153595
+SHA256 3c14b8ab975bc8639dc4ff2db2b2108b42c852edf39ae311c182c8a02c7abf5f usermin-1.210.tar.gz 3153595
diff --git a/app-admin/usermin/usermin-1.210.ebuild b/app-admin/usermin/usermin-1.210.ebuild
new file mode 100644
index 000000000000..e49082561cb4
--- /dev/null
+++ b/app-admin/usermin/usermin-1.210.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/usermin/usermin-1.210.ebuild,v 1.1 2006/06/23 19:10:28 eradicator Exp $
+
+IUSE="ssl"
+
+inherit eutils pam
+
+DESCRIPTION="a web-based user administration interface"
+HOMEPAGE="http://www.webmin.com/index6.html"
+SRC_URI="mirror://sourceforge/webadmin/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~hppa ~ppc ppc64 sparc ~x86"
+
+DEPEND="dev-lang/perl"
+
+RDEPEND="${DEPEND}
+ sys-process/lsof
+ ssl? ( dev-perl/Net-SSLeay )"
+
+# pam? ( dev-perl/Authen-PAM )
+
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ # Point to the correct mysql location
+ sed -i -e "s:/usr/local/mysql:/usr:g" mysql/config
+
+ epatch ${FILESDIR}/${PN}-1.080-safestop.patch
+ epatch ${FILESDIR}/${PN}-1.150-setup-nocheck.patch
+}
+
+src_install() {
+ # Change /usr/local/bin/perl references
+ find . -type f | xargs sed -i -e 's:^#!.*/usr/local/bin/perl:#!/usr/bin/perl:'
+
+ dodir /usr/libexec/usermin
+ cp -pR * ${D}/usr/libexec/usermin
+
+ newinitd ${FILESDIR}/init.d.usermin usermin
+
+ newpamd ${FILESDIR}/${PN}.pam-include ${PN}
+
+ # Fix ownership
+ chown -R root:0 ${D}
+
+ dodir /etc/usermin
+ dodir /var/log/usermin
+
+ config_dir=${D}/etc/usermin
+ var_dir=${D}/var/log/usermin
+ perl=${ROOT}/usr/bin/perl
+ autoos=1
+ port=20000
+ login=root
+ crypt="XXX"
+ host=`hostname`
+ use ssl && ssl=1 || ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ tempdir="${T}"
+ export config_dir var_dir perl autoos port login crypt host ssl atboot nostart nochown autothird nouninstall noperlpath tempdir
+ ${D}/usr/libexec/usermin/setup.sh > ${T}/usermin-setup.out 2>&1 || die "Failed to create initial usermin configuration."
+
+ # Fixup the config files to use their real locations
+ sed -i -e "s:^pidfile=.*$:pidfile=${ROOT}/var/run/usermin.pid:" ${D}/etc/usermin/miniserv.conf
+ find ${D}/etc/usermin -type f | xargs sed -i -e "s:${D}:${ROOT}:g"
+
+ # Cleanup from the config script
+ rm -rf ${D}/var/log/usermin
+ keepdir /var/log/usermin/
+}
+
+pkg_postinst() {
+ einfo "To make usermin start at boot time, run: 'rc-update add usermin default'."
+ einfo "Point your web browser to http://localhost:20000 to use usermin."
+}
+
+pkg_prerm() {
+ ${ROOT}/etc/init.d/usermin stop >& /dev/null
+}
diff --git a/app-admin/webmin/files/digest-webmin-1.280 b/app-admin/webmin/files/digest-webmin-1.280
new file mode 100644
index 000000000000..2dfe29140149
--- /dev/null
+++ b/app-admin/webmin/files/digest-webmin-1.280
@@ -0,0 +1,9 @@
+MD5 aa7274ebecc8d0df6704546ed13709d6 virtual-server-2.611.wbm.gz 283217
+RMD160 bbcee33f9398a78d7e8a68168316f011d2cf391d virtual-server-2.611.wbm.gz 283217
+SHA256 f7579da94a6b356ce4548a0ed8fcc366e1d8e7e7199e5337e8d703bf4f92090a virtual-server-2.611.wbm.gz 283217
+MD5 499a0b1c11187c3b4847f690a0af515f webmin-1.280-minimal.tar.gz 1396687
+RMD160 08cd7b50952e89f92a8356afd1a03ac308406e9c webmin-1.280-minimal.tar.gz 1396687
+SHA256 f142062dc1c71120593333d20487fd9356d5326ae7e2f0cdf384eb2025e22e7a webmin-1.280-minimal.tar.gz 1396687
+MD5 3f218921457341be0d49c99f7ab83ae4 webmin-1.280.tar.gz 10299513
+RMD160 de915cfca7b9fa7c0eb0e3c060434273f4963ae6 webmin-1.280.tar.gz 10299513
+SHA256 b6d911dca8dcbbdcf5d650b14f9c5ea04a279aa48ae54b4c20e023fda462fd78 webmin-1.280.tar.gz 10299513
diff --git a/app-admin/webmin/webmin-1.280.ebuild b/app-admin/webmin/webmin-1.280.ebuild
new file mode 100644
index 000000000000..0ba6a7376b06
--- /dev/null
+++ b/app-admin/webmin/webmin-1.280.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/webmin-1.280.ebuild,v 1.1 2006/06/23 19:09:43 eradicator Exp $
+
+IUSE="apache2 postgres ssl webmin-minimal"
+
+inherit eutils pam
+
+VM_V="2.611"
+
+DESCRIPTION="Webmin, a web-based system administration interface"
+HOMEPAGE="http://www.webmin.com/"
+SRC_URI="webmin-minimal? ( mirror://sourceforge/webadmin/${P}-minimal.tar.gz )
+ !webmin-minimal? ( mirror://sourceforge/webadmin/${P}.tar.gz
+ http://www.webmin.com/download/virtualmin/virtual-server-${VM_V}.wbm.gz )"
+
+LICENSE="BSD"
+SLOT="0"
+
+# ~mips removed because of broken deps. Bug #86085
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ ssl? ( dev-perl/Net-SSLeay )
+ postgres? ( dev-perl/DBD-Pg )
+ dev-perl/XML-Generator"
+
+# See bug #62123
+# pam? ( dev-perl/Authen-PAM )
+
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ # in webmin-minimal apache2 are not present
+ if ! use webmin-minimal ; then
+ # Bug #50810, #51943
+ if use apache2; then
+ epatch ${FILESDIR}/${PN}-1.140-apache2.patch
+ fi
+
+ # Correct ldapness
+ epatch ${FILESDIR}/${PN}-1.270-ldap-useradmin.patch
+
+ # Postfix should modify the last entry of the maps file
+ epatch ${FILESDIR}/${PN}-1.170-postfix.patch
+
+ mv ${WORKDIR}/virtual-server-${VM_V}.wbm ${T}/vs.tar
+ tar -xf ${T}/vs.tar
+
+ # Don't create ${HOME}/cgi-bin on new accounts
+ epatch ${FILESDIR}/virtual-server-2.60-nocgibin.patch
+
+ # Check if a newly added IP is already active
+ epatch ${FILESDIR}/virtual-server-2.610-checkip.patch
+
+ # Verify Postgres usernames
+ epatch ${FILESDIR}/virtual-server-2.31-pgsql.patch
+
+ # Fix some all name virtual items
+ epatch ${FILESDIR}/virtual-server-2.31-namevirtual.patch
+ fi
+
+ epatch ${FILESDIR}/${PN}-1.170-setup-nocheck.patch
+}
+
+src_install() {
+ # Bug #97212
+ addpredict /var/lib/rpm
+
+ rm -f mount/freebsd-mounts*
+ rm -f mount/openbsd-mounts*
+ rm -f mount/macos-mounts*
+
+ (find . -name '*.cgi' ; find . -name '*.pl') | perl perlpath.pl /usr/bin/perl -
+ dodir /usr/libexec/webmin
+ dodir /var
+
+ cp -rp * ${D}/usr/libexec/webmin
+
+ # in webmin-minimal openslp is not present
+ if [ ! -f "${D}/usr/libexec/webmin/openslp/config-gentoo-linux" ] ; then
+ cp ${D}/usr/libexec/webmin/openslp/config \
+ ${D}/usr/libexec/webmin/openslp/config-gentoo-linux
+ fi
+
+ newinitd ${FILESDIR}/init.d.webmin webmin
+
+ newpamd ${FILESDIR}/webmin-pam webmin
+ echo gentoo > ${D}/usr/libexec/webmin/install-type
+
+ # Fix ownership
+ chown -R root:0 ${D}
+
+ dodir /etc/webmin
+ dodir /var/log/webmin
+
+ config_dir=${D}/etc/webmin
+ var_dir=${D}/var/log/webmin
+ perl=${ROOT}/usr/bin/perl
+ autoos=1
+ port=10000
+ login=root
+ crypt="XXX"
+ host=`hostname`
+ use ssl && ssl=1 || ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ tempdir="${T}"
+ export config_dir var_dir perl autoos port login crypt host ssl atboot nostart nochown autothird nouninstall noperlpath tempdir
+ ${D}/usr/libexec/webmin/setup.sh > ${T}/webmin-setup.out 2>&1 || die "Failed to create initial webmin configuration."
+
+ # Fixup the config files to use their real locations
+ sed -i -e "s:^pidfile=.*$:pidfile=${ROOT}/var/run/webmin.pid:" ${D}/etc/webmin/miniserv.conf
+ find ${D}/etc/webmin -type f | xargs sed -i -e "s:${D}:${ROOT}:g"
+
+ # Cleanup from the config script
+ rm -rf ${D}/var/log/webmin
+ keepdir /var/log/webmin/
+
+ # Get rid of this crap...
+ rm -rf ${D}/usr/libexec/webmin/acl/Authen-SolarisRBAC-0.1
+ rm -f ${D}/usr/libexec/webmin/acl/Authen-SolarisRBAC-0.1.tar.gz
+}
+
+pkg_postinst() {
+ local crypt=$(grep "^root:" ${ROOT}/etc/shadow | cut -f 2 -d :)
+ crypt=${crypt//\\/\\\\}
+ crypt=${crypt//\//\\\/}
+ sed -i -e "s/root:XXX/root:${crypt}/" /etc/webmin/miniserv.users
+
+ einfo "To make webmin start at boot time, run: 'rc-update add webmin default'."
+ use ssl && einfo "Point your web browser to https://localhost:10000 to use webmin."
+ use ssl || einfo "Point your web browser to http://localhost:10000 to use webmin."
+}
+
+pkg_prerm() {
+ ${ROOT}/etc/init.d/webmin stop >& /dev/null
+}