summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2010-07-03 12:36:13 +0000
committerBenedikt Boehm <hollow@gentoo.org>2010-07-03 12:36:13 +0000
commit4fb0dc3f61ce62cfc5e8731367faf58ac76f77ee (patch)
tree860036e181c4b65a06e98f472d7c951442416f38 /app-admin
parentinitial ebuild, thanks to Gábor Vészi (diff)
downloadhistorical-4fb0dc3f61ce62cfc5e8731367faf58ac76f77ee.tar.gz
historical-4fb0dc3f61ce62cfc5e8731367faf58ac76f77ee.tar.bz2
historical-4fb0dc3f61ce62cfc5e8731367faf58ac76f77ee.zip
initial ebuild, thanks to Gábor Vészi
Package-Manager: portage-2.2_rc67/cvs/Linux i686
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/chef/ChangeLog11
-rw-r--r--app-admin/chef/Manifest8
-rw-r--r--app-admin/chef/chef-0.9.6.ebuild54
-rw-r--r--app-admin/chef/files/client.rb65
-rw-r--r--app-admin/chef/files/confd/chef-client19
-rw-r--r--app-admin/chef/files/initd/chef-client27
-rw-r--r--app-admin/chef/files/solo.rb49
-rw-r--r--app-admin/chef/metadata.xml10
8 files changed, 243 insertions, 0 deletions
diff --git a/app-admin/chef/ChangeLog b/app-admin/chef/ChangeLog
new file mode 100644
index 000000000000..36b40051feb2
--- /dev/null
+++ b/app-admin/chef/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-admin/chef
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chef/ChangeLog,v 1.1 2010/07/03 12:36:12 hollow Exp $
+
+*chef-0.9.6 (03 Jul 2010)
+
+ 03 Jul 2010; Benedikt Böhm <hollow@gentoo.org> +chef-0.9.6.ebuild,
+ +files/client.rb, +files/confd/chef-client, +files/initd/chef-client,
+ +files/solo.rb, +metadata.xml:
+ initial ebuild, thanks to Gábor Vészi
+
diff --git a/app-admin/chef/Manifest b/app-admin/chef/Manifest
new file mode 100644
index 000000000000..ee7c846f0238
--- /dev/null
+++ b/app-admin/chef/Manifest
@@ -0,0 +1,8 @@
+AUX client.rb 2491 RMD160 7f3ab27743edaab3c279a67d1f967634bd823c28 SHA1 edc62d53058d803ff37dab7117f12c72aea3a75f SHA256 12fd8d9f944da3cc902acb0b8aee5a13202b8f7edd107d72db219b7349bc46ff
+AUX confd/chef-client 477 RMD160 fee00784183c89eba72978a9cd8a7ed0a7229a6b SHA1 1d179065b3bd69cd7fc81a20ee05fb03c097a98b SHA256 87ae3fc931df89fc890d1b976c9596a078780ecf95c1fac4f08cad08f8e89a90
+AUX initd/chef-client 726 RMD160 8a1876428591e93fce814883fb07016b0a78d31f SHA1 6824a6028db843f393032122ae9da57ba72d9ddb SHA256 c5e47f3a9a4528746f9217a17c04e6ab8d7bec2e669bf020025158d19a483d1b
+AUX solo.rb 2023 RMD160 5c60853cf40f3b3565618b8d074814efb0f2e408 SHA1 8cfc5e67e427252c26ebf4c04b504a8a4845d1c7 SHA256 48e1863e4cbcdbf935ea4c9e29514c825c04ff35d68cb6bf8b8f246cd4b6a815
+DIST chef-0.9.6.gem 216064 RMD160 706c55cc043f2be01bcefe643bad5d647c22efb3 SHA1 15fd1245a587cdfb9d2223bfdf2e047a97d34417 SHA256 db676545f35c8b703dc97cee82c05e3604f250d66e0100d6a2a3aaa42a70416c
+EBUILD chef-0.9.6.ebuild 1267 RMD160 3ccad20e4a3cbfa77d2fa7d60c39c6ba1e707a8f SHA1 182b5a914144e7d8798ad457d993f7e0c77f5e92 SHA256 27d6129c1c9452237594de07cfb51d875cbc2018d71a54dd90caa388afe215e3
+MISC ChangeLog 446 RMD160 ebceb983259d419fdbb614443d48a4c0f119302b SHA1 bb8359472ffc3554884780c67638a51d2f9d4ded SHA256 871c585a09912665b2394a47680fc876aaeaedb95dc7f348d152f5ee726fac0f
+MISC metadata.xml 256 RMD160 d9b3d76f0f3b12500bf0a1e012563f2f32f4992f SHA1 2520f467b4a64d131a92dd8101e03ad334d6d7a6 SHA256 74f2c9d6b7ef600697deed6d19bc64604a39ba7a2e8c24fae47ca2544def84c0
diff --git a/app-admin/chef/chef-0.9.6.ebuild b/app-admin/chef/chef-0.9.6.ebuild
new file mode 100644
index 000000000000..52c77ef298aa
--- /dev/null
+++ b/app-admin/chef/chef-0.9.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chef/chef-0.9.6.ebuild,v 1.1 2010/07/03 12:36:12 hollow Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Chef is a systems integration framework"
+HOMEPAGE="http://wiki.opscode.com/display/chef"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/bunny-0.6.0
+ dev-ruby/erubis
+ dev-ruby/extlib
+ dev-ruby/highline
+ <=dev-ruby/json-1.4.2
+ >=dev-ruby/mixlib-authentication-1.1.0
+ >=dev-ruby/mixlib-cli-1.1.0
+ >=dev-ruby/mixlib-config-1.1.0
+ >=dev-ruby/mixlib-log-1.1.0
+ dev-ruby/moneta
+ >=dev-ruby/ohai-0.5.0
+ >=dev-ruby/rest-client-1.0.4
+ <=dev-ruby/rest-client-1.5.1
+ dev-ruby/uuidtools"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ keepdir /etc/chef /var/lib/chef /var/log/chef /var/run/chef
+
+ doinitd "${FILESDIR}/initd/chef-client"
+ doconfd "${FILESDIR}/confd/chef-client"
+
+ insinto /etc/chef
+ doins "${FILESDIR}/client.rb"
+ doins "${FILESDIR}/solo.rb"
+}
+
+pkg_postinst() {
+ elog
+ elog "You should edit /etc/chef/client.rb before starting the service with"
+ elog "/etc/init.d/chef-client start"
+ elog
+}
diff --git a/app-admin/chef/files/client.rb b/app-admin/chef/files/client.rb
new file mode 100644
index 000000000000..a32a9c931636
--- /dev/null
+++ b/app-admin/chef/files/client.rb
@@ -0,0 +1,65 @@
+# Configuration File For Chef (chef-client)
+#
+# The chef-client program will connect the local system to the specified
+# server URLs through a RESTful API to retrieve its configuration.
+#
+# By default, the client is configured to connect to a Chef Server
+# running on the local system. Change this to reflect your environment.
+#
+# Chef uses a Ruby DSL for configuration, and this file contains a few
+# Ruby idioms. First, symbols. These are designated by a colon sigil, ie,
+# :value. Second, in Ruby, everything but false and nil (no quotes or other
+# designations) is true, including true, the integer 0 and the string "false".
+# So to set the value of a setting to false, write:
+#
+# some_setting false
+#
+# Third, Ruby class methods can be used, for example we tell the log to show
+# the current time stamp with Chef::Log::Formatter.show_time, below.
+#
+# log_level specifies the level of verbosity for output.
+# valid values are: :debug, :info, :warn, :error, :fatal
+
+log_level :info
+
+# log_location specifies where the client should log to.
+# valid values are: a quoted string specifying a file, or STDOUT with
+# no quotes. When run as a daemon (default), STDOUT will produce no output.
+
+log_location "/var/log/chef/client.log"
+
+# ssl_verify_mode specifies if the REST client should verify SSL certificates.
+# valid values are :verify_none, :verify_peer. The default Chef Server
+# installation will use a self-generated SSL certificate so this should be
+# :verify_none unless you replace the certificate.
+
+ssl_verify_mode :verify_none
+
+# Server URLs.
+#
+# chef_server_url specifies the Chef Server to connect to.
+# valid values are any HTTP URL (e.g. https://chef.example.com:4443).
+
+chef_server_url "http://localhost:4000"
+
+# file_cache_path specifies where the client should cache cookbooks, server
+# cookie ID, and openid registration data.
+# valid value is any filesystem directory location.
+
+file_cache_path "/var/lib/chef/cache"
+
+file_backup_path "/var/lib/chef/backup"
+
+# pid_file specifies the location of where chef-client daemon should keep the pid
+# file.
+# valid value is any filesystem file location.
+
+pid_file "/var/run/chef/client.pid"
+
+# Mixlib::Log::Formatter.show_time specifies whether the chef-client
+# log should contain timestamps. valid values are true or false (no
+# quotes, see above about Ruby idioms). The printed timestamp is
+# rfc2822, for example:
+# Fri, 31 Jul 2009 19:19:46 -0600
+
+Mixlib::Log::Formatter.show_time = true
diff --git a/app-admin/chef/files/confd/chef-client b/app-admin/chef/files/confd/chef-client
new file mode 100644
index 000000000000..b32d70f88736
--- /dev/null
+++ b/app-admin/chef/files/confd/chef-client
@@ -0,0 +1,19 @@
+# /etc/conf.d/chef-client: config file for /etc/init.d/chef-client
+
+# The configuration file to use.
+#CONFIGFILE="/etc/chef/client.rb"
+
+# Run chef-client periodically, in seconds.
+#INTERVAL=1800
+
+# The splay time for running at intervals, in seconds.
+#SPLAY=20
+
+# Any radom options you want to pass to chef.
+#CHEF_CLIENT_OPTS=""
+
+# Path to the chef client binary.
+#CHEF_CLIENT_BINARY="/usr/bin/chef-client"
+
+# PID file location.
+#CHEF_CLIENT_PIDFILE="/var/run/chef/client.pid"
diff --git a/app-admin/chef/files/initd/chef-client b/app-admin/chef/files/initd/chef-client
new file mode 100644
index 000000000000..4c50564abf5b
--- /dev/null
+++ b/app-admin/chef/files/initd/chef-client
@@ -0,0 +1,27 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+CHEF_CLIENT_BINARY=${CHEF_CLIENT_BINARY:-/usr/bin/chef-client}
+CHEF_CLIENT_PIDFILE=${CHEF_CLIENT_PIDFILE:-/var/run/chef/client.pid}
+CONFIGFILE=${CONFIGFILE:-/etc/chef/client.rb}
+INTERVAL=${INTERVAL:-1800}
+SPLAY=${SPLAY:-20}
+
+start() {
+ ebegin "Starting Chef client"
+ start-stop-daemon --start --quiet --pidfile ${CHEF_CLIENT_PIDFILE} \
+ --exec ${CHEF_CLIENT_BINARY} -- -d -c ${CONFIGFILE} \
+ -i ${INTERVAL} -s ${SPLAY} ${CHEF_CLIENT_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Shutting down Chef client"
+ start-stop-daemon --stop --quiet --pidfile ${CHEF_CLIENT_PIDFILE}
+ eend $?
+}
diff --git a/app-admin/chef/files/solo.rb b/app-admin/chef/files/solo.rb
new file mode 100644
index 000000000000..250dd393ca2e
--- /dev/null
+++ b/app-admin/chef/files/solo.rb
@@ -0,0 +1,49 @@
+# Configuration File For Chef Solo (chef-solo)
+#
+# The program chef-solo allows you to run Chef as a standalone program
+# without connecting to a remote Chef Server.
+#
+# Chef uses a Ruby DSL for configuration, and this file may contain some
+# Ruby idioms. First, symbols. These are designated by a colon sigil, ie,
+# :value. Second, in Ruby, everything but false and nil (no quotes or other
+# designations) is true, including true, the integer 0 and the string "false".
+# So to set the value of a setting to false, write:
+#
+# some_setting false
+#
+# Third, Ruby class methods can be used, for example we tell the log to show
+# the current time stamp with Mixlib::Log::Formatter.show_time, below.
+#
+# log_level specifies the level of verbosity for output.
+# valid values are: :debug, :info, :warn, :error, :fatal
+
+log_level :info
+
+# log_location specifies where the client should log to.
+# valid values are: a quoted string specifying a file, or STDOUT with
+# no quotes.
+
+log_location "/var/log/chef/solo.log"
+
+# file_cache_path specifies where solo should look for the cookbooks to use
+# valid value is any filesystem directory location. This is slightly
+# different from 'normal' client mode as solo is actually downloading (or
+# using) the specified cookbooks in this location.
+
+file_cache_path "/var/lib/chef"
+
+# cookbook_path specifies where solo should look for cookbooks it will use.
+# valid value is a string, or array of strings of filesystem directory locations.
+# This setting is similar to the server setting of the same name. Solo will use
+# this as a search location, in Array order. It should be a subdirectory of
+# file_cache_path, above.
+
+cookbook_path [ "/var/lib/chef/cookbooks" ]
+
+# Mixlib::Log::Formatter.show_time specifies whether the chef-client log should
+# contain timestamps.
+# valid values are true or false (no quotes, see above about Ruby idioms). The
+# printed timestamp is rfc2822, for example:
+# Fri, 31 Jul 2009 19:19:46 -0600
+
+Mixlib::Log::Formatter.show_time = true
diff --git a/app-admin/chef/metadata.xml b/app-admin/chef/metadata.xml
new file mode 100644
index 000000000000..b263a5bc4f28
--- /dev/null
+++ b/app-admin/chef/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>hollow@gentoo.org</email>
+ <name>Benedikt Böhm</name>
+ </maintainer>
+</pkgmetadata>
+