summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-05-01 14:15:25 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-05-01 14:15:25 +0000
commit5d1a99290188586b6f1554f58bd57c0ddeed92cf (patch)
tree4bd03972b7c43596fc8cdab044f36cf7c6d503de /app-admin/torsmo/torsmo-0.18-r3.ebuild
parentPurge old versions (diff)
downloadhistorical-5d1a99290188586b6f1554f58bd57c0ddeed92cf.tar.gz
historical-5d1a99290188586b6f1554f58bd57c0ddeed92cf.tar.bz2
historical-5d1a99290188586b6f1554f58bd57c0ddeed92cf.zip
Added Seti support as per bug #85633.
Package-Manager: portage-2.0.51.20-r5
Diffstat (limited to 'app-admin/torsmo/torsmo-0.18-r3.ebuild')
-rw-r--r--app-admin/torsmo/torsmo-0.18-r3.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/app-admin/torsmo/torsmo-0.18-r3.ebuild b/app-admin/torsmo/torsmo-0.18-r3.ebuild
index eccb1c3fc8e7..3293df5cc42b 100644
--- a/app-admin/torsmo/torsmo-0.18-r3.ebuild
+++ b/app-admin/torsmo/torsmo-0.18-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/torsmo/torsmo-0.18-r3.ebuild,v 1.1 2005/02/28 07:46:36 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/torsmo/torsmo-0.18-r3.ebuild,v 1.2 2005/05/01 14:15:25 dragonheart Exp $
inherit eutils
@@ -11,12 +11,15 @@ SRC_URI="mirror://sourceforge/torsmo/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
-IUSE="truetype"
+IUSE="truetype seti"
RDEPEND="virtual/libc
virtual/x11
- truetype? ( >=media-libs/freetype-2*)"
-DEPEND="${RDEPEND}
+ truetype? ( >=media-libs/freetype-2*)
+ seti? ( sci-astronomy/setiathome )"
+
+DEPEND="truetype? ( >=media-libs/freetype-2*)
+ virtual/x11
>=sys-devel/automake-1.4
sys-devel/autoconf
sys-apps/grep
@@ -33,6 +36,7 @@ src_unpack() {
src_compile() {
econf \
`use_enable truetype xft` \
+ `use_enable seti` \
--x-libraries=/usr/X11R6/lib/ || die "econf failed"
emake || die "compile failed"
}