summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-05-06 05:04:04 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-05-06 05:04:04 +0000
commit1309ce12d03b926aa9c477dee859dd609e1fc2cc (patch)
treee0582eb1c7181c4970d0d3599eb0d25de2f49fbc /app-admin/autopsy
parentclean older version (diff)
downloadhistorical-1309ce12d03b926aa9c477dee859dd609e1fc2cc.tar.gz
historical-1309ce12d03b926aa9c477dee859dd609e1fc2cc.tar.bz2
historical-1309ce12d03b926aa9c477dee859dd609e1fc2cc.zip
Inital import thanks to Daniel Fullmer in bug #47096
Diffstat (limited to 'app-admin/autopsy')
-rw-r--r--app-admin/autopsy/ChangeLog10
-rw-r--r--app-admin/autopsy/Manifest3
-rw-r--r--app-admin/autopsy/autopsy-2.00.ebuild53
-rw-r--r--app-admin/autopsy/files/autopsy.pl28
-rw-r--r--app-admin/autopsy/files/digest-autopsy-2.001
-rw-r--r--app-admin/autopsy/metadata.xml12
6 files changed, 107 insertions, 0 deletions
diff --git a/app-admin/autopsy/ChangeLog b/app-admin/autopsy/ChangeLog
new file mode 100644
index 000000000000..417593c57f3e
--- /dev/null
+++ b/app-admin/autopsy/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-admin/autopsy
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/autopsy/ChangeLog,v 1.1 2004/05/06 05:04:04 dragonheart Exp $
+
+*autopsy-2.00 (06 May 2004)
+
+ 06 May 2004; Daniel Black <dragonheart@gentoo.org> +metadata.xml,
+ +autopsy-2.00.ebuild:
+ Inital import thanks to Daniel Fullmer in bug #47097
+
diff --git a/app-admin/autopsy/Manifest b/app-admin/autopsy/Manifest
new file mode 100644
index 000000000000..04e84b33d7f6
--- /dev/null
+++ b/app-admin/autopsy/Manifest
@@ -0,0 +1,3 @@
+MD5 a19eb27570781e8638d19e9876ed1a01 autopsy-2.00.ebuild 1113
+MD5 c05a3215316f445eab678356bd2c3327 files/digest-autopsy-2.00 64
+MD5 7acbb37db527316691b7d21cb904a0ae files/autopsy.pl 663
diff --git a/app-admin/autopsy/autopsy-2.00.ebuild b/app-admin/autopsy/autopsy-2.00.ebuild
new file mode 100644
index 000000000000..88e07b4de8c0
--- /dev/null
+++ b/app-admin/autopsy/autopsy-2.00.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/autopsy/autopsy-2.00.ebuild,v 1.1 2004/05/06 05:04:04 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="A graphical interface to the digital forensic analysis tools in The Sleuth Kit."
+SRC_URI="mirror://sourceforge/autopsy/${P}.tar.gz"
+HOMEPAGE="http://www.sleuthkit.org/autopsy/"
+RESTRICT="nomirror"
+
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="dev-lang/perl
+ app-admin/sleuthkit
+ sys-apps/grep"
+
+DEPEND="dev-lang/perl
+ app-admin/sleuthkit
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ echo "#!/usr/bin/perl -wT" > autopsy
+ echo "use lib '/usr/lib/autopsy/';" >> autopsy
+ echo "use lib '/usr/lib/autopsy/lib/';" >> autopsy
+ cat base/autopsy.base >> autopsy
+ sed -i 's:conf.pl:/etc/autopsy.pl:' autopsy lib/Main.pm
+}
+
+src_install() {
+ insinto /usr/lib/autopsy
+ doins autopsy
+ insinto /usr/lib/autopsy/help
+ doins help/*
+ insinto /usr/lib/autopsy/lib
+ doins lib/*
+ insinto /usr/lib/autopsy/pict
+ doins pict/*
+ insinto /etc
+ doins ${FILESDIR}/autopsy.pl
+
+ dodir /usr/bin
+ dosym /usr/lib/autopsy/autopsy /usr/bin/autopsy
+ fperms +x /usr/lib/autopsy/autopsy
+
+ doman man/man1/autopsy.1
+ dodoc CHANGES.txt README.txt TODO.txt docs/sleuthkit-informer-13.txt
+}
diff --git a/app-admin/autopsy/files/autopsy.pl b/app-admin/autopsy/files/autopsy.pl
new file mode 100644
index 000000000000..40bc343153f2
--- /dev/null
+++ b/app-admin/autopsy/files/autopsy.pl
@@ -0,0 +1,28 @@
+# Autopsy configuration settings
+
+# when set to 1, the server will stop after it receives no
+# connections for STIMEOUT seconds.
+$USE_STIMEOUT = 0;
+$STIMEOUT = 3600;
+
+# number of seconds that child waits for input from client
+$CTIMEOUT = 15;
+
+# set to 1 to save the cookie value in a file (for scripting)
+$SAVE_COOKIE = 1;
+
+$INSTALLDIR = '/usr/lib/autopsy';
+
+# System Utilities
+$STRINGS_EXE = '/usr/bin/strings';
+$GREP_EXE = '/bin/grep';
+
+# Directories
+# Where sleuthkit is installed (leave this alone)
+$TSKDIR = '/usr/bin/';
+
+# National Software Reference Library (NSRL) Database
+$NSRLDB = '';
+
+# Evidence Locker (where autopsy stores stuff)
+$LOCKDIR = '/tmp';
diff --git a/app-admin/autopsy/files/digest-autopsy-2.00 b/app-admin/autopsy/files/digest-autopsy-2.00
new file mode 100644
index 000000000000..98c7c3180e52
--- /dev/null
+++ b/app-admin/autopsy/files/digest-autopsy-2.00
@@ -0,0 +1 @@
+MD5 73873b4af937cf11354f681b0c269f50 autopsy-2.00.tar.gz 341772
diff --git a/app-admin/autopsy/metadata.xml b/app-admin/autopsy/metadata.xml
new file mode 100644
index 000000000000..b9fc2b9c6f11
--- /dev/null
+++ b/app-admin/autopsy/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>dragonheart@gentoo.org</email>
+ <name>Daniel Black</name>
+ <description>A user ebuild that I felt obliged to include. Please take over if you want
+it</description>
+</maintainer>
+<longdescription></longdescription>
+</pkgmetadata>