summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alberto Suarez Lopez <bass@gentoo.org>2003-06-19 15:55:33 +0000
committerJose Alberto Suarez Lopez <bass@gentoo.org>2003-06-19 15:55:33 +0000
commitf00f29be299c4fbc65e2d5b6e5a7d811d5bf2333 (patch)
tree5994e4ddcdb244f4ae4488979aba765df3396b33
parentmarking latest (1.4) as stable for x86 and as ~ppc and ~sparc for testing (diff)
downloadhistorical-f00f29be299c4fbc65e2d5b6e5a7d811d5bf2333.tar.gz
historical-f00f29be299c4fbc65e2d5b6e5a7d811d5bf2333.tar.bz2
historical-f00f29be299c4fbc65e2d5b6e5a7d811d5bf2333.zip
this must fix some minors bugs and typos
-rw-r--r--app-emulation/win4lin/files/win4lin.initd.new21
-rw-r--r--app-emulation/win4lin/win4lin-5.0.1.ebuild13
2 files changed, 28 insertions, 6 deletions
diff --git a/app-emulation/win4lin/files/win4lin.initd.new b/app-emulation/win4lin/files/win4lin.initd.new
new file mode 100644
index 000000000000..dd123d3be68f
--- /dev/null
+++ b/app-emulation/win4lin/files/win4lin.initd.new
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/win4lin/files/win4lin.initd.new,v 1.1 2003/06/19 15:55:33 bass Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting Win4Lin"
+ /etc/rc.d/init.d/Win4Lin start >/tmp/win4lin_init.log
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Win4Lin"
+ /etc/rc.d/init.d/Win4Lin stop >/tmp/win4lin_init.log
+ eend $?
+}
+
diff --git a/app-emulation/win4lin/win4lin-5.0.1.ebuild b/app-emulation/win4lin/win4lin-5.0.1.ebuild
index 602b0bddab4d..b38141b0cdce 100644
--- a/app-emulation/win4lin/win4lin-5.0.1.ebuild
+++ b/app-emulation/win4lin/win4lin-5.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/win4lin/win4lin-5.0.1.ebuild,v 1.2 2003/06/05 23:38:29 bass Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/win4lin/win4lin-5.0.1.ebuild,v 1.3 2003/06/19 15:55:33 bass Exp $
IUSE="doc"
@@ -15,7 +15,7 @@ SRC_URI="mirror://gentoo/${MY_P}.rpm"
SLOT="0"
LICENSE="NeTraverse"
-KEYWORDS="~x86"
+KEYWORDS="x86"
DEPEND="app-arch/rpm2targz
virtual/winkernel"
@@ -36,7 +36,7 @@ src_install() {
mv ${S}/opt ${D}
mv ${S}/etc ${D}
cp ${FILESDIR}/registerme.sh ${D}/opt/win4lin/
-# cp ${FILESDIR}/win4lin.initd ${D}/opt/win4lin/
+ cp ${FILESDIR}/win4lin.initd.new ${D}/opt/win4lin/
# if [ -n "`use doc`" ]
# then
@@ -53,7 +53,7 @@ pkg_postinst() {
einfo "to install the windows setup files. You will need your Windows cdrom in the "
einfo "drive in order to complete this step."
einfo "============"
- einfo "If this is an upgrade 4.x to 5.x the trial license code isn valid,"
+ einfo "If this is an upgrade 4.x to 5.x the trial license code isn't valid,"
einfo "you need register it in NeTraverse, or unemerge ALL Win4Lin files."
}
@@ -65,8 +65,9 @@ pkg_prerm() {
pkg_config() {
loadwindowsCD cddevice /dev/cdrom
- ln -s /etc/rc.d/init.d/Win4Lin /etc/init.d/Win4Lin
- cp /opt/win4lin/win4lin.initd /etc/init.d/Win4Lin
+ cp /opt/win4lin/win4lin.initd.new /etc/init.d/Win4Lin
+ chmod +x /etc/init.d/Win4Lin
+
#put debugging stuff here
if [ ${?} -eq "0" ]; then
einfo "You can now run the command \"installwindows\" from an xterm "