summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-03 02:09:08 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-03 02:09:08 +0000
commitec35d09862487eb50abcdbc47ae04a0bbe6faf81 (patch)
tree49e6a913acc9a705159ec3b134f3a15413a75fca
parentAdded more verbose output if failing, and removed the pre-Beta1 stuff. (diff)
downloadhistorical-ec35d09862487eb50abcdbc47ae04a0bbe6faf81.tar.gz
historical-ec35d09862487eb50abcdbc47ae04a0bbe6faf81.tar.bz2
historical-ec35d09862487eb50abcdbc47ae04a0bbe6faf81.zip
Fix use invocation
-rw-r--r--dev-java/commons-beanutils/ChangeLog6
-rw-r--r--dev-java/commons-beanutils/commons-beanutils-1.6.1-r1.ebuild10
-rw-r--r--dev-java/jdbc3-oracle/ChangeLog6
-rw-r--r--dev-java/jdbc3-oracle/jdbc3-oracle-9.2.0.1.ebuild4
-rw-r--r--dev-java/jdbc3-oracle/jdbc3-oracle-9.2.0.3.ebuild4
-rw-r--r--dev-java/sablecc/ChangeLog5
-rw-r--r--dev-java/sablecc/sablecc-2.18.2.ebuild4
-rw-r--r--dev-java/sun-jdk/ChangeLog7
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.3.1.09.ebuild4
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.3.1.10.ebuild4
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.4.1.06.ebuild4
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.4.2.03.ebuild4
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.4.2.04.ebuild4
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.5.0_beta1-r1.ebuild18
14 files changed, 50 insertions, 34 deletions
diff --git a/dev-java/commons-beanutils/ChangeLog b/dev-java/commons-beanutils/ChangeLog
index f332bab530bf..22e06acdfa7c 100644
--- a/dev-java/commons-beanutils/ChangeLog
+++ b/dev-java/commons-beanutils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/commons-beanutils
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-beanutils/ChangeLog,v 1.10 2004/01/21 02:48:49 strider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-beanutils/ChangeLog,v 1.11 2004/06/03 02:04:11 agriffis Exp $
+
+ 02 Jun 2004; Aron Griffis <agriffis@gentoo.org>
+ commons-beanutils-1.6.1-r1.ebuild:
+ Fix use invocation
*commons-beanutils-1.6.1-r1 (20 Jan 2004)
diff --git a/dev-java/commons-beanutils/commons-beanutils-1.6.1-r1.ebuild b/dev-java/commons-beanutils/commons-beanutils-1.6.1-r1.ebuild
index 8b8d5f95834a..039b4acb918f 100644
--- a/dev-java/commons-beanutils/commons-beanutils-1.6.1-r1.ebuild
+++ b/dev-java/commons-beanutils/commons-beanutils-1.6.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-beanutils/commons-beanutils-1.6.1-r1.ebuild,v 1.2 2004/01/21 05:06:27 strider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-beanutils/commons-beanutils-1.6.1-r1.ebuild,v 1.3 2004/06/03 02:04:11 agriffis Exp $
inherit java-pkg
@@ -30,18 +30,18 @@ src_compile() {
echo "commons-collections.jar=`java-config --classpath=commons-collections`" > build.properties
echo "commons-logging.jar=`java-config --classpath=commons-logging`" | sed s/\=.*:/\=/ >> build.properties
- if [ -n "`use jikes`" ] ; then
+ if use jikes ; then
myc="${myc} -Dbuild.compiler=jikes"
fi
- if [ -n "`use junit`" ] ; then
+ if use junit ; then
echo "junit.jar=`java-config --classpath=junit`" | sed s/:.*// >> build.properties
ANT_OPTS=${myc} ant test || die "Testing Classes Failed"
fi
ANT_OPTS=${myc} ant jar || die "Compilation Failed"
- if [ -n "`use doc`" ] ; then
+ if use doc ; then
ANT_OPTS=${myc} ant javadoc || die "Unable to create documents"
fi
}
@@ -51,7 +51,7 @@ src_install () {
dodoc RELEASE-NOTES.txt LICENSE
dohtml STATUS.html PROPOSAL.html
- if [ -n "`use doc`" ] ; then
+ if use doc ; then
dohtml -r dist/docs/*
fi
}
diff --git a/dev-java/jdbc3-oracle/ChangeLog b/dev-java/jdbc3-oracle/ChangeLog
index d247a56d6cd9..5f0677732ce9 100644
--- a/dev-java/jdbc3-oracle/ChangeLog
+++ b/dev-java/jdbc3-oracle/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/jdbc3-oracle
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc3-oracle/ChangeLog,v 1.4 2004/01/17 04:39:21 strider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc3-oracle/ChangeLog,v 1.5 2004/06/03 02:00:03 agriffis Exp $
+
+ 02 Jun 2004; Aron Griffis <agriffis@gentoo.org> jdbc3-oracle-9.2.0.1.ebuild,
+ jdbc3-oracle-9.2.0.3.ebuild:
+ Fix use invocation
17 Jan 2004; Adrian Almenar <strider@gentoo.org> jdbc3-oracle-9.2.0.1.ebuild,
jdbc3-oracle-9.2.0.3.ebuild:
diff --git a/dev-java/jdbc3-oracle/jdbc3-oracle-9.2.0.1.ebuild b/dev-java/jdbc3-oracle/jdbc3-oracle-9.2.0.1.ebuild
index 5bd46036cf82..de53e775b3c4 100644
--- a/dev-java/jdbc3-oracle/jdbc3-oracle-9.2.0.1.ebuild
+++ b/dev-java/jdbc3-oracle/jdbc3-oracle-9.2.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc3-oracle/jdbc3-oracle-9.2.0.1.ebuild,v 1.5 2004/01/17 04:39:21 strider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc3-oracle/jdbc3-oracle-9.2.0.1.ebuild,v 1.6 2004/06/03 02:00:03 agriffis Exp $
inherit java-pkg
@@ -71,7 +71,7 @@ src_compile() {
}
src_install() {
- if [ -n "`use doc`" ] ; then
+ if use doc ; then
mkdir ${S}/javadoc
cd ${S}/javadoc
unzip ${DISTDIR}/${FILE3}
diff --git a/dev-java/jdbc3-oracle/jdbc3-oracle-9.2.0.3.ebuild b/dev-java/jdbc3-oracle/jdbc3-oracle-9.2.0.3.ebuild
index 89f980a1316d..60e439db0e31 100644
--- a/dev-java/jdbc3-oracle/jdbc3-oracle-9.2.0.3.ebuild
+++ b/dev-java/jdbc3-oracle/jdbc3-oracle-9.2.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc3-oracle/jdbc3-oracle-9.2.0.3.ebuild,v 1.5 2004/01/17 04:39:21 strider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc3-oracle/jdbc3-oracle-9.2.0.3.ebuild,v 1.6 2004/06/03 02:00:03 agriffis Exp $
inherit java-pkg
@@ -71,7 +71,7 @@ src_compile() {
}
src_install() {
- if [ -n "`use doc`" ] ; then
+ if use doc ; then
mkdir ${S}/javadoc
cd ${S}/javadoc
tar xf ${DISTDIR}/${FILE3}
diff --git a/dev-java/sablecc/ChangeLog b/dev-java/sablecc/ChangeLog
index 1681d132cfb1..23fcfe5772de 100644
--- a/dev-java/sablecc/ChangeLog
+++ b/dev-java/sablecc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-java/sablecc
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sablecc/ChangeLog,v 1.3 2004/05/03 21:57:49 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sablecc/ChangeLog,v 1.4 2004/06/03 01:59:13 agriffis Exp $
+
+ 02 Jun 2004; Aron Griffis <agriffis@gentoo.org> sablecc-2.18.2.ebuild:
+ Fix use invocation
08 May 2004; Chris Aniszczyk <zx@gentoo.org> +files/sablecc,
sablecc-2.18.2.ebuild:
diff --git a/dev-java/sablecc/sablecc-2.18.2.ebuild b/dev-java/sablecc/sablecc-2.18.2.ebuild
index cf1e9312727b..caab47ae0538 100644
--- a/dev-java/sablecc/sablecc-2.18.2.ebuild
+++ b/dev-java/sablecc/sablecc-2.18.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sablecc/sablecc-2.18.2.ebuild,v 1.3 2004/05/03 21:57:49 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sablecc/sablecc-2.18.2.ebuild,v 1.4 2004/06/03 01:59:13 agriffis Exp $
inherit java-pkg
@@ -20,7 +20,7 @@ RDEPEND=">=virtual/jre-1.4"
src_compile () {
local antflags="jar"
- if [ `use jikes` ] ; then
+ if use jikes ; then
:; # Do nothing, jikes is enable by default
else
antflags="${antflags} -Dbuild.compiler=modern"
diff --git a/dev-java/sun-jdk/ChangeLog b/dev-java/sun-jdk/ChangeLog
index 04ac5b960777..ef8ecbfbef67 100644
--- a/dev-java/sun-jdk/ChangeLog
+++ b/dev-java/sun-jdk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/sun-jdk
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.71 2004/04/06 16:38:25 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.72 2004/06/03 02:09:08 agriffis Exp $
+
+ 02 Jun 2004; Aron Griffis <agriffis@gentoo.org> sun-jdk-1.3.1.09.ebuild,
+ sun-jdk-1.3.1.10.ebuild, sun-jdk-1.4.1.06.ebuild, sun-jdk-1.4.2.03.ebuild,
+ sun-jdk-1.4.2.04.ebuild, sun-jdk-1.5.0_beta1-r1.ebuild:
+ Fix use invocation
06 Apr 2004; Chris Aniszczyk <zx@gentoo.org> sun-jdk-1.4.2.04-r1.ebuild:
Add proper dependancy on app-arch/unzip. Closes bug #46953
diff --git a/dev-java/sun-jdk/sun-jdk-1.3.1.09.ebuild b/dev-java/sun-jdk/sun-jdk-1.3.1.09.ebuild
index fdb99c30d821..cdf8f73fe7c1 100644
--- a/dev-java/sun-jdk/sun-jdk-1.3.1.09.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.3.1.09.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.3.1.09.ebuild,v 1.8 2004/02/22 19:51:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.3.1.09.ebuild,v 1.9 2004/06/03 02:09:08 agriffis Exp $
IUSE="doc"
@@ -83,7 +83,7 @@ src_install () {
dodir /opt/${P}/share/
cp -a demo src.jar ${D}/opt/${P}/share/
- if [ "`use mozilla`" ] ; then
+ if use mozilla ; then
dodir /usr/lib/mozilla/plugins
dosym /opt/${P}/jre/plugin/i386/ns600/libjavaplugin_oji.so /usr/lib/mozilla/plugins/
fi
diff --git a/dev-java/sun-jdk/sun-jdk-1.3.1.10.ebuild b/dev-java/sun-jdk/sun-jdk-1.3.1.10.ebuild
index 049f59630b11..c1594ca56748 100644
--- a/dev-java/sun-jdk/sun-jdk-1.3.1.10.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.3.1.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.3.1.10.ebuild,v 1.2 2004/02/22 19:51:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.3.1.10.ebuild,v 1.3 2004/06/03 02:09:08 agriffis Exp $
IUSE="doc"
@@ -83,7 +83,7 @@ src_install () {
dodir /opt/${P}/share/
cp -a demo src.jar ${D}/opt/${P}/share/
- if [ "`use mozilla`" ] ; then
+ if use mozilla ; then
dodir /usr/lib/mozilla/plugins
dosym /opt/${P}/jre/plugin/i386/ns600/libjavaplugin_oji.so /usr/lib/mozilla/plugins/
fi
diff --git a/dev-java/sun-jdk/sun-jdk-1.4.1.06.ebuild b/dev-java/sun-jdk/sun-jdk-1.4.1.06.ebuild
index dd7491b1d249..a52c8b3c1f34 100644
--- a/dev-java/sun-jdk/sun-jdk-1.4.1.06.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.4.1.06.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.1.06.ebuild,v 1.4 2004/02/22 19:51:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.1.06.ebuild,v 1.5 2004/06/03 02:09:08 agriffis Exp $
IUSE="doc"
@@ -73,7 +73,7 @@ src_install () {
dodir /opt/${P}/share/
cp -a demo src.zip ${D}/opt/${P}/share/
- if [ "`use mozilla`" ] ; then
+ if use mozilla ; then
dodir /usr/lib/mozilla/plugins
dosym /opt/${P}/jre/plugin/i386/ns610/libjavaplugin_oji.so /usr/lib/mozilla/plugins/
fi
diff --git a/dev-java/sun-jdk/sun-jdk-1.4.2.03.ebuild b/dev-java/sun-jdk/sun-jdk-1.4.2.03.ebuild
index 187f0865ca98..a89c4d347298 100644
--- a/dev-java/sun-jdk/sun-jdk-1.4.2.03.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.4.2.03.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.03.ebuild,v 1.6 2004/02/22 19:51:48 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.03.ebuild,v 1.7 2004/06/03 02:09:08 agriffis Exp $
IUSE="doc gnome kde mozilla"
@@ -83,7 +83,7 @@ src_install () {
if has_version '>=gcc-3.2*' ; then
plugin_dir="ns610-gcc32"
fi
- if [ "`use mozilla`" ] ; then
+ if use mozilla ; then
install_mozilla_plugin /opt/${P}/jre/plugin/i386/$plugin_dir/libjavaplugin_oji.so
fi
inst_plugin /opt/${P}/jre/plugin/i386/$plugin_dir/libjavaplugin_oji.so
diff --git a/dev-java/sun-jdk/sun-jdk-1.4.2.04.ebuild b/dev-java/sun-jdk/sun-jdk-1.4.2.04.ebuild
index 20bda92c307d..c7a0b9047d85 100644
--- a/dev-java/sun-jdk/sun-jdk-1.4.2.04.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.4.2.04.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.04.ebuild,v 1.1 2004/03/11 01:32:12 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.04.ebuild,v 1.2 2004/06/03 02:09:08 agriffis Exp $
IUSE="doc gnome kde mozilla"
@@ -83,7 +83,7 @@ src_install () {
if has_version '>=gcc-3.2*' ; then
plugin_dir="ns610-gcc32"
fi
- if [ "`use mozilla`" ] ; then
+ if use mozilla ; then
install_mozilla_plugin /opt/${P}/jre/plugin/i386/$plugin_dir/libjavaplugin_oji.so
fi
inst_plugin /opt/${P}/jre/plugin/i386/$plugin_dir/libjavaplugin_oji.so
diff --git a/dev-java/sun-jdk/sun-jdk-1.5.0_beta1-r1.ebuild b/dev-java/sun-jdk/sun-jdk-1.5.0_beta1-r1.ebuild
index 3c2425bce533..579bfe81012d 100644
--- a/dev-java/sun-jdk/sun-jdk-1.5.0_beta1-r1.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.5.0_beta1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.5.0_beta1-r1.ebuild,v 1.1 2004/02/15 06:57:19 strider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.5.0_beta1-r1.ebuild,v 1.2 2004/06/03 02:09:08 agriffis Exp $
IUSE="doc gnome kde mozilla"
@@ -9,9 +9,9 @@ inherit java
amd64file="j2sdk-1_5_0-beta-linux-amd64.bin"
x86file="j2sdk-1_5_0-beta-linux-i586.bin"
-if [ `use x86` ]; then
+if use x86; then
At=${x86file}
-elif [ `use amd64` ]; then
+elif use amd64; then
At=${amd64file}
fi
@@ -91,7 +91,7 @@ src_install () {
dohtml README.html
dodir /opt/${P}/share/
cp -a demo src.zip ${D}/opt/${P}/share/
- if [ "`use x86`" ]; then
+ if use x86; then
cp -a sample ${D}/opt/${P}/share/
fi
@@ -100,8 +100,8 @@ src_install () {
plugin_dir="ns7"
fi
- if [ "`use mozilla`" ] ; then
- if [ "`use x86`" ] ; then
+ if use mozilla ; then
+ if use x86 ; then
install_mozilla_plugin /opt/${P}/jre/plugin/i386/$plugin_dir/libjavaplugin_oji.so
else
eerror "No plugin available for amd64 arch"
@@ -117,15 +117,15 @@ src_install () {
${D}/opt/${P}/jre/plugin/desktop/sun_java.desktop > \
${T}/sun_java.desktop
- if [ "`use x86`" ]; then
- if [ "`use gnome`" ] ; then
+ if use x86; then
+ if use gnome ; then
#TODO check this on Gnome
dodir /usr/share/gnome/apps/Internet
insinto /usr/share/gnome/apps/Internet
doins ${T}/sun_java.desktop
fi
- if [ "`use kde`" ] ; then
+ if use kde ; then
dodir /usr/share/applnk/Internet
insinto /usr/share/applnk/Internet
doins ${T}/sun_java.desktop