summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-05-29 18:39:39 +0000
committerMatti Bickel <mabi@gentoo.org>2010-05-29 18:39:39 +0000
commitd68eb8796e57412107203d951c8f27145a6696fd (patch)
tree6a198ce361a3c224d232cd9d13f242ed417ee76b
parentVersion bump. (diff)
downloadhistorical-d68eb8796e57412107203d951c8f27145a6696fd.tar.gz
historical-d68eb8796e57412107203d951c8f27145a6696fd.tar.bz2
historical-d68eb8796e57412107203d951c8f27145a6696fd.zip
version bump
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
-rw-r--r--dev-php5/phing/ChangeLog7
-rw-r--r--dev-php5/phing/phing-2.4.1.ebuild41
-rw-r--r--dev-php5/phpunit/ChangeLog7
-rw-r--r--dev-php5/phpunit/phpunit-3.4.13.ebuild40
-rw-r--r--dev-php5/propel-runtime/ChangeLog12
-rw-r--r--dev-php5/propel-runtime/propel-runtime-1.3.0_beta2.ebuild29
-rw-r--r--dev-php5/propel-runtime/propel-runtime-1.3.0_beta3.ebuild25
-rw-r--r--dev-php5/propel-runtime/propel-runtime-1.3.0_beta4.ebuild25
-rw-r--r--dev-php5/propel-runtime/propel-runtime-1.5.1.ebuild26
9 files changed, 129 insertions, 83 deletions
diff --git a/dev-php5/phing/ChangeLog b/dev-php5/phing/ChangeLog
index 50d4c123665d..0d753754ad76 100644
--- a/dev-php5/phing/ChangeLog
+++ b/dev-php5/phing/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/phing
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phing/ChangeLog,v 1.11 2010/01/01 22:30:47 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phing/ChangeLog,v 1.12 2010/05/29 18:35:14 mabi Exp $
+
+*phing-2.4.1 (29 May 2010)
+
+ 29 May 2010; <mabi@gentoo.org> +phing-2.4.1.ebuild:
+ version bump
*phing-2.3.3 (01 Jan 2010)
diff --git a/dev-php5/phing/phing-2.4.1.ebuild b/dev-php5/phing/phing-2.4.1.ebuild
new file mode 100644
index 000000000000..0d173642b16c
--- /dev/null
+++ b/dev-php5/phing/phing-2.4.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phing/phing-2.4.1.ebuild,v 1.1 2010/05/29 18:35:14 mabi Exp $
+
+EAPI="2"
+inherit php-pear-lib-r1 eutils
+
+DESCRIPTION="PHP project build system based on Apache Ant"
+HOMEPAGE="http://www.phing.info/"
+SRC_URI="http://pear.phing.info/get/phing-${PV/_/}.tgz"
+
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+minimal"
+
+DEPEND=""
+RDEPEND="!minimal? ( >=dev-php/PEAR-PhpDocumentor-1.4.0
+ >=dev-php/PEAR-PEAR_PackageFileManager-1.5.2
+ >=dev-php/PEAR-VersionControl_SVN-0.3.0_alpha1
+ >=dev-php5/phpunit-3.2.0
+ >=dev-php5/xdebug-2.0.0
+ >=dev-php/simpletest-1.0.1_beta2
+ >=dev-php5/creole-1.1.0 )
+ >=dev-lang/php-5.0.2[xml,xsl]
+ || ( <dev-lang/php-5.3.1[pcre,reflection,spl] >=dev-lang/php-5.3.1 )
+ "
+
+need_php_by_category
+
+S=${WORKDIR}/${PN}-${PV/_/}
+
+
+pkg_postinst() {
+ if use minimal; then
+ elog "You have enabled the minimal USE flag. If you want to use features"
+ elog "from xdebug, phpunit, simpletest and more, disable the"
+ elog "USE flag or emerge the packages manually"
+ fi
+}
diff --git a/dev-php5/phpunit/ChangeLog b/dev-php5/phpunit/ChangeLog
index 5b3fb5bdd28b..14d43f05db8f 100644
--- a/dev-php5/phpunit/ChangeLog
+++ b/dev-php5/phpunit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php5/phpunit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.27 2010/04/06 19:22:54 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.28 2010/05/29 18:30:40 mabi Exp $
+
+*phpunit-3.4.13 (29 May 2010)
+
+ 29 May 2010; <mabi@gentoo.org> +phpunit-3.4.13.ebuild:
+ version bump
06 Apr 2010; Maciej Mrozowski <reavertm@gentoo.org> -phpunit-3.2.8.ebuild,
-phpunit-3.2.21.ebuild, -phpunit-3.3.1.ebuild:
diff --git a/dev-php5/phpunit/phpunit-3.4.13.ebuild b/dev-php5/phpunit/phpunit-3.4.13.ebuild
new file mode 100644
index 000000000000..e7aa77a1e82f
--- /dev/null
+++ b/dev-php5/phpunit/phpunit-3.4.13.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/phpunit-3.4.13.ebuild,v 1.1 2010/05/29 18:30:40 mabi Exp $
+
+EAPI="2"
+inherit php-pear-lib-r1
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~sparc ~x86"
+
+DESCRIPTION="Unit testing framework for PHP5"
+HOMEPAGE="http://www.phpunit.de/"
+SRC_URI="http://pear.phpunit.de/get/PHPUnit-${PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+IUSE="+minimal"
+
+DEPEND="!dev-php4/phpunit
+ >=dev-php/PEAR-PEAR-1.8.1"
+RDEPEND="${DEPEND}
+ >=dev-lang/php-5.2[simplexml,xml,tokenizer]
+ || ( <dev-lang/php-5.3[pcre,reflection,spl] >=dev-lang/php-5.3 )
+ !minimal? ( >=dev-php5/xdebug-2.0.5
+ >=dev-php/PEAR-Image_GraphViz-1.2.1
+ >=dev-php/PEAR-Log-1.8.7-r1
+ >=dev-php/PEAR-Testing_Selenium-0.2.0 )"
+
+need_php_by_category
+
+S="${WORKDIR}/PHPUnit-${PV}"
+
+pkg_postinst() {
+ has_php
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge ${PHP_PKG} with USE=\"json pdo sqlite mysql\"."
+ if use minimal; then
+ elog "You have enabled the minimal USE flag. If you want to use features"
+ elog "from xdebug, PEAR-Log or PEAR-Testing_Selenium disable the"
+ elog "USE flag or emerge the packages manually"
+ fi
+}
diff --git a/dev-php5/propel-runtime/ChangeLog b/dev-php5/propel-runtime/ChangeLog
index c377e116043c..ee32be6407ce 100644
--- a/dev-php5/propel-runtime/ChangeLog
+++ b/dev-php5/propel-runtime/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-php5/propel-runtime
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/propel-runtime/ChangeLog,v 1.9 2008/02/26 16:41:25 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/propel-runtime/ChangeLog,v 1.10 2010/05/29 18:39:39 mabi Exp $
+
+*propel-runtime-1.5.1 (29 May 2010)
+
+ 29 May 2010; <mabi@gentoo.org> -propel-runtime-1.3.0_beta2.ebuild,
+ -propel-runtime-1.3.0_beta3.ebuild, -propel-runtime-1.3.0_beta4.ebuild,
+ +propel-runtime-1.5.1.ebuild:
+ version bump, depends on dev-php/pear-1.9.0-1 because of pear channel name
+ change
*propel-runtime-1.3.0_beta4 (26 Feb 2008)
diff --git a/dev-php5/propel-runtime/propel-runtime-1.3.0_beta2.ebuild b/dev-php5/propel-runtime/propel-runtime-1.3.0_beta2.ebuild
deleted file mode 100644
index 97f181001ae1..000000000000
--- a/dev-php5/propel-runtime/propel-runtime-1.3.0_beta2.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/propel-runtime/propel-runtime-1.3.0_beta2.ebuild,v 1.1 2007/03/20 18:36:50 chtekk Exp $
-
-inherit php-pear-lib-r1
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="Object Persistence Layer for PHP 5 (Runtime)."
-HOMEPAGE="http://propel.phpdb.org/trac/wiki/"
-SRC_URI="http://pear.phpdb.org/get/propel_runtime-${PV/_/}.tgz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-IUSE=""
-
-DEPEND=""
-RDEPEND=">=dev-php/PEAR-Log-1.8.7-r1"
-
-S="${WORKDIR}/propel_runtime-${PV/_/}"
-
-need_php_by_category
-
-pkg_setup() {
- has_php
-
- # We need PDO and a few other things
- require_pdo
- require_php_with_use reflection spl xml xsl
-}
diff --git a/dev-php5/propel-runtime/propel-runtime-1.3.0_beta3.ebuild b/dev-php5/propel-runtime/propel-runtime-1.3.0_beta3.ebuild
deleted file mode 100644
index 66415a4f388c..000000000000
--- a/dev-php5/propel-runtime/propel-runtime-1.3.0_beta3.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/propel-runtime/propel-runtime-1.3.0_beta3.ebuild,v 1.1 2007/12/24 14:52:00 armin76 Exp $
-
-inherit php-pear-lib-r1
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="Object Persistence Layer for PHP 5 (Runtime)."
-HOMEPAGE="http://propel.phpdb.org/trac/wiki/"
-SRC_URI="http://pear.phpdb.org/get/propel_runtime-${PV/_/}.tgz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-IUSE=""
-
-DEPEND=">=dev-lang/php-5.2.0"
-RDEPEND="${DEPEND}
- >=dev-php/PEAR-Log-1.8.7-r1"
-
-S="${WORKDIR}/propel_runtime-${PV/_/}"
-
-pkg_setup() {
- # We need PDO and a few other things
- require_php_with_use pdo reflection spl xml xsl
-}
diff --git a/dev-php5/propel-runtime/propel-runtime-1.3.0_beta4.ebuild b/dev-php5/propel-runtime/propel-runtime-1.3.0_beta4.ebuild
deleted file mode 100644
index 38973cb8f9d0..000000000000
--- a/dev-php5/propel-runtime/propel-runtime-1.3.0_beta4.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/propel-runtime/propel-runtime-1.3.0_beta4.ebuild,v 1.1 2008/02/26 16:41:25 armin76 Exp $
-
-inherit php-pear-lib-r1 depend.php
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="Object Persistence Layer for PHP 5 (Runtime)."
-HOMEPAGE="http://propel.phpdb.org/trac/wiki/"
-SRC_URI="http://pear.phpdb.org/get/propel_runtime-${PV/_/}.tgz"
-LICENSE="LGPL-2.1"
-SLOT="0"
-IUSE=""
-
-DEPEND=">=dev-lang/php-5.2.0"
-RDEPEND="${DEPEND}
- >=dev-php/PEAR-Log-1.8.7-r1"
-
-S="${WORKDIR}/propel_runtime-${PV/_/}"
-
-pkg_setup() {
- # We need PDO and a few other things
- require_php_with_use pdo reflection spl xml xsl
-}
diff --git a/dev-php5/propel-runtime/propel-runtime-1.5.1.ebuild b/dev-php5/propel-runtime/propel-runtime-1.5.1.ebuild
new file mode 100644
index 000000000000..5b593eeff893
--- /dev/null
+++ b/dev-php5/propel-runtime/propel-runtime-1.5.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/propel-runtime/propel-runtime-1.5.1.ebuild,v 1.1 2010/05/29 18:39:39 mabi Exp $
+
+EAPI="2"
+inherit php-pear-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Object Persistence Layer for PHP 5 (Runtime)."
+HOMEPAGE="http://propel.phpdb.org/trac/wiki/"
+SRC_URI="http://pear.propelorm.org/get/propel_runtime-${PV}.tgz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-lang/php-5.2.4[pdo,xml,xsl]
+ || ( <dev-lang/php-5.3[pcre,reflection,spl] >=dev-lang/php-5.3 )
+ >=dev-php/pear-1.9.0-r1"
+RDEPEND="${DEPEND}
+ >=dev-php/PEAR-Log-1.8.7-r1
+ "
+
+S="${WORKDIR}/propel_runtime-${PV}"
+
+need_php_by_category