summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-03-15 01:41:55 +0000
committerNed Ludd <solar@gentoo.org>2004-03-15 01:41:55 +0000
commitd32ec2c71252c2b754d178ce6130bc9640ccd687 (patch)
treee7cb5f46b5f87fd946f70f049635bf63a7bbb708
parentfix assignment of P=, it SHOULD be MY_P, peoplels -al Closing bug #44712 by M... (diff)
downloadhistorical-d32ec2c71252c2b754d178ce6130bc9640ccd687.tar.gz
historical-d32ec2c71252c2b754d178ce6130bc9640ccd687.tar.bz2
historical-d32ec2c71252c2b754d178ce6130bc9640ccd687.zip
masked pre testing version
-rw-r--r--sys-kernel/hardened-dev-sources/hardened-dev-sources-2.6.4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-kernel/hardened-dev-sources/hardened-dev-sources-2.6.4.ebuild b/sys-kernel/hardened-dev-sources/hardened-dev-sources-2.6.4.ebuild
new file mode 100644
index 000000000000..65d9981d3fbf
--- /dev/null
+++ b/sys-kernel/hardened-dev-sources/hardened-dev-sources-2.6.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-dev-sources/hardened-dev-sources-2.6.4.ebuild,v 1.1 2004/03/15 01:41:55 solar Exp $
+
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+NETRAND_CORE_VER="${OKV}"
+NETRAND_DRIVERS_VER="${OKV}"
+
+#GRSEC_VER=2.0-testing-${OKV}
+#GRSEC_URI="http://grsecurity.net/grsecurity-${GRSEC_VER}.patch"
+
+# repackage while brad is developing 2.6.x to avoid md5sum conflicts if
+# he changes it upstream.
+
+GRSEC_STAMP=20040314
+GRSEC_VER=2.0-testing-${GRSEC_STAMP}-${OKV}
+GRSEC_URI="http://dev.gentoo.org/~solar/grsecurity/grsecurity-${GRSEC_VER}.patch"
+
+NETRAND_CORE_URI="http://zeus.polsl.gliwice.pl/~albeiro/netdev-random/netdev-random-core-${NETRAND_CORE_VER}.patch"
+NETRAND_DRIVERS_URI="http://zeus.polsl.gliwice.pl/~albeiro/netdev-random/netdev-random-drivers-${NETRAND_DRIVERS_VER}.patch"
+
+AVC_PAX_VER=
+AVC_PAX_URI=
+
+KEYWORDS="-*"
+
+UNIPATCH_LIST="${DISTDIR}/grsecurity-${GRSEC_VER}.patch
+ ${DISTDIR}/linux-${OKV}-avc_pax.patch
+ ${DISTDIR}/linux-${OKV}-audit_textrel.patch
+ ${DISTDIR}/netdev-random-core-${NETRAND_CORE_VER}.patch
+ ${DISTDIR}/netdev-random-drivers-${NETRAND_DRIVERS_VER}.patch"
+
+
+DESCRIPTION="Vanilla sources for the ${KV_MAJOR}.${KV_MINOR} kernel tree patch with the grsecurity patch"
+SRC_URI="${KERNEL_URI} ${GRSEC_URI} ${AVC_PAX_URI} ${NETRAND_CORE_URI} ${NETRAND_DRIVERS_URI}"
+UNIPATCH_STRICTORDER="yes"
+
+pkg_postinst() {
+ postinst_sources
+ einfo "UNIPATCH_LIST=$(for p in $UNIPATCH_LIST ; do echo -n "$(basename ${p} .patch), " ; done ; date -u +%Y%m%d.%s)"
+ einfo "You sick bastard."
+}