summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-10-19 02:00:48 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-10-19 02:00:48 +0000
commitcd4360b9a28b9c0386760e0b155c437e5de349c5 (patch)
tree080a916f52789c810d5dca67754a389daa2cfee7
parent040 release (diff)
downloadhistorical-cd4360b9a28b9c0386760e0b155c437e5de349c5.tar.gz
historical-cd4360b9a28b9c0386760e0b155c437e5de349c5.tar.bz2
historical-cd4360b9a28b9c0386760e0b155c437e5de349c5.zip
initial commit - ebuild submitted by Ali Sabil via bug #64431
-rw-r--r--games-arcade/tomatoes/ChangeLog10
-rw-r--r--games-arcade/tomatoes/Manifest4
-rw-r--r--games-arcade/tomatoes/files/digest-tomatoes-1.52
-rw-r--r--games-arcade/tomatoes/metadata.xml5
-rw-r--r--games-arcade/tomatoes/tomatoes-1.5.ebuild58
5 files changed, 79 insertions, 0 deletions
diff --git a/games-arcade/tomatoes/ChangeLog b/games-arcade/tomatoes/ChangeLog
new file mode 100644
index 000000000000..bfeccc727279
--- /dev/null
+++ b/games-arcade/tomatoes/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-arcade/tomatoes
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/tomatoes/ChangeLog,v 1.1 2004/10/19 02:00:48 mr_bones_ Exp $
+
+*tomatoes-1.5 (18 Oct 2004)
+
+ 18 Oct 2004; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+ +tomatoes-1.5.ebuild:
+ initial commit - ebuild submitted by Ali Sabil via bug #64431
+
diff --git a/games-arcade/tomatoes/Manifest b/games-arcade/tomatoes/Manifest
new file mode 100644
index 000000000000..155e701e103d
--- /dev/null
+++ b/games-arcade/tomatoes/Manifest
@@ -0,0 +1,4 @@
+MD5 cf157414c307fe4bafdfaef4a50b5452 tomatoes-1.5.ebuild 1731
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 de4c26b6f0170091d2c282ea5316b8be ChangeLog 406
+MD5 2c9494bdf746978eff80c55028b0e5dc files/digest-tomatoes-1.5 146
diff --git a/games-arcade/tomatoes/files/digest-tomatoes-1.5 b/games-arcade/tomatoes/files/digest-tomatoes-1.5
new file mode 100644
index 000000000000..be303a4f36e0
--- /dev/null
+++ b/games-arcade/tomatoes/files/digest-tomatoes-1.5
@@ -0,0 +1,2 @@
+MD5 5cb01c40b2a43e5fa2cae2d7a451fc1d tomatoes-linux-src-1.5.tar.bz2 62759
+MD5 a6a7ff71bb1098fd0a4098fd3d846339 tomatoes-linux-1.5.tar.bz2 8807421
diff --git a/games-arcade/tomatoes/metadata.xml b/games-arcade/tomatoes/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/tomatoes/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-arcade/tomatoes/tomatoes-1.5.ebuild b/games-arcade/tomatoes/tomatoes-1.5.ebuild
new file mode 100644
index 000000000000..1d39ad9e22fb
--- /dev/null
+++ b/games-arcade/tomatoes/tomatoes-1.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/tomatoes/tomatoes-1.5.ebuild,v 1.1 2004/10/19 02:00:48 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="How many tomatoes can you smash in ten short minutes?"
+HOMEPAGE="http://tomatoes.sourceforge.net/about.html"
+SRC_URI="mirror://sourceforge/tomatoes/tomatoes-linux-src-${PV}.tar.bz2
+ mirror://sourceforge/tomatoes/tomatoes-linux-${PV}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ >=media-libs/libsdl-1.2.7
+ >=media-libs/sdl-image-1.2.2
+ >=media-libs/fmod-3.73"
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i \
+ -e '/^CC/d' \
+ -e '/^MARCH/d' \
+ -e "/^CFLAGS/s/=.*$/= ${CFLAGS} \$(SDL_FLAGS)/" \
+ -e "/^MPKDIR = /s:./:${GAMES_DATADIR}/${PN}/:" \
+ -e "/^MUSICDIR = /s:./music/:${GAMES_DATADIR}/${PN}/music/:" \
+ -e "/^HISCOREDIR = /s:./:${GAMES_STATEDIR}/${PN}/:" \
+ -e "/^CONFIGDIR = /s:./:${GAMES_SYSCONFDIR}/${PN}/:" \
+ -e "/^OVERRIDEDIR = /s:./data/:${GAMES_DATADIR}/${PN}/data/:" \
+ "${S}/makefile" \
+ || die "sed failed"
+}
+
+src_install() {
+ dogamesbin tomatoes || die "dogamesbin failed"
+ dodir "${GAMES_DATADIR}/${PN}" "${GAMES_STATEDIR}/${PN}"
+ dodoc README README-src
+
+ cp -r tomatoes.mpk music/ "${D}${GAMES_DATADIR}/${PN}" \
+ || die "failed to copy game data"
+
+ insinto /usr/share/icons/
+ newins icon.png ${PN}.png
+ make_desktop_entry tomatoes "I Have No Tomatoes" ${PN}.png
+
+ touch "${D}${GAMES_STATEDIR}/${PN}/hiscore.lst" || die "touch failed"
+ fperms 660 "${GAMES_STATEDIR}/${PN}/hiscore.lst"
+
+ insinto "${GAMES_SYSCONFDIR}/${PN}/"
+ insopts -m0640
+ doins config.cfg || die "failed to copy game config"
+
+ prepgamesdirs
+}