summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-03-03 18:16:57 +0000
committerMike Frysinger <vapier@gentoo.org>2003-03-03 18:16:57 +0000
commitae18ccd0d2c7d6d556805a70a324ce346b4c7bb8 (patch)
treed4a5d41c5e872c27cbea733f66dbad1e1467dde0
parentVersion bumped. (diff)
downloadhistorical-ae18ccd0d2c7d6d556805a70a324ce346b4c7bb8.tar.gz
historical-ae18ccd0d2c7d6d556805a70a324ce346b4c7bb8.tar.bz2
historical-ae18ccd0d2c7d6d556805a70a324ce346b4c7bb8.zip
libgd fixes #14255
-rw-r--r--dev-php/mod_php/mod_php-4.3.0-r2.ebuild10
-rw-r--r--dev-php/mod_php/mod_php-4.3.1-r1.ebuild11
-rw-r--r--dev-php/mod_php/mod_php-4.3.1.ebuild12
3 files changed, 15 insertions, 18 deletions
diff --git a/dev-php/mod_php/mod_php-4.3.0-r2.ebuild b/dev-php/mod_php/mod_php-4.3.0-r2.ebuild
index 929a428b8011..4ce7fbcb7eed 100644
--- a/dev-php/mod_php/mod_php-4.3.0-r2.ebuild
+++ b/dev-php/mod_php/mod_php-4.3.0-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.0-r2.ebuild,v 1.7 2003/03/03 09:20:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.0-r2.ebuild,v 1.8 2003/03/03 18:16:57 vapier Exp $
inherit flag-o-matic
-IUSE="java png apache2 truetype postgres tiff libwww nls jpeg ssl oci8 mysql X gdbm curl imap xml2 xml cjk pdflib qt snmp crypt flash odbc ldap berkdb freetds firebird pam"
+IUSE="java png apache2 truetype postgres tiff libwww nls jpeg gd ssl oci8 mysql X gdbm curl imap xml2 xml cjk pdflib qt snmp crypt flash odbc ldap berkdb freetds firebird pam"
MY_P=php-${PV}
S=${WORKDIR}/${MY_P}
@@ -52,7 +52,8 @@ DEPEND="
libwww? ( >=net-libs/libwww-5.3.2 )
firebird? ( >=dev-db/firebird-1.0 )
pdflib? ( >=media-libs/pdflib-4.0.1-r2 )
- postgres? ( >=dev-db/postgresql-7.1 )"
+ postgres? ( >=dev-db/postgresql-7.1 )
+ gd? ( media-libs/libgd )"
#java? ( virtual/jdk )
# Only needed by CGI-Version
# readline? ( >=sys-libs/ncurses-5.1
@@ -125,6 +126,7 @@ src_compile() {
use pdflib && myconf="${myconf} --with-pdflib=/usr"
use jpeg && myconf="${myconf} --with-jpeg-dir=/usr/lib"
use tiff && myconf="${myconf} --with-tiff-dir=/usr"
+ use gd && myconf="${myconf} --with-gd=/usr"
if [ "`use png`" ] ; then
myconf="${myconf} --with-png-dir=/usr/lib"
@@ -198,7 +200,6 @@ src_compile() {
--enable-ftp \
--enable-force-cgi-redirect \
--enable-discard-path \
- --enable-gd-native-ttf \
--enable-mime-magic \
--enable-wddx \
--enable-dbase \
@@ -207,7 +208,6 @@ src_compile() {
--enable-bcmath \
--enable-sysvsem \
--enable-exif \
- --with-gd \
--enable-sysvshm \
--enable-sockets \
--enable-calendar \
diff --git a/dev-php/mod_php/mod_php-4.3.1-r1.ebuild b/dev-php/mod_php/mod_php-4.3.1-r1.ebuild
index 8feb15aac83e..ad4f48a9e58b 100644
--- a/dev-php/mod_php/mod_php-4.3.1-r1.ebuild
+++ b/dev-php/mod_php/mod_php-4.3.1-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.1-r1.ebuild,v 1.8 2003/03/03 17:32:27 sethbc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.1-r1.ebuild,v 1.9 2003/03/03 18:16:57 vapier Exp $
inherit flag-o-matic
-IUSE="java png apache2 truetype postgres tiff libwww nls jpeg ssl oci8 mysql X gdbm curl imap xml2 xml cjk pdflib qt snmp crypt flash odbc ldap berkdb freetds firebird pam spell"
+IUSE="java png apache2 truetype postgres tiff libwww nls gd jpeg ssl oci8 mysql X gdbm curl imap xml2 xml cjk pdflib qt snmp crypt flash odbc ldap berkdb freetds firebird pam spell"
MY_P=php-${PV}
S=${WORKDIR}/${MY_P}
@@ -24,7 +24,6 @@ replace-flags "-march=k6*" "-march=i586"
#>=dev-libs/gmp-3.1.1
DEPEND=">=net-www/apache-1.3.26-r2
- >=app-crypt/mhash-0.8
apache2? ( >=net-www/apache-2.0.43-r1 )
truetype? ( ~media-libs/freetype-1.3.1 >=media-libs/t1lib-1.3.1 )
jpeg? ( >=media-libs/jpeg-6b )
@@ -52,7 +51,8 @@ DEPEND=">=net-www/apache-1.3.26-r2
pdflib? ( >=media-libs/pdflib-4.0.1-r2 )
freetds? ( >=dev-db/freetds-0.53 )
firebird? ( >=dev-db/firebird-1.0 )
- postgres? ( >=dev-db/postgresql-7.1 )"
+ postgres? ( >=dev-db/postgresql-7.1 )
+ gd? ( media-libs/libgd )"
#java? ( virtual/jdk )
# Only needed by CGI-Version
# readline? ( >=sys-libs/ncurses-5.1
@@ -126,6 +126,7 @@ src_compile() {
use jpeg && myconf="${myconf} --with-jpeg-dir=/usr/lib"
use tiff && myconf="${myconf} --with-tiff-dir=/usr"
use spell && myconf="${myconf} --with-pspell"
+ use gd && myconf="${myconf} --with-gd=/usr"
if [ "`use png`" ] ; then
myconf="${myconf} --with-png-dir=/usr/lib"
@@ -196,7 +197,6 @@ src_compile() {
--enable-ftp \
--enable-force-cgi-redirect \
--enable-discard-path \
- --enable-gd-native-ttf \
--enable-mime-magic \
--enable-wddx \
--enable-dbase \
@@ -205,7 +205,6 @@ src_compile() {
--enable-bcmath \
--enable-sysvsem \
--enable-exif \
- --with-gd \
--enable-sysvshm \
--enable-sockets \
--enable-calendar \
diff --git a/dev-php/mod_php/mod_php-4.3.1.ebuild b/dev-php/mod_php/mod_php-4.3.1.ebuild
index d0633ea61db9..3e3bd8ae6f17 100644
--- a/dev-php/mod_php/mod_php-4.3.1.ebuild
+++ b/dev-php/mod_php/mod_php-4.3.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.1.ebuild,v 1.6 2003/03/03 13:28:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/mod_php-4.3.1.ebuild,v 1.7 2003/03/03 18:16:57 vapier Exp $
inherit flag-o-matic
-IUSE="java spell png apache2 truetype postgres tiff libwww nls jpeg ssl oci8 mysql X gdbm curl imap xml2 xml cjk pdflib qt snmp crypt flash odbc ldap berkdb freetds firebird pam"
+IUSE="java spell png apache2 truetype postgres tiff libwww nls gd jpeg ssl oci8 mysql X gdbm curl imap xml2 xml cjk pdflib qt snmp crypt flash odbc ldap berkdb freetds firebird pam"
MY_P=php-${PV}
S=${WORKDIR}/${MY_P}
@@ -24,7 +24,6 @@ replace-flags "-march=k6*" "-march=i586"
#>=dev-libs/gmp-3.1.1
DEPEND=">=net-www/apache-1.3.26-r2
- >=app-crypt/mhash-0.8 )
apache2? ( >=net-www/apache-2.0.43-r1 )
truetype? ( ~media-libs/freetype-1.3.1 >=media-libs/t1lib-1.3.1 )
jpeg? ( >=media-libs/jpeg-6b )
@@ -52,7 +51,8 @@ DEPEND=">=net-www/apache-1.3.26-r2
libwww? ( >=net-libs/libwww-5.3.2 )
firebird? ( >=dev-db/firebird-1.0 )
pdflib? ( >=media-libs/pdflib-4.0.1-r2 )
- postgres? ( >=dev-db/postgresql-7.1 )"
+ postgres? ( >=dev-db/postgresql-7.1 )
+ gd? ( media-libs/libgd )"
#java? ( virtual/jdk )
# Only needed by CGI-Version
# readline? ( >=sys-libs/ncurses-5.1
@@ -125,7 +125,7 @@ src_compile() {
use pdflib && myconf="${myconf} --with-pdflib=/usr"
use jpeg && myconf="${myconf} --with-jpeg-dir=/usr/lib"
use tiff && myconf="${myconf} --with-tiff-dir=/usr"
-
+ use gd && myconf="${myconf} --with-gd=/usr"
use spell && myconf="${myconf} --with-pspell"
if [ "`use png`" ] ; then
@@ -197,7 +197,6 @@ src_compile() {
--enable-ftp \
--enable-force-cgi-redirect \
--enable-discard-path \
- --enable-gd-native-ttf \
--enable-mime-magic \
--enable-wddx \
--enable-dbase \
@@ -206,7 +205,6 @@ src_compile() {
--enable-bcmath \
--enable-sysvsem \
--enable-exif \
- --with-gd \
--enable-sysvshm \
--enable-sockets \
--enable-calendar \