summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-03-09 00:05:52 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-03-09 00:05:52 +0000
commitab2488303537284cad3f0d448487ab116740c20e (patch)
tree4581f827ac50c70a416ff958c1e06bb03100d1eb
parentVersion bump. (diff)
downloadhistorical-ab2488303537284cad3f0d448487ab116740c20e.tar.gz
historical-ab2488303537284cad3f0d448487ab116740c20e.tar.bz2
historical-ab2488303537284cad3f0d448487ab116740c20e.zip
Version bump.
Package-Manager: portage-2.2.0_alpha89/cvs/Linux x86_64
-rw-r--r--x11-drivers/xf86-input-vmmouse/ChangeLog10
-rw-r--r--x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-12.8.0.ebuild30
-rw-r--r--x11-drivers/xf86-video-vmware/ChangeLog8
-rw-r--r--x11-drivers/xf86-video-vmware/xf86-video-vmware-12.0.0.ebuild15
4 files changed, 60 insertions, 3 deletions
diff --git a/x11-drivers/xf86-input-vmmouse/ChangeLog b/x11-drivers/xf86-input-vmmouse/ChangeLog
index 2925585d578e..35ec7656fd73 100644
--- a/x11-drivers/xf86-input-vmmouse/ChangeLog
+++ b/x11-drivers/xf86-input-vmmouse/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-vmmouse
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-vmmouse/ChangeLog,v 1.49 2011/04/18 11:28:51 scarabeus Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-vmmouse/ChangeLog,v 1.50 2012/03/09 00:05:33 chithanh Exp $
+
+*xf86-input-vmmouse-12.8.0 (09 Mar 2012)
+
+ 09 Mar 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +xf86-input-vmmouse-12.8.0.ebuild:
+ Version bump.
18 Apr 2011; Tomáš Chvátal <scarabeus@gentoo.org>
-xf86-input-vmmouse-12.6.10.ebuild:
diff --git a/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-12.8.0.ebuild b/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-12.8.0.ebuild
new file mode 100644
index 000000000000..eb717c6e543b
--- /dev/null
+++ b/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-12.8.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-vmmouse/xf86-input-vmmouse-12.8.0.ebuild,v 1.1 2012/03/09 00:05:33 chithanh Exp $
+
+EAPI=4
+
+inherit xorg-2
+
+DESCRIPTION="VMWare mouse input driver"
+IUSE=""
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ x11-proto/randrproto"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ --with-hal-bin-dir=/punt
+ --with-hal-callouts-dir=/punt
+ --with-hal-fdi-dir=/punt
+ )
+
+ xorg-2_pkg_setup
+}
+
+src_install() {
+ xorg-2_src_install
+ rm -rf "${ED}"/punt
+}
diff --git a/x11-drivers/xf86-video-vmware/ChangeLog b/x11-drivers/xf86-video-vmware/ChangeLog
index d14db46722fc..65f4e2314388 100644
--- a/x11-drivers/xf86-video-vmware/ChangeLog
+++ b/x11-drivers/xf86-video-vmware/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-video-vmware
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-vmware/ChangeLog,v 1.60 2012/01/16 00:59:56 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-vmware/ChangeLog,v 1.61 2012/03/09 00:05:52 chithanh Exp $
+
+*xf86-video-vmware-12.0.0 (09 Mar 2012)
+
+ 09 Mar 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +xf86-video-vmware-12.0.0.ebuild:
+ Version bump.
*xf86-video-vmware-11.1.0 (16 Jan 2012)
diff --git a/x11-drivers/xf86-video-vmware/xf86-video-vmware-12.0.0.ebuild b/x11-drivers/xf86-video-vmware/xf86-video-vmware-12.0.0.ebuild
new file mode 100644
index 000000000000..68159c96642f
--- /dev/null
+++ b/x11-drivers/xf86-video-vmware/xf86-video-vmware-12.0.0.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-vmware/xf86-video-vmware-12.0.0.ebuild,v 1.1 2012/03/09 00:05:52 chithanh Exp $
+
+EAPI=4
+
+XORG_DRI=always
+inherit xorg-2
+
+DESCRIPTION="VMware SVGA video driver"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libdrm[libkms,video_cards_vmware]"
+DEPEND="${RDEPEND}"