summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-07-15 22:20:22 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-07-15 22:20:22 +0000
commit8a0981fb841dff7463bc12d7ea78372fef46502d (patch)
tree2d68ac3a4a2acdbf1e1af381c8a69fb2784183e5
parentwasabi->tenshi (diff)
downloadhistorical-8a0981fb841dff7463bc12d7ea78372fef46502d.tar.gz
historical-8a0981fb841dff7463bc12d7ea78372fef46502d.tar.bz2
historical-8a0981fb841dff7463bc12d7ea78372fef46502d.zip
bug #56917, pic stuff.
-rw-r--r--net-mail/uw-imap/ChangeLog5
-rw-r--r--net-mail/uw-imap/Manifest4
-rw-r--r--net-mail/uw-imap/files/digest-uw-imap-2002e-r31
-rw-r--r--net-mail/uw-imap/uw-imap-2002e-r3.ebuild127
4 files changed, 135 insertions, 2 deletions
diff --git a/net-mail/uw-imap/ChangeLog b/net-mail/uw-imap/ChangeLog
index d4fc3dab25d6..663941b5b6f7 100644
--- a/net-mail/uw-imap/ChangeLog
+++ b/net-mail/uw-imap/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-mail/uw-imap
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-imap/ChangeLog,v 1.31 2004/07/01 22:36:43 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-imap/ChangeLog,v 1.32 2004/07/15 22:20:22 robbat2 Exp $
+
+ 15 Jul 2004; Robin H. Johnson <robbat2@gentoo.org> :
+ bug #56917, pic stuff.
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
uw-imap-2002d-r1.ebuild, uw-imap-2002d.ebuild, uw-imap-2002e-r1.ebuild,
diff --git a/net-mail/uw-imap/Manifest b/net-mail/uw-imap/Manifest
index 119ee892b183..bfbbe8f2b5d3 100644
--- a/net-mail/uw-imap/Manifest
+++ b/net-mail/uw-imap/Manifest
@@ -1,8 +1,9 @@
MD5 979bed91d308223958ffe9c988d744ad uw-imap-2002e-r2.ebuild 3108
MD5 7f6b3d166deb9a5536e6bb3ed0cdb03c uw-imap-2002e.ebuild 2932
MD5 3c8b9095f4bd5afcd95c93a076635c56 uw-imap-2002e-r1.ebuild 3093
+MD5 dd0e6852e53192074d9defc73d5c6bba uw-imap-2002e-r3.ebuild 3353
MD5 8dd3c14bf6b644035b66eb851612386e uw-imap-2002d-r1.ebuild 2935
-MD5 18887a3385fdb2eb801e7d3dd95677be ChangeLog 5164
+MD5 402b4278de8ab11ef2ff13ab0273e802 ChangeLog 5242
MD5 5721b86fd871bdfab77231abc6e02f68 metadata.xml 161
MD5 e4d5b81145aa085b4e36d86e6318dac1 uw-imap-2002d.ebuild 2586
MD5 506e7347cac698714cf5cd60eca761ba files/uw-ipop2.xinetd 563
@@ -17,3 +18,4 @@ MD5 f9441b5a20dd2477f12e0b0f04e2748d files/uw-imap.pam 243
MD5 1fc1132a6fb90046b701e9196e7a96b0 files/digest-uw-imap-2002d-r1 62
MD5 27b9eec6a66d66ef07109f82da8f10ce files/digest-uw-imap-2002e-r1 62
MD5 27b9eec6a66d66ef07109f82da8f10ce files/digest-uw-imap-2002e-r2 62
+MD5 27b9eec6a66d66ef07109f82da8f10ce files/digest-uw-imap-2002e-r3 62
diff --git a/net-mail/uw-imap/files/digest-uw-imap-2002e-r3 b/net-mail/uw-imap/files/digest-uw-imap-2002e-r3
new file mode 100644
index 000000000000..cbbff9d87969
--- /dev/null
+++ b/net-mail/uw-imap/files/digest-uw-imap-2002e-r3
@@ -0,0 +1 @@
+MD5 0d246d868f20d8c441d235b77c940676 imap-2002e.tar.Z 2157511
diff --git a/net-mail/uw-imap/uw-imap-2002e-r3.ebuild b/net-mail/uw-imap/uw-imap-2002e-r3.ebuild
new file mode 100644
index 000000000000..bd47e3139066
--- /dev/null
+++ b/net-mail/uw-imap/uw-imap-2002e-r3.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/uw-imap/uw-imap-2002e-r3.ebuild,v 1.1 2004/07/15 22:20:22 robbat2 Exp $
+
+inherit flag-o-matic
+
+MY_P=imap-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="UW server daemons for IMAP and POP network mail protocols."
+HOMEPAGE="http://www.washington.edu/imap/"
+SRC_URI="ftp://ftp.cac.washington.edu/imap/${MY_P}.tar.Z"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~hppa ~alpha ~amd64"
+IUSE="ssl"
+
+DEPEND="virtual/libc
+ >=sys-libs/pam-0.72
+ ssl? ( dev-libs/openssl )"
+# vimap and imap-c-client are both based off the same codebase
+RDEPEND="${DEPEND}
+ !net-mail/vimap
+ !virtual/imap-c-client
+ virtual/inetd"
+PROVIDE="virtual/imapd
+ virtual/imap-c-client"
+
+src_unpack() {
+ unpack ${A}
+ # Tarball packed with bad file perms
+ chmod -R ug+w ${S}
+
+ # lots of things need -fPIC, including various platforms, and this library
+ # generally should be built with it anyway.
+ append-flags -fPIC
+
+
+ # Modifications so we can build it optimially and correctly
+ sed \
+ -e "s:BASECFLAGS=\".*\":BASECFLAGS=\"${CFLAGS}\":g" \
+ -e 's:SSLDIR=/usr/local/ssl:SSLDIR=/usr:g' \
+ -e 's:SSLCERTS=$(SSLDIR)/certs:SSLCERTS=/etc/ssl/certs:g' \
+ -i ${S}/src/osdep/unix/Makefile || die "Makefile sed fixing failed"
+
+ # Uncomment this for MBX support
+ #cd ${S}/src/osdep/unix/
+ #cp Makefile Makefile.orig2
+ #sed \
+ # -e "s:CREATEPROTO=unixproto:CREATEPROTO=mbxproto:" \
+ # -e "s:EMPTYPROTO=unixproto:EMPTYPROTO=mbxproto:" \
+ # < Makefile.orig2 > Makefile
+ #cd ${S}
+
+ # Remove the pesky checks about SSL stuff
+ sed -e '/read.*exit/d' -i ${S}/Makefile
+}
+
+src_compile() {
+ if use ssl; then
+ cd ${S}
+ yes | make lnp SSLTYPE=unix || die
+
+ local i
+ for i in imapd ipop3d; do
+ umask 077
+ PEM1=`/bin/mktemp ${T}/openssl.XXXXXX`
+ PEM2=`/bin/mktemp ${T}/openssl.XXXXXX`
+ /usr/bin/openssl req -newkey rsa:1024 -keyout $$PEM1 \
+ -nodes -x509 -days 365 -out $$PEM2 << EOF
+--
+SomeState
+SomeCity
+SomeOrganization
+SomeOrganizationalUnit
+localhost.localdomain
+root@localhost.localdomain
+EOF
+
+ cat $$PEM1 > ${i}.pem
+ echo "" >> ${i}.pem
+ cat $$PEM2 >> ${i}.pem
+ rm $$PEM1 $$PEM2
+ umask 022
+ done
+ else
+ yes | make lnp SSLTYPE=none || die
+ fi
+}
+
+src_install() {
+ into /usr
+ dosbin imapd/imapd ipopd/ipop?d dmail/dmail tmail/tmail
+ dobin mailutil/mailutil mlock/mlock mtest/mtest
+
+ if use ssl; then
+ dodir /etc/ssl/certs
+ mv imapd.pem ${D}/etc/ssl/certs
+ mv ipop3d.pem ${D}/etc/ssl/certs
+ fi
+
+ insinto /usr/include/imap
+ doins c-client/{c-client,mail,imap4r1,rfc822,linkage,misc,smtp,nntp}.h
+ doins c-client/{osdep,env_unix,env,fs,ftl,nl,tcp}.h
+ dolib.a c-client/c-client.a
+ dosym /usr/lib/c-client.a /usr/lib/libc-client.a
+
+ doman src/ipopd/ipopd.8c src/imapd/imapd.8c
+ doman src/dmail/dmail.1 src/tmail/tmail.1 src/mailutil/mailutil.1
+
+ dodoc CPYRIGHT README docs/*.txt docs/CONFIG docs/RELNOTES
+
+ docinto rfc
+ dodoc docs/rfc/*.txt
+
+ # gentoo config stuff
+ insinto /etc/pam.d
+ newins ${FILESDIR}/uw-imap.pam-system-auth imap
+ newins ${FILESDIR}/uw-imap.pam-system-auth pop
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/uw-imap.xinetd imap
+ newins ${FILESDIR}/uw-ipop2.xinetd ipop2
+ newins ${FILESDIR}/uw-ipop3.xinetd ipop3
+ newins ${FILESDIR}/uw-ipop3s.xinetd ipop3s
+ newins ${FILESDIR}/uw-imaps.xinetd imaps
+}