summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2009-09-27 22:31:02 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2009-09-27 22:31:02 +0000
commit88d9305e54ce6e6bbc00d99fb73500dd9633f743 (patch)
tree6e20911696552cc0a08fcecee753f9828a7741b0
parentversion bump (diff)
downloadhistorical-88d9305e54ce6e6bbc00d99fb73500dd9633f743.tar.gz
historical-88d9305e54ce6e6bbc00d99fb73500dd9633f743.tar.bz2
historical-88d9305e54ce6e6bbc00d99fb73500dd9633f743.zip
Add xvid support by default (used by the Computer, PDA Generic, and DVD profiles in Arista)
Package-Manager: portage-2.2_rc42/cvs/Linux i686
-rw-r--r--media-video/arista/ChangeLog9
-rw-r--r--media-video/arista/Manifest3
-rw-r--r--media-video/arista/arista-0.9.3-r1.ebuild44
3 files changed, 54 insertions, 2 deletions
diff --git a/media-video/arista/ChangeLog b/media-video/arista/ChangeLog
index 42c738206358..3d1bac5a69de 100644
--- a/media-video/arista/ChangeLog
+++ b/media-video/arista/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/arista
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/arista/ChangeLog,v 1.1 2009/08/02 10:34:42 ford_prefect Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/arista/ChangeLog,v 1.2 2009/09/27 22:31:02 ford_prefect Exp $
+
+*arista-0.9.3-r1 (27 Sep 2009)
+
+ 27 Sep 2009; Arun Raghavan <ford_prefect@gentoo.org>
+ +arista-0.9.3-r1.ebuild:
+ Add xvid support by default (used by the Computer, PDA Generic, and DVD
+ profiles in Arista)
*arista-0.9.3 (02 Aug 2009)
diff --git a/media-video/arista/Manifest b/media-video/arista/Manifest
index 3f18e760f69c..0201e9192341 100644
--- a/media-video/arista/Manifest
+++ b/media-video/arista/Manifest
@@ -1,4 +1,5 @@
DIST arista-0.9.3.tar.gz 195937 RMD160 c4137b589b40a21753f85435758bfd2d98565064 SHA1 724b01956a5e3f94f9b4f37adf4c24aaa29303fd SHA256 1749b3ea5b46d69f728ef79cb5ed81e91df514f12bb77c99584998ad4d1eca5c
+EBUILD arista-0.9.3-r1.ebuild 1455 RMD160 573ca0f9ddbd5b059b7b5ee6c4e150317f686bda SHA1 a17f44bbbcffdb2e23a1cbbe51f6dd75bfadae60 SHA256 9a1904e76e85703931a77fbe8f0632dce8503d8f514652fe5a49f0563aea0d32
EBUILD arista-0.9.3.ebuild 1340 RMD160 7f4a4101bd9b4d3c96fe3ab8fea3e5268cda044d SHA1 0572d70abe3d31efa46b82135944e89c124afba2 SHA256 4bb96677e923482399d50671186f30764f62bfe088d64ad7ba96512cbe70a21d
-MISC ChangeLog 357 RMD160 bad260a845911b8a7ad29bec3ed06b109c2d7462 SHA1 ede3c584a3465657a27aa4ed0e53cece3e5caba1 SHA256 84958f40dfe11a0f0f0d219e5222cf60ebc4d5606afcddd4a79cd92ba59d28c7
+MISC ChangeLog 568 RMD160 b4313941d986111757fcb2730380eab58b49735d SHA1 c43e666d046bd864f9176b3ba02699a5e3351065 SHA256 747b334724527004b4a656d325befd847ef2096b7206e16c55b9ecc12bb13416
MISC metadata.xml 354 RMD160 218c4a47f4d6ea490baa538bede817b362ee60d8 SHA1 3a21275a32c07d27ee19d27bfb11e1ec1f2f6bc8 SHA256 039d5f7752dbfde8207e6c233b244966e86a7c5c11ce59f5dc8eb7126e083656
diff --git a/media-video/arista/arista-0.9.3-r1.ebuild b/media-video/arista/arista-0.9.3-r1.ebuild
new file mode 100644
index 000000000000..0229b4aadf32
--- /dev/null
+++ b/media-video/arista/arista-0.9.3-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/arista/arista-0.9.3-r1.ebuild,v 1.1 2009/09/27 22:31:02 ford_prefect Exp $
+
+EAPI=2
+
+inherit distutils
+
+DESCRIPTION="An easy to use multimedia transcoder for the GNOME Desktop"
+HOMEPAGE="http://programmer-art.org/projects/arista-transcoder"
+SRC_URI="http://programmer-art.org/media/releases/arista-transcoder/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+# Making these USE-defaults since encoding for portable devices is a very
+# common use case for Arista. xvid is being added since it's required for
+# DVD ripping
+IUSE="+faac +x264 +xvid"
+
+DEPEND="dev-python/setuptools"
+RDEPEND="dev-lang/python[xml]
+ >=x11-libs/gtk+-2.16
+ >=dev-python/pygtk-2.14
+ dev-python/pygobject
+ dev-python/pycairo
+ dev-python/gconf-python
+ dev-python/dbus-python
+ >=media-libs/gstreamer-0.10.22
+ dev-python/gst-python
+ media-libs/gst-plugins-base:0.10
+ media-libs/gst-plugins-good:0.10
+ media-plugins/gst-plugins-meta:0.10
+ media-plugins/gst-plugins-ffmpeg:0.10
+ faac? ( media-plugins/gst-plugins-faac:0.10 )
+ x264? ( media-plugins/gst-plugins-x264:0.10 )
+ xvid? ( media-plugins/gst-plugins-xvid:0.10 )"
+
+pkg_postinst()
+{
+ einfo "If you find that a format you want is not supported in Arista,"
+ einfo "please make sure that you have the corresponding USE-flag enabled"
+ einfo "media-plugins/gst-plugins-meta"
+}