summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-08-01 23:34:07 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-08-01 23:34:07 +0000
commit8407bff128f8a8e9cd4bd6a90b386f115ebce37c (patch)
treefb7da4285db7f11dc79fe2c96d7d10b1e689cc16
parentRemoved conflicts with x11-misc/shared-mime-info noted by bug 99900 (diff)
downloadhistorical-8407bff128f8a8e9cd4bd6a90b386f115ebce37c.tar.gz
historical-8407bff128f8a8e9cd4bd6a90b386f115ebce37c.tar.bz2
historical-8407bff128f8a8e9cd4bd6a90b386f115ebce37c.zip
Replace -lthr with -lpthread, else amarok dies on Gentoo/FreeBSD.
Package-Manager: portage-2.0.51.22-r2
-rw-r--r--media-libs/tunepimp/ChangeLog6
-rw-r--r--media-libs/tunepimp/Manifest14
-rw-r--r--media-libs/tunepimp/tunepimp-0.3.0-r1.ebuild13
3 files changed, 27 insertions, 6 deletions
diff --git a/media-libs/tunepimp/ChangeLog b/media-libs/tunepimp/ChangeLog
index 5ea6d0a2102a..1d2ca1d9cc8c 100644
--- a/media-libs/tunepimp/ChangeLog
+++ b/media-libs/tunepimp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/tunepimp
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tunepimp/ChangeLog,v 1.25 2005/07/02 00:16:48 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tunepimp/ChangeLog,v 1.26 2005/08/01 23:34:07 flameeyes Exp $
+
+ 01 Aug 2005; Diego Pettenò <flameeyes@gentoo.org>
+ tunepimp-0.3.0-r1.ebuild:
+ Replace -lthr with -lpthread, else amarok dies on Gentoo/FreeBSD.
02 Jul 2005; Hardave Riar <hardave@gentoo.org> tunepimp-0.3.0.ebuild:
Stable on mips
diff --git a/media-libs/tunepimp/Manifest b/media-libs/tunepimp/Manifest
index 23f3cc3946a1..0b9f3b64a757 100644
--- a/media-libs/tunepimp/Manifest
+++ b/media-libs/tunepimp/Manifest
@@ -1,7 +1,17 @@
-MD5 271cbbc553cc01cd5875419ae439acb1 ChangeLog 2813
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 328b5fda5c295f45fd6e54921d787847 ChangeLog 2965
MD5 acc03a4b12bb0433a57e95bd253b9501 metadata.xml 156
-MD5 48ddd931c4283c2a1f01bdda2b91af53 tunepimp-0.3.0-r1.ebuild 1601
MD5 23bbf2a6b56b2d5c6e4538544079076a tunepimp-0.3.0.ebuild 1522
+MD5 99d32047422c664f0e9effe26650114c tunepimp-0.3.0-r1.ebuild 1713
MD5 f79074eba8191dbaded3e898a9e6faf9 files/digest-tunepimp-0.3.0 69
MD5 f79074eba8191dbaded3e898a9e6faf9 files/digest-tunepimp-0.3.0-r1 69
MD5 9df04c3c157b652e3e895eeabb7015e6 files/thread.patch 393
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFC7rGDj5H05b2HAEkRArT3AKCdxEvCfF+HXobcBDOgiETUwplCygCfX4ej
+0IQz8KUSIxQj2CJAfb+uPt0=
+=Gjvy
+-----END PGP SIGNATURE-----
diff --git a/media-libs/tunepimp/tunepimp-0.3.0-r1.ebuild b/media-libs/tunepimp/tunepimp-0.3.0-r1.ebuild
index 0de2c4ff89c6..d981f0d4b9f5 100644
--- a/media-libs/tunepimp/tunepimp-0.3.0-r1.ebuild
+++ b/media-libs/tunepimp/tunepimp-0.3.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tunepimp/tunepimp-0.3.0-r1.ebuild,v 1.11 2005/06/17 20:38:43 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tunepimp/tunepimp-0.3.0-r1.ebuild,v 1.12 2005/08/01 23:34:07 flameeyes Exp $
inherit eutils distutils perl-module
@@ -25,11 +25,18 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/lib${P}
-src_compile() {
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/thread.patch
+
# do not try to link against obsolete libtermcap
sed -i -e 's,-ltermcap,-lncurses,' configure
+ sed -i -e 's:-lthr:-lpthread:g' ${S}/lib/threads/posix/Makefile.in
+}
- epatch ${FILESDIR}/thread.patch
+src_compile() {
econf || die "configure failed"
emake || die "emake failed"
if use perl; then