summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2003-01-29 19:09:47 +0000
committerHannes Mehnert <hannes@gentoo.org>2003-01-29 19:09:47 +0000
commit78ccb9681ff853ddde368a0f6eae453d5ae88ead (patch)
tree697e6cd998d59e49f2232d3d72c7cb72e8825846
parentreflect svgalib not available on alpha in profile as well as ebuilds (diff)
downloadhistorical-78ccb9681ff853ddde368a0f6eae453d5ae88ead.tar.gz
historical-78ccb9681ff853ddde368a0f6eae453d5ae88ead.tar.bz2
historical-78ccb9681ff853ddde368a0f6eae453d5ae88ead.zip
version bump
-rw-r--r--net-im/licq/ChangeLog7
-rw-r--r--net-im/licq/files/digest-licq-1.2.41
-rw-r--r--net-im/licq/licq-1.2.4.ebuild64
3 files changed, 71 insertions, 1 deletions
diff --git a/net-im/licq/ChangeLog b/net-im/licq/ChangeLog
index ec306e08c9ba..bd3bb7c2559c 100644
--- a/net-im/licq/ChangeLog
+++ b/net-im/licq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/licq
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.9 2003/01/10 13:34:03 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/ChangeLog,v 1.10 2003/01/29 19:09:43 hannes Exp $
+
+*licq-1.2.4 (29 Jan 2003)
+
+ 29 Jan 2003; Hannes Mehnert <hannes@gentoo.org> licq-1.2.4.ebuild:
+ version bump
*licq-1.2.3 (10 Jan 2003)
diff --git a/net-im/licq/files/digest-licq-1.2.4 b/net-im/licq/files/digest-licq-1.2.4
new file mode 100644
index 000000000000..42f62183e2b1
--- /dev/null
+++ b/net-im/licq/files/digest-licq-1.2.4
@@ -0,0 +1 @@
+MD5 3267518199e440a2c7be5e608b05bfd4 licq-1.2.4.tar.bz2 2952409
diff --git a/net-im/licq/licq-1.2.4.ebuild b/net-im/licq/licq-1.2.4.ebuild
new file mode 100644
index 000000000000..0fccb9eac9b5
--- /dev/null
+++ b/net-im/licq/licq-1.2.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/licq/licq-1.2.4.ebuild,v 1.1 2003/01/29 19:09:43 hannes Exp $
+
+IUSE="ssl socks5 qt kde"
+
+DESCRIPTION="ICQ Client with v8 support"
+HOMEPAGE="http://www.licq.org"
+LICENSE="GPL-2"
+
+DEPEND="${DEPEND}
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ qt? ( >=x11-libs/qt-3.0.0 )"
+
+SRC_URI="http://download.sourceforge.net/licq/${P}.tar.bz2"
+SLOT="2"
+KEYWORDS="~x86"
+
+use kde && inherit kde-base
+use kde && need-kde 3.0
+
+src_compile() {
+
+ local first_conf
+ use ssl || first_conf = "${first_conf} --disable-openssl"
+ use socks5 && first_conf = "${first_conf} --enable-socks5"
+
+ ./configure --host=${CHOST} --prefix=/usr ${first_conf} || die
+ emake || die
+
+ if [ "`use qt`" ]
+ then
+ # A hack to build against the latest QT:
+ local v
+ for v in /usr/qt/[0-9]
+ do
+ [ -d "${v}" ] && export QTDIR="${v}"
+ done
+ use kde && kde_src_compile myconf
+ use kde && second_conf="${second_conf} ${myconf} --with-kde"
+
+ # note! watch the --prefix=/usr placement;
+ # licq itself installs into /usr, but the
+ # optional kde/qt interface (to which second_conf belogns)
+ # installs its files in $KDE3DIR/{lib,share}/licq
+
+ cd plugins/qt-gui
+ ./configure --host=${CHOST} ${second_conf} --prefix=/usr || die
+ emake || die
+ fi
+
+}
+
+src_install() {
+
+ cd ${S}
+ make DESTDIR=${D} install || die
+ if [ "`use qt`" ]
+ then
+ cd plugins/qt-gui
+ make DESTDIR=${D} install || die
+ fi
+
+}