summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-07-19 07:06:06 +0000
committerNed Ludd <solar@gentoo.org>2004-07-19 07:06:06 +0000
commit63f4fadaeffdc19d1aad7dc09a63ffca5bae1912 (patch)
treef0bedcf9e82863ce162374ff1a09a312bdf38888
parentversion bump. bug #55269 (diff)
downloadhistorical-63f4fadaeffdc19d1aad7dc09a63ffca5bae1912.tar.gz
historical-63f4fadaeffdc19d1aad7dc09a63ffca5bae1912.tar.bz2
historical-63f4fadaeffdc19d1aad7dc09a63ffca5bae1912.zip
version bump and added gnuconfig_updade call, needed for atleast uclibc and maybe others
-rw-r--r--sys-apps/texinfo/ChangeLog8
-rw-r--r--sys-apps/texinfo/Manifest4
-rw-r--r--sys-apps/texinfo/files/digest-texinfo-4.71
-rw-r--r--sys-apps/texinfo/texinfo-4.7.ebuild74
4 files changed, 85 insertions, 2 deletions
diff --git a/sys-apps/texinfo/ChangeLog b/sys-apps/texinfo/ChangeLog
index af932dcb11e2..10bc3b0d6315 100644
--- a/sys-apps/texinfo/ChangeLog
+++ b/sys-apps/texinfo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/texinfo
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/ChangeLog,v 1.40 2004/07/04 17:46:00 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/ChangeLog,v 1.41 2004/07/19 07:06:06 solar Exp $
+
+*texinfo-4.7 (19 Jul 2004)
+
+ 19 Jul 2004; <solar@gentoo.org> texinfo-4.7.ebuild:
+ version bump and added gnuconfig_updade call, needed for atleast uclibc and
+ maybe others
04 Jul 2004; <solar@gentoo.org> texinfo-4.6.ebuild:
added static USE flag to help assist when porting to new arches/libc's
diff --git a/sys-apps/texinfo/Manifest b/sys-apps/texinfo/Manifest
index eeba9c166bac..5ee884190e32 100644
--- a/sys-apps/texinfo/Manifest
+++ b/sys-apps/texinfo/Manifest
@@ -1,10 +1,12 @@
MD5 2203374b084a0248412b72161a0c0f79 texinfo-4.5.ebuild 1664
+MD5 bfb5bd95d62aea49807df0d3e14197e3 texinfo-4.7.ebuild 1779
MD5 b010ee0984e648992c747f4b17859dfa texinfo-4.3-r1.ebuild 1726
MD5 67f563e9ad137067bd16ccae9378de74 texinfo-4.6.ebuild 1689
-MD5 db4a0babad15f431f851cbb29715f180 ChangeLog 5260
+MD5 367b0ae7120303bf256b90f21ebccd58 ChangeLog 5436
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 3173c3b67a3ef4e594cf5ce1b8253504 files/digest-texinfo-4.3-r1 64
MD5 c14f75d4a1d21ae1776a9868bd0c0296 files/digest-texinfo-4.5 65
MD5 247b349c3d22ddbd4288247e611bb186 files/digest-texinfo-4.6 65
+MD5 a2c21c53079eb65c306a08d230d15b2b files/digest-texinfo-4.7 65
MD5 b8ed9b84ca8ab4c2ac4e628a8f928dcb files/install-info.patch 729
MD5 690fb86d0c0215155b1d18671099115a files/mkinfodir 7318
diff --git a/sys-apps/texinfo/files/digest-texinfo-4.7 b/sys-apps/texinfo/files/digest-texinfo-4.7
new file mode 100644
index 000000000000..7db9f45dcad5
--- /dev/null
+++ b/sys-apps/texinfo/files/digest-texinfo-4.7
@@ -0,0 +1 @@
+MD5 c2fa2ef957f0d728f821ae9b2362ef4e texinfo-4.7.tar.bz2 1418717
diff --git a/sys-apps/texinfo/texinfo-4.7.ebuild b/sys-apps/texinfo/texinfo-4.7.ebuild
new file mode 100644
index 000000000000..48afc23da44c
--- /dev/null
+++ b/sys-apps/texinfo/texinfo-4.7.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/texinfo/texinfo-4.7.ebuild,v 1.1 2004/07/19 07:06:06 solar Exp $
+
+inherit flag-o-matic gnuconfig
+
+DESCRIPTION="The GNU info program and utilities"
+HOMEPAGE="http://www.gnu.org/software/texinfo/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~ppc64 ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~s390"
+IUSE="nls build static"
+
+DEPEND="virtual/libc
+ !build? ( >=sys-libs/ncurses-5.2-r2
+ >=sys-apps/sed-4.0.5
+ nls? ( sys-devel/gettext ) )"
+
+RDEPEND="virtual/libc
+ !build? ( >=sys-libs/ncurses-5.2-r2 )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/doc
+ # Get the texinfo info page to have a proper name of texinfo.info
+ sed -i 's:setfilename texinfo:setfilename texinfo.info:' texinfo.txi
+
+ sed -i \
+ -e 's:INFO_DEPS = texinfo:INFO_DEPS = texinfo.info:' \
+ -e 's:texinfo\::texinfo.info\::' \
+ Makefile.in
+ # update config.sub/config.guess for newer arches.
+ gnuconfig_update
+}
+
+src_compile() {
+ local myconf=
+ if ! use nls || use build ; then
+ myconf="--disable-nls"
+ fi
+
+ use static && append-ldflags -static
+
+ export WANT_AUTOMAKE_1_6=1
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ if use build ; then
+ mv util/ginstall-info util/install-info
+ dobin makeinfo/makeinfo util/{install-info,texi2dvi,texindex}
+ else
+ make DESTDIR=${D} \
+ infodir=/usr/share/info \
+ install || die
+
+ exeinto /usr/sbin
+ doexe ${FILESDIR}/mkinfodir
+
+ if [ ! -f ${D}/usr/share/info/texinfo.info ] ; then
+ die "Could not install texinfo.info!!!"
+ fi
+
+ dodoc AUTHORS ChangeLog INTRODUCTION NEWS README TODO
+ docinto info
+ dodoc info/README
+ docinto makeinfo
+ dodoc makeinfo/README
+ fi
+}