summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2005-01-25 21:53:19 +0000
committerAndres Loeh <kosmikus@gentoo.org>2005-01-25 21:53:19 +0000
commit404a1f527255e79a687bda08b8700cac5245aa60 (patch)
tree4c06f174f0aad81992ebee0191805ff307d7db7d
parentAdd >=kde-base/konqueror-akregator-3.4.0_beta to hardmasked ebuilds. (diff)
downloadhistorical-404a1f527255e79a687bda08b8700cac5245aa60.tar.gz
historical-404a1f527255e79a687bda08b8700cac5245aa60.tar.bz2
historical-404a1f527255e79a687bda08b8700cac5245aa60.zip
handling of virtuals changed in portage so that dev-lang/ghc no longer emerges fine on vanilla systems; modified the ebuild temporarily to produce at least an informative errors message; hopefully, I'll find a real solution soon; cf. bug #79509
-rw-r--r--dev-lang/ghc/ChangeLog7
-rw-r--r--dev-lang/ghc/Manifest4
-rw-r--r--dev-lang/ghc/ghc-6.2.2.ebuild12
3 files changed, 19 insertions, 4 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index c0fdaaefe555..f61493df20f3 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ghc
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.49 2005/01/19 12:47:10 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.50 2005/01/25 21:53:19 kosmikus Exp $
+
+ 25 Jan 2005; Andres Loeh <kosmikus@gentoo.org> ghc-6.2.2.ebuild:
+ Dependency resolution for virtuals changed in portage. Temporily adapted the
+ ebuild to quit with an informative error message until a real solution comes
+ to mind. (Bug #79509)
19 Jan 2005; Andres Loeh <kosmikus@gentoo.org> ghc-6.2.2.ebuild:
Marked stable on x86.
diff --git a/dev-lang/ghc/Manifest b/dev-lang/ghc/Manifest
index e8f0ddc2418f..718ec24d1fe6 100644
--- a/dev-lang/ghc/Manifest
+++ b/dev-lang/ghc/Manifest
@@ -1,8 +1,8 @@
MD5 b3aca41dacac3a53ee3573cd6a17c7b5 ghc-6.2.1-r1.ebuild 5790
MD5 9c8c25714a043393277567279e652e16 ghc-6.2.ebuild 5003
MD5 9da4aa7cbf64e86dd7b84a2b1bfa3b2a ghc-6.0.1.ebuild 4712
-MD5 54da56775fa0d42ad326576728bfb458 ghc-6.2.2.ebuild 5071
-MD5 7af12dc347f95d2cb70b5cd8f4bd95f3 ChangeLog 9491
+MD5 66ac22c55e6e3a10f2f824a06d64f62b ghc-6.2.2.ebuild 5411
+MD5 01476d13b651b7aa0739b6357f6e089c ChangeLog 9741
MD5 a769ecfcd1cdd2d40986627df7dfb249 metadata.xml 224
MD5 96042998f565e1486e53050ae829f094 ghc-6.2-r1.ebuild 5185
MD5 ee4e4b2265839fca7a4c06d565a51334 files/ghc-updater 8068
diff --git a/dev-lang/ghc/ghc-6.2.2.ebuild b/dev-lang/ghc/ghc-6.2.2.ebuild
index 27e3ec00e6a1..21a67ddc8e94 100644
--- a/dev-lang/ghc/ghc-6.2.2.ebuild
+++ b/dev-lang/ghc/ghc-6.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.2.2.ebuild,v 1.9 2005/01/19 12:47:10 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.2.2.ebuild,v 1.10 2005/01/25 21:53:19 kosmikus Exp $
# Brief explanation of the bootstrap logic:
#
@@ -72,6 +72,16 @@ setup_cflags() {
check_cflags "-nopie -fno-stack-protector -fno-stack-protector-all"
}
+pkg_setup() {
+ if ! has_version virtual/ghc; then
+ eerror "This ebuild needs a version of GHC to bootstrap from."
+ eerror "Please emerge dev-lang/ghc-bin to get a binary version."
+ eerror "You can either use the binary version directly or emerge"
+ eerror "dev-lang/ghc afterwards."
+ die "virtual/ghc version required to build"
+ fi
+}
+
src_unpack() {
base_src_unpack