summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-08-14 16:19:43 +0000
committerAchim Gottinger <achim@gentoo.org>2001-08-14 16:19:43 +0000
commit2eab9e4fea756dda9932c91001625162cadace6b (patch)
treeeecfb6251fd214c77349892e55d824547308d684
parentkdebase needs exactly lame-2.88-r1 2.89 did not work, so I changed the depend... (diff)
downloadhistorical-2eab9e4fea756dda9932c91001625162cadace6b.tar.gz
historical-2eab9e4fea756dda9932c91001625162cadace6b.tar.bz2
historical-2eab9e4fea756dda9932c91001625162cadace6b.zip
Added a new prerealse and removed 2.0 which was 2.0_pre1
-rw-r--r--app-editors/quanta/files/digest-quanta-2.0_pre21
-rw-r--r--app-editors/quanta/quanta-2.0_pre2.ebuild (renamed from kde-apps/quanta/quanta-2.0-r1.ebuild)5
-rw-r--r--kde-apps/quanta/files/digest-quanta-2.0-r11
-rw-r--r--kde-apps/quanta/files/digest-quanta-2.0_pre21
-rw-r--r--kde-apps/quanta/quanta-2.0_pre2.ebuild34
5 files changed, 38 insertions, 4 deletions
diff --git a/app-editors/quanta/files/digest-quanta-2.0_pre2 b/app-editors/quanta/files/digest-quanta-2.0_pre2
new file mode 100644
index 000000000000..e8d652443361
--- /dev/null
+++ b/app-editors/quanta/files/digest-quanta-2.0_pre2
@@ -0,0 +1 @@
+MD5 bcdbed620bcf4447cb89b5d74a337b2b quanta-2.0-pr2.tar.bz2
diff --git a/kde-apps/quanta/quanta-2.0-r1.ebuild b/app-editors/quanta/quanta-2.0_pre2.ebuild
index 3777b71d0bca..744a0361e559 100644
--- a/kde-apps/quanta/quanta-2.0-r1.ebuild
+++ b/app-editors/quanta/quanta-2.0_pre2.ebuild
@@ -2,12 +2,11 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Philippe Namias <pnamias@gentoo.org>
-A=${P}-pr1.tar.bz2
+A=${PN}-2.0-pr2.tar.bz2
S=${WORKDIR}/quanta
DESCRIPTION="HTML editor for KDE2"
-SRC_URI="http://ftp1.sourceforge.net/quanta/${A}"
+SRC_URI="http://prdownloads.sourceforge.net/quanta/${A}"
HOMEPAGE="http://quanta.sourceforge.net"
-
DEPEND=">=kde-base/kdelibs-2.1.1"
RDEPEND=$DEPEND
diff --git a/kde-apps/quanta/files/digest-quanta-2.0-r1 b/kde-apps/quanta/files/digest-quanta-2.0-r1
deleted file mode 100644
index e41f2d2ffb86..000000000000
--- a/kde-apps/quanta/files/digest-quanta-2.0-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 dec00150b247d40162fa3941b56c3b93 quanta-2.0-pr1.tar.bz2
diff --git a/kde-apps/quanta/files/digest-quanta-2.0_pre2 b/kde-apps/quanta/files/digest-quanta-2.0_pre2
new file mode 100644
index 000000000000..e8d652443361
--- /dev/null
+++ b/kde-apps/quanta/files/digest-quanta-2.0_pre2
@@ -0,0 +1 @@
+MD5 bcdbed620bcf4447cb89b5d74a337b2b quanta-2.0-pr2.tar.bz2
diff --git a/kde-apps/quanta/quanta-2.0_pre2.ebuild b/kde-apps/quanta/quanta-2.0_pre2.ebuild
new file mode 100644
index 000000000000..744a0361e559
--- /dev/null
+++ b/kde-apps/quanta/quanta-2.0_pre2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Philippe Namias <pnamias@gentoo.org>
+
+A=${PN}-2.0-pr2.tar.bz2
+S=${WORKDIR}/quanta
+DESCRIPTION="HTML editor for KDE2"
+SRC_URI="http://prdownloads.sourceforge.net/quanta/${A}"
+HOMEPAGE="http://quanta.sourceforge.net"
+DEPEND=">=kde-base/kdelibs-2.1.1"
+
+RDEPEND=$DEPEND
+
+src_compile() {
+ local myconf
+ if [ "`use qtmt`" ]
+ then
+ myconf="--enable-mt"
+ fi
+ if [ "`use mitshm`" ]
+ then
+ myconf="$myconf --enable-mitshm"
+ fi
+ try ./configure --prefix=${KDEDIR} --host=${CHOST} $myconf
+ try make
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}
+