summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisa M. Seelye <lisa@gentoo.org>2006-03-20 16:09:33 +0000
committerLisa M. Seelye <lisa@gentoo.org>2006-03-20 16:09:33 +0000
commit2d19e6141bd0bba50055e9ef08f30dd35e11e767 (patch)
treee38ab7496ccc214a36ac18f40edbc15fd0326225
parentMarked stable on x86 (diff)
downloadhistorical-2d19e6141bd0bba50055e9ef08f30dd35e11e767.tar.gz
historical-2d19e6141bd0bba50055e9ef08f30dd35e11e767.tar.bz2
historical-2d19e6141bd0bba50055e9ef08f30dd35e11e767.zip
ccache-2.4-respectflags.patch from bug #126875 to respect user defined LDFLAGS
Package-Manager: portage-2.0.54
-rw-r--r--dev-util/ccache/ChangeLog8
-rw-r--r--dev-util/ccache/Manifest5
-rw-r--r--dev-util/ccache/ccache-2.4-r1.ebuild74
-rw-r--r--dev-util/ccache/files/ccache-2.4-respectflags.patch13
-rw-r--r--dev-util/ccache/files/digest-ccache-2.4-r11
5 files changed, 99 insertions, 2 deletions
diff --git a/dev-util/ccache/ChangeLog b/dev-util/ccache/ChangeLog
index c77d472b4bba..ff76fe7cf283 100644
--- a/dev-util/ccache/ChangeLog
+++ b/dev-util/ccache/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/ccache
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.41 2006/03/06 16:23:03 lisa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.42 2006/03/20 16:09:33 lisa Exp $
+
+*ccache-2.4-r1 (20 Mar 2006)
+
+ 20 Mar 2006; Lisa Seelye <lisa@gentoo.org>
+ +files/ccache-2.4-respectflags.patch, +ccache-2.4-r1.ebuild:
+ ccache-2.4-respectflags.patch from bug #126875 to respect user defined LDFLAGS
06 Mar 2006; Lisa Seelye <lisa@gentoo.org> ccache-2.2.ebuild,
ccache-2.3.ebuild, ccache-2.4.ebuild:
diff --git a/dev-util/ccache/Manifest b/dev-util/ccache/Manifest
index 5c68dd8f8c28..d3f53dfef1a7 100644
--- a/dev-util/ccache/Manifest
+++ b/dev-util/ccache/Manifest
@@ -1,9 +1,12 @@
-MD5 207798fd667193b0ba75f4c39ff9e408 ChangeLog 4987
+MD5 67f74a852987b029bc016648a45ef6e8 ChangeLog 5208
MD5 da9c02e7e8e50fefb7fc259354d004fa ccache-2.2.ebuild 2111
MD5 90b71c416670ef466b34d73fc9d9bbab ccache-2.3.ebuild 2033
+MD5 e5b58dc1b8025b130cfc8078728d9d7e ccache-2.4-r1.ebuild 2119
MD5 022d1231138f39cbb44c900cd8c32acd ccache-2.4.ebuild 2010
+MD5 ff94f3cf974deb56b1effb276dc9b6ea files/ccache-2.4-respectflags.patch 403
MD5 3a5de45f5094320a0ce4eb5201506042 files/ccache-config 1554
MD5 0dfb58c5d312454e0c766c14f3d76dad files/digest-ccache-2.2 61
MD5 6bbfd5ad2a75fbaf4b4a5e42fc61270a files/digest-ccache-2.3 61
MD5 4ec9394758a87717466629023c2872fd files/digest-ccache-2.4 61
+MD5 4ec9394758a87717466629023c2872fd files/digest-ccache-2.4-r1 61
MD5 0e91c81450afb11a7d06d7543dddcd57 metadata.xml 386
diff --git a/dev-util/ccache/ccache-2.4-r1.ebuild b/dev-util/ccache/ccache-2.4-r1.ebuild
new file mode 100644
index 000000000000..1dace7232deb
--- /dev/null
+++ b/dev-util/ccache/ccache-2.4-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-2.4-r1.ebuild,v 1.1 2006/03/20 16:09:33 lisa Exp $
+
+inherit eutils
+
+DESCRIPTION="fast compiler cache"
+HOMEPAGE="http://ccache.samba.org/"
+SRC_URI="http://samba.org/ftp/ccache/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-macos"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+# Note: this version is designed to be auto-detected and used if
+# you happen to have Portage 2.0.X+ installed.
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/ccache-2.4-respectflags.patch
+}
+
+src_install() {
+ dobin ccache || die
+ doman ccache.1
+ dodoc README
+ dohtml web/*.html
+
+ diropts -m0755
+ dodir /usr/lib/ccache/bin
+ keepdir /usr/lib/ccache/bin
+
+ exeinto /usr/bin
+ doexe ${FILESDIR}/ccache-config
+
+ diropts -m0700
+ if use ppc-macos; then
+ dodir /var/root/.ccache
+ keepdir /var/root/.ccache
+ else
+ dodir /root/.ccache
+ keepdir /root/.ccache
+ fi
+}
+
+pkg_preinst() {
+ # Portage doesn't handle replacing a non-empty dir with a file!
+ [[ -e ${ROOT}/usr/bin/ccache ]] && rm -r "${ROOT}"/usr/bin/ccache
+ [[ -e ${ROOT}/usr/bin/ccache.backup ]] && rm -r "${ROOT}"/usr/bin/ccache.backup
+}
+
+pkg_postinst() {
+ if [[ ${ROOT} = "/" ]] ; then
+ einfo "Scanning for compiler front-ends..."
+ /usr/bin/ccache-config --install-links
+ /usr/bin/ccache-config --install-links ${CHOST}
+ else
+ ewarn "Install is incomplete; you must run the following commands:"
+ ewarn " # ccache-config --install-links"
+ ewarn " # ccache-config --install-links ${CHOST}"
+ ewarn "after booting or chrooting to ${ROOT} to complete installation."
+ fi
+
+ einfo "To use ccache with **non-Portage** C compiling, add"
+ einfo "/usr/lib/ccache/bin to the beginning of your path, before /usr/bin."
+ einfo "Portage 2.0.46-r11+ will automatically take advantage of ccache with"
+ einfo "no additional steps. If this is your first install of ccache, type"
+ einfo "something like this to set a maximum cache size of 2GB:"
+ einfo "# ccache -M 2G"
+}
diff --git a/dev-util/ccache/files/ccache-2.4-respectflags.patch b/dev-util/ccache/files/ccache-2.4-respectflags.patch
new file mode 100644
index 000000000000..38d5f6a590d8
--- /dev/null
+++ b/dev-util/ccache/files/ccache-2.4-respectflags.patch
@@ -0,0 +1,13 @@
+Index: ccache-2.4/Makefile.in
+===================================================================
+--- ccache-2.4.orig/Makefile.in
++++ ccache-2.4/Makefile.in
+@@ -20,7 +20,7 @@ all: ccache$(EXEEXT)
+ docs: ccache.1 web/ccache-man.html
+
+ ccache$(EXEEXT): $(OBJS) $(HEADERS)
+- $(CC) $(CFLAGS) -o $@ $(OBJS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJS)
+
+ ccache.1: ccache.yo
+ -yodl2man -o ccache.1 ccache.yo
diff --git a/dev-util/ccache/files/digest-ccache-2.4-r1 b/dev-util/ccache/files/digest-ccache-2.4-r1
new file mode 100644
index 000000000000..309204b80d28
--- /dev/null
+++ b/dev-util/ccache/files/digest-ccache-2.4-r1
@@ -0,0 +1 @@
+MD5 73c1ed1e767c1752dd0f548ec1e66ce7 ccache-2.4.tar.gz 86363