summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/gbase/gbase-0.5-r2.ebuild')
-rw-r--r--x11-misc/gbase/gbase-0.5-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-misc/gbase/gbase-0.5-r2.ebuild b/x11-misc/gbase/gbase-0.5-r2.ebuild
new file mode 100644
index 000000000000..c24962442fd6
--- /dev/null
+++ b/x11-misc/gbase/gbase-0.5-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A convert program for decimal, hexadecimal, octal and binary values"
+HOMEPAGE="http://www.fluxcode.net"
+SRC_URI="http://www.fluxcode.net/files/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="amd64 x86"
+RESTRICT="test" #424671
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-gtk.patch )
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+}
+
+src_install() {
+ dobin gbase
+ einstalldocs
+}