summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/basqet')
-rw-r--r--x11-misc/basqet/Manifest2
-rw-r--r--x11-misc/basqet/basqet-0.1.4.ebuild26
-rw-r--r--x11-misc/basqet/basqet-0.2.0.ebuild30
-rw-r--r--x11-misc/basqet/files/basqet-0.2.0-desktop.patch14
-rw-r--r--x11-misc/basqet/metadata.xml8
5 files changed, 80 insertions, 0 deletions
diff --git a/x11-misc/basqet/Manifest b/x11-misc/basqet/Manifest
new file mode 100644
index 000000000000..259656427824
--- /dev/null
+++ b/x11-misc/basqet/Manifest
@@ -0,0 +1,2 @@
+DIST basqet_0.1.4-src.tgz 153422 SHA256 ad8187510fcc8c211e049053c0c10eeb4a3719856c17b1ecd8d0501406e4c967
+DIST basqet_0.2.0-src.tgz 471700 SHA256 46a66a61af82b57c5fc6be40565837dab785f1dbb375656cf207ef08eb09f8a2
diff --git a/x11-misc/basqet/basqet-0.1.4.ebuild b/x11-misc/basqet/basqet-0.1.4.ebuild
new file mode 100644
index 000000000000..c541946b9ce1
--- /dev/null
+++ b/x11-misc/basqet/basqet-0.1.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit eutils qt4-r2
+
+DESCRIPTION="Keep your notes, pictures, ideas, and information in Baskets"
+HOMEPAGE="http://code.google.com/p/basqet/"
+SRC_URI="http://basqet.googlecode.com/files/${PN}_${PV}-src.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtgui:4
+ dev-qt/qtxmlpatterns:4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt4-r2_src_prepare
+
+ sed -i 's:PREFIX = /usr/local:PREFIX = /usr:' ${PN}.pro || die
+}
diff --git a/x11-misc/basqet/basqet-0.2.0.ebuild b/x11-misc/basqet/basqet-0.2.0.ebuild
new file mode 100644
index 000000000000..ab66136dba7e
--- /dev/null
+++ b/x11-misc/basqet/basqet-0.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit qt4-r2
+
+DESCRIPTION="Keep your notes, pictures, ideas, and information in Baskets"
+HOMEPAGE="http://code.google.com/p/basqet/"
+SRC_URI="http://basqet.googlecode.com/files/${PN}_${PV}-src.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/release_${PV}
+
+PATCHES=( "${FILESDIR}/${P}-desktop.patch" )
+
+src_prepare() {
+ qt4-r2_src_prepare
+
+ sed -i 's:PREFIX = /usr/local:PREFIX = /usr:' ${PN}.pro || die
+}
diff --git a/x11-misc/basqet/files/basqet-0.2.0-desktop.patch b/x11-misc/basqet/files/basqet-0.2.0-desktop.patch
new file mode 100644
index 000000000000..161ad1d8fd3c
--- /dev/null
+++ b/x11-misc/basqet/files/basqet-0.2.0-desktop.patch
@@ -0,0 +1,14 @@
+--- basqet.desktop
++++ basqet.desktop
+@@ -1,9 +1,9 @@
+ [Desktop Entry]
+-Version=0.2.0
++Version=1.0
+ Terminal=false
+ TryExec=basqet
+ Exec=basqet
+-Icon=basqet.png
++Icon=basqet
+ Type=Application
+ Categories=Office;WordProcessor;
+ StartupNotify=false
diff --git a/x11-misc/basqet/metadata.xml b/x11-misc/basqet/metadata.xml
new file mode 100644
index 000000000000..7aa61dde7f6e
--- /dev/null
+++ b/x11-misc/basqet/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <upstream>
+ <remote-id type="google-code">basqet</remote-id>
+ </upstream>
+</pkgmetadata>