summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-misc/shellinabox/shellinabox-2.20-r3.ebuild')
-rw-r--r--www-misc/shellinabox/shellinabox-2.20-r3.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/www-misc/shellinabox/shellinabox-2.20-r3.ebuild b/www-misc/shellinabox/shellinabox-2.20-r3.ebuild
index dd3929f75bfe..4ddaef132e05 100644
--- a/www-misc/shellinabox/shellinabox-2.20-r3.ebuild
+++ b/www-misc/shellinabox/shellinabox-2.20-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools systemd
+inherit user autotools systemd
DESCRIPTION="Export command line tools to a web based terminal emulator"
HOMEPAGE="https://github.com/shellinabox/shellinabox"
@@ -14,12 +14,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="+pam"
-RDEPEND="
- acct-user/shellinaboxd
- acct-group/shellinaboxd"
-
DEPEND="
- ${RDEPEND}
dev-libs/openssl:0=
pam? ( sys-libs/pam )"
@@ -39,6 +34,11 @@ cat server.crt server.key > certificate.pem
EOF
}
+pkg_setup() {
+ enewgroup "${SIAB_DAEMON}"
+ enewuser "${SIAB_DAEMON}" -1 -1 -1 "${SIAB_DAEMON}"
+}
+
src_prepare() {
default
eautoreconf
@@ -77,6 +77,7 @@ src_install() {
# Create directory where SSL certificates will be generated.
dodir "${SIAB_CERT_DIR}"
+ fowners "${SIAB_DAEMON}:${SIAB_DAEMON}" "${SIAB_CERT_DIR}"
# Generate set up variable.
shellinbox_gen_ssl_setup