summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/httrack/httrack-3.48.21.ebuild')
-rw-r--r--www-client/httrack/httrack-3.48.21.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/www-client/httrack/httrack-3.48.21.ebuild b/www-client/httrack/httrack-3.48.21.ebuild
new file mode 100644
index 000000000000..3134384ed67d
--- /dev/null
+++ b/www-client/httrack/httrack-3.48.21.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="HTTrack Website Copier, Open Source Offline Browser"
+HOMEPAGE="http://www.httrack.com/"
+SRC_URI="http://mirror.httrack.com/historical/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND=">=sys-libs/zlib-1.2.5.1-r1
+ dev-libs/openssl"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS README greetings.txt history.txt )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.48.13-minizip.patch
+}
+
+src_configure() {
+ econf $(use_enable static-libs static) \
+ --docdir=/usr/share/doc/${PF} \
+ --htmldir=/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}