summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/venus')
-rw-r--r--www-apps/venus/Manifest1
-rw-r--r--www-apps/venus/files/postinstall-en.txt10
-rw-r--r--www-apps/venus/metadata.xml14
-rw-r--r--www-apps/venus/venus-20100911.ebuild79
4 files changed, 104 insertions, 0 deletions
diff --git a/www-apps/venus/Manifest b/www-apps/venus/Manifest
new file mode 100644
index 000000000000..d07ac1ed68c1
--- /dev/null
+++ b/www-apps/venus/Manifest
@@ -0,0 +1 @@
+DIST venus-20100911.tar.bz2 349639 SHA256 72e19495518ade6641a3c50346374b4868b232d58a32fa18be387ae4a151dc03
diff --git a/www-apps/venus/files/postinstall-en.txt b/www-apps/venus/files/postinstall-en.txt
new file mode 100644
index 000000000000..37427c4a8d5a
--- /dev/null
+++ b/www-apps/venus/files/postinstall-en.txt
@@ -0,0 +1,10 @@
+INSTALLATION
+
+Installation instructions can be found at:
+
+http://intertwingly.net/code/venus/docs/
+/usr/share/doc/\${PF}/html
+
+Example configuration files can be found at:
+
+${VHOST_ROOT}/conf
diff --git a/www-apps/venus/metadata.xml b/www-apps/venus/metadata.xml
new file mode 100644
index 000000000000..6b3fc620a69e
--- /dev/null
+++ b/www-apps/venus/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>web-apps</herd>
+ <maintainer>
+ <email>tampakrap@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="django">Support for django template style to config files</flag>
+ <flag name="genshi">Support for genshi style to config files</flag>
+ <flag name="redland">Enable support for Redland RDF</flag>
+ </use>
+</pkgmetadata>
+
diff --git a/www-apps/venus/venus-20100911.ebuild b/www-apps/venus/venus-20100911.ebuild
new file mode 100644
index 000000000000..69e148a5e095
--- /dev/null
+++ b/www-apps/venus/venus-20100911.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit webapp python
+
+WEBAPP_MANUAL_SLOT="yes"
+
+DESCRIPTION="A feed aggregator application"
+HOMEPAGE="http://intertwingly.net/code/venus/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="PSF-2.2"
+KEYWORDS="~amd64 ~x86"
+IUSE="django genshi redland test"
+SLOT="0"
+
+DEPEND="
+ test? ( =dev-lang/python-2*[berkdb] )
+ "
+RDEPEND="django? ( dev-python/django )
+ genshi? ( dev-python/genshi )
+ redland? ( dev-python/rdflib[redland] )
+ dev-python/chardet
+ dev-python/httplib2
+ dev-python/utidylib
+"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" runtests.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc AUTHORS README TODO
+ dohtml -r docs/*
+
+ installation() {
+ insinto "$(python_get_sitedir)/${PN}"
+ doins -r *py {filters,planet}
+ }
+ python_execute_function installation
+
+ insinto "${MY_APPDIR}"
+ doins -r themes
+
+ insinto "${MY_HOSTROOTDIR}/conf"
+ doins -r examples
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ python_mod_optimize venus
+ webapp_pkg_postinst
+ elog "Installation instructions can be found at /usr/share/doc/${PF}/html/
+ or http://intertwingly.net/code/venus/docs/index.html"
+}
+
+pkg_postrm() {
+ python_mod_cleanup venus
+}