summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/at/files/at-3.2.5-Makefile.binary-permission-fix.patch')
-rw-r--r--sys-process/at/files/at-3.2.5-Makefile.binary-permission-fix.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/sys-process/at/files/at-3.2.5-Makefile.binary-permission-fix.patch b/sys-process/at/files/at-3.2.5-Makefile.binary-permission-fix.patch
new file mode 100644
index 000000000000..af83b6e25b37
--- /dev/null
+++ b/sys-process/at/files/at-3.2.5-Makefile.binary-permission-fix.patch
@@ -0,0 +1,12 @@
+diff -Naur at-3.2.5-orig/Makefile.in at-3.2.5/Makefile.in
+--- at-3.2.5-orig/Makefile.in 2022-02-05 02:00:57.000000000 -0800
++++ at-3.2.5/Makefile.in 2023-07-27 20:49:58.505824137 -0700
+@@ -114,7 +114,7 @@
+ chmod 600 $(DESTDIR)$(LFILE)
+ chown $(DAEMON_USERNAME):$(DAEMON_GROUPNAME) $(DESTDIR)$(LFILE)
+ test -f $(DESTDIR)$(etcdir)/at.allow || test -f $(DESTDIR)$(etcdir)/at.deny || $(INSTALL) -o root -g $(DAEMON_GROUPNAME) -m 640 at.deny $(DESTDIR)$(etcdir)/
+- $(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 6755 at $(DESTDIR)$(bindir)
++ $(INSTALL) -g $(DAEMON_GROUPNAME) -o root -m 6755 at $(DESTDIR)$(bindir)
+ $(LN_S) -f at $(DESTDIR)$(bindir)/atq
+ $(LN_S) -f at $(DESTDIR)$(bindir)/atrm
+ $(INSTALL) -g root -o root -m 755 batch $(DESTDIR)$(bindir)