summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/open-mx/Manifest1
-rw-r--r--sys-cluster/open-mx/files/omxoed.initd45
-rw-r--r--sys-cluster/open-mx/files/open-mx-1.4.0-driver.patch14
-rw-r--r--sys-cluster/open-mx/metadata.xml12
-rw-r--r--sys-cluster/open-mx/open-mx-1.5.4.ebuild78
5 files changed, 0 insertions, 150 deletions
diff --git a/sys-cluster/open-mx/Manifest b/sys-cluster/open-mx/Manifest
deleted file mode 100644
index ef6ebf236362..000000000000
--- a/sys-cluster/open-mx/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST open-mx-1.5.4.tar.gz 1094452 BLAKE2B 324db9b2cfeaba3ee057fd3f7c163b0085a57c022be1d170e37bee21c952a49a48bc53cd301e186eb2a0fa837be702fe3a187ce2fbebaf8aa22173bd25f907b1 SHA512 df41132de0c6f7a20a1cdb9aff3c654d5e306771369c12086affda785686e1a3ed23ba82e617618ebbd72ffa3b32d1f3c76e4450d6ab772d9e5a3080f6a3e977
diff --git a/sys-cluster/open-mx/files/omxoed.initd b/sys-cluster/open-mx/files/omxoed.initd
deleted file mode 100644
index 765842ed7f68..000000000000
--- a/sys-cluster/open-mx/files/omxoed.initd
+++ /dev/null
@@ -1,45 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- need net
-}
-
-checksystem() {
- if [ -c /dev/open-mx ]; then
- einfo "Open-MX module already loaded"
- return 0
- else
- einfo "Checking if Open-MX module present"
- if [ "x$(modprobe -l open-mx | grep open-mx)" == "x" ]; then
- eerror "open-mx not found!"
- return 1
- fi
- fi
-}
-
-start() {
- ebegin "Starting ${SVCNAME}"
- checksystem || return 1
- if [ ! -c /dev/open-mx ]; then
- ebegin "Loading open-mx module"
- modprobe -q open-mx
- fi
- start-stop-daemon --start --exec /usr/bin/omxoed \
- --background --make-pidfile \
- --pidfile /var/run/omeoed.pid
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop --exec /usr/bin/omxoed \
- --pidfile /var/run/omeoed.pid
- eend $?
-}
-
-status() {
- ebegin "Showing current active Open-MX peers"
- omx_info -q
-}
diff --git a/sys-cluster/open-mx/files/open-mx-1.4.0-driver.patch b/sys-cluster/open-mx/files/open-mx-1.4.0-driver.patch
deleted file mode 100644
index e082865c235a..000000000000
--- a/sys-cluster/open-mx/files/open-mx-1.4.0-driver.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- Makefile.am 2011-07-15 02:42:53.000000000 +0400
-+++ Makefile.am 2011-07-15 02:43:02.000000000 +0400
-@@ -20,11 +20,6 @@
-
- SUBDIRS =
-
--# Driver
--if OMX_BUILD_DRIVER
-- SUBDIRS += driver/linux
--endif
--
- # Library
- if OMX_BUILD_LIBRARY
- SUBDIRS += libopen-mx tools tests tests/mx
diff --git a/sys-cluster/open-mx/metadata.xml b/sys-cluster/open-mx/metadata.xml
deleted file mode 100644
index fc70a30f312d..000000000000
--- a/sys-cluster/open-mx/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>alexxy@gentoo.org</email>
- <name>Alexey Shvetsov</name>
- </maintainer>
-<maintainer type="project">
- <email>cluster@gentoo.org</email>
- <name>Gentoo Cluster Project</name>
- </maintainer>
-</pkgmetadata>
diff --git a/sys-cluster/open-mx/open-mx-1.5.4.ebuild b/sys-cluster/open-mx/open-mx-1.5.4.ebuild
deleted file mode 100644
index ac461bfced30..000000000000
--- a/sys-cluster/open-mx/open-mx-1.5.4.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit autotools eutils linux-mod multilib toolchain-funcs udev
-
-DESCRIPTION="Open-MX - Myrinet Express over Generic Ethernet Hardware"
-HOMEPAGE="http://open-mx.gforge.inria.fr/"
-SRC_URI="http://gforge.inria.fr/frs/download.php/34371/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug modules static-libs"
-
-DEPEND="
- sys-apps/hwloc
- virtual/linux-sources
- virtual/pkgconfig"
-RDEPEND="
- sys-apps/hwloc
- virtual/modutils"
-
-MODULE_NAMES="open-mx(misc:${S}/driver/linux)"
-BUILD_TARGETS="all"
-BUILD_PARAMS="KDIR=${KERNEL_DIR}"
-
-pkg_setup() {
- einfo "You can set desired mtu by setting OPEN_MX_MTU in make.conf"
- linux-mod_pkg_setup
-}
-
-src_prepare() {
- # We still want to configure driver but dont want to build it at all
- epatch "${FILESDIR}/open-mx-1.4.0-driver.patch"
- # We dont want tests
- sed -e 's:tests/mx::g' \
- -e 's:tests::g' \
- -i Makefile.am || die "sed failed"
- eautoreconf
-}
-
-src_configure() {
- econf \
- --with-mtu=${OPEN_MX_MTU:-9000} \
- --with-linux="${KERNEL_DIR}" \
- --with-linux-release=${KV_FULL} \
- $(use_enable static-libs static) \
- $(use_enable debug)
-}
-
-src_compile() {
- default
- if use modules; then
- cd "${S}/driver/linux"
- linux-mod_src_compile || die "failed to build driver"
- fi
-}
-
-src_install() {
- default
- use static-libs || find "${ED}" -name '*.*a' -exec rm {} +
- # Drop init scripts
- rm -rf "${ED}/usr/sbin" || die
- rm "${ED}/usr/bin/omx_check"
- # install udev rules
- udev_dorules "${ED}/etc/open-mx/10-open-mx.rules"
- dodoc "${ED}/usr/share/open-mx/FAQ.html"
- # Drop misc stuff
- rm "${ED}/etc/open-mx/10-open-mx.rules" || die
- rm -rf "${ED}/usr/share/open-mx" || die
- newinitd "${FILESDIR}/omxoed.initd" omxoed
- if use modules; then
- cd "${S}/driver/linux"
- linux-mod_src_install || die "failed to install driver"
- fi
-}