summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/cpuid')
-rw-r--r--sys-apps/cpuid/Manifest1
-rw-r--r--sys-apps/cpuid/cpuid-20230614.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/cpuid/Manifest b/sys-apps/cpuid/Manifest
index f4227e8a50df..ba028cbf0d50 100644
--- a/sys-apps/cpuid/Manifest
+++ b/sys-apps/cpuid/Manifest
@@ -1 +1,2 @@
DIST cpuid-20230505.src.tar.gz 148584 BLAKE2B 6f1e6f9666b22d3df8e93ff695a650d2cd6d8c12531ede58d2f9517bbd03e2bd833645a7ea26df23c2edee78507b2ffb9697684c3d702c5aae48dca6e97222f8 SHA512 695b7bab729526021decef57e938d74188bfa4e918435367550f950373760e726b60a278ccb92c91013624a06c077124182f51077b50f60b1dbabf4ff1740461
+DIST cpuid-20230614.src.tar.gz 149777 BLAKE2B 5ebfd7d055f2b67cd158dd6eaa5467a5776170a879a4323e2dc103e8b84f4cf72523d5ae5272d2f89ae6555f597d903bdf149f279f9565bf88a1e26b0e574606 SHA512 46698e5565d1c558e50b9526154489d82ada64ea5dbcebc01e3cd34b79b2b646f324deaf7d63678cd477d227e902437c3ff6c7998b4385ddd373aa1fc76ff70c
diff --git a/sys-apps/cpuid/cpuid-20230614.ebuild b/sys-apps/cpuid/cpuid-20230614.ebuild
new file mode 100644
index 000000000000..18c1efcd3afe
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20230614.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux tool to dump x86 CPUID information about the CPUs"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+BDEPEND="
+ app-arch/gzip
+ dev-lang/perl
+"
+
+DOCS=( "ChangeLog" "FUTURE" )
+
+PATCHES=( "${FILESDIR}/${PN}-20220620-makefile.patch" )
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ emake BUILDROOT="${ED}" install
+
+ einstalldocs
+}