summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/coq/coq-8.17.0.ebuild')
-rw-r--r--sci-mathematics/coq/coq-8.17.0.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/sci-mathematics/coq/coq-8.17.0.ebuild b/sci-mathematics/coq/coq-8.17.0.ebuild
index 19df902424b8..f8376e6eeb69 100644
--- a/sci-mathematics/coq/coq-8.17.0.ebuild
+++ b/sci-mathematics/coq/coq-8.17.0.ebuild
@@ -53,6 +53,13 @@ BDEPEND="
DOCS=( CODE_OF_CONDUCT.md CONTRIBUTING.md CREDITS INSTALL.md README.md )
+src_prepare() {
+ # Remove failing tests. bug #859877
+ rm -r test-suite/coq-makefile/timing || die
+
+ default
+}
+
src_configure() {
export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"