summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/qgis/files/qgis-1.8.0-no-python-pyc.patch')
-rw-r--r--sci-geosciences/qgis/files/qgis-1.8.0-no-python-pyc.patch54
1 files changed, 0 insertions, 54 deletions
diff --git a/sci-geosciences/qgis/files/qgis-1.8.0-no-python-pyc.patch b/sci-geosciences/qgis/files/qgis-1.8.0-no-python-pyc.patch
deleted file mode 100644
index ec3e1c2dccf6..000000000000
--- a/sci-geosciences/qgis/files/qgis-1.8.0-no-python-pyc.patch
+++ /dev/null
@@ -1,54 +0,0 @@
---- cmake/PythonMacros.cmake
-+++ cmake/PythonMacros.cmake
-@@ -22,40 +22,4 @@
- # Install the source file.
- INSTALL(FILES ${SOURCE_FILE} DESTINATION ${DESINATION_DIR})
-
-- # Byte compile and install the .pyc file.
-- GET_FILENAME_COMPONENT(_absfilename ${SOURCE_FILE} ABSOLUTE)
-- GET_FILENAME_COMPONENT(_filename ${SOURCE_FILE} NAME)
-- GET_FILENAME_COMPONENT(_filenamebase ${SOURCE_FILE} NAME_WE)
-- GET_FILENAME_COMPONENT(_basepath ${SOURCE_FILE} PATH)
--
-- if(WIN32)
-- string(REGEX REPLACE ".:/" "/" _basepath "${_basepath}")
-- endif(WIN32)
--
-- SET(_bin_py ${CMAKE_CURRENT_BINARY_DIR}/${_basepath}/${_filename})
-- SET(_bin_pyc ${CMAKE_CURRENT_BINARY_DIR}/${_basepath}/${_filenamebase}.pyc)
--
-- FILE(MAKE_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/${_basepath})
--
-- SET(_message "-DMESSAGE=Byte-compiling ${_bin_py}")
--
-- GET_FILENAME_COMPONENT(_abs_bin_py ${_bin_py} ABSOLUTE)
-- IF(_abs_bin_py STREQUAL ${_absfilename}) # Don't copy the file onto itself.
-- ADD_CUSTOM_COMMAND(
-- TARGET compile_python_files
-- COMMAND ${CMAKE_COMMAND} -E echo ${message}
-- COMMAND ${PYTHON_EXECUTABLE} ${_python_compile_py} ${_bin_py}
-- DEPENDS ${_absfilename}
-- )
-- ELSE(_abs_bin_py STREQUAL ${_absfilename})
-- ADD_CUSTOM_COMMAND(
-- TARGET compile_python_files
-- COMMAND ${CMAKE_COMMAND} -E echo ${message}
-- COMMAND ${CMAKE_COMMAND} -E copy ${_absfilename} ${_bin_py}
-- COMMAND ${PYTHON_EXECUTABLE} ${_python_compile_py} ${_bin_py}
-- DEPENDS ${_absfilename}
-- )
-- ENDIF(_abs_bin_py STREQUAL ${_absfilename})
--
-- INSTALL(FILES ${_bin_pyc} DESTINATION ${DESINATION_DIR})
- ENDMACRO(PYTHON_INSTALL)
---- python/CMakeLists.txt
-+++ python/CMakeLists.txt
-@@ -102,8 +102,6 @@
-
- SET (QGIS_PYTHON_DIR ${PYTHON_SITE_PACKAGES_DIR}/qgis)
-
--ADD_CUSTOM_TARGET(compile_python_files ALL)
--
- ADD_CUSTOM_COMMAND(TARGET compile_python_files
- POST_BUILD
- COMMAND ${CMAKE_COMMAND} -E make_directory ${QGIS_PYTHON_OUTPUT_DIRECTORY}