summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/threeV/threeV-1.2.ebuild')
-rw-r--r--sci-chemistry/threeV/threeV-1.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-chemistry/threeV/threeV-1.2.ebuild b/sci-chemistry/threeV/threeV-1.2.ebuild
new file mode 100644
index 000000000000..7aaa18bba004
--- /dev/null
+++ b/sci-chemistry/threeV/threeV-1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="3V: Voss Volume Voxelator"
+HOMEPAGE="http://geometry.molmovdb.org/3v/"
+SRC_URI="http://geometry.molmovdb.org/3v/3v-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+PDEPEND="sci-chemistry/msms-bin"
+# sci-chemistry/usf-rave"
+
+S="${WORKDIR}/3v-${PV}/src"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+ tc-export CXX
+ emake distclean || die
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install || die
+
+ cd ..
+ dodoc AUTHORS ChangeLog QUICKSTART README TODO VERSION || die
+}