summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/pysam/pysam-0.6-r1.ebuild')
-rw-r--r--sci-biology/pysam/pysam-0.6-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sci-biology/pysam/pysam-0.6-r1.ebuild b/sci-biology/pysam/pysam-0.6-r1.ebuild
new file mode 100644
index 000000000000..3873100fa45f
--- /dev/null
+++ b/sci-biology/pysam/pysam-0.6-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for the SAM/BAM sequence alignment and mapping format"
+HOMEPAGE="http://code.google.com/p/pysam http://pypi.python.org/pypi/pysam"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}