summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/wepdecrypt/wepdecrypt-0.8-r2.ebuild')
-rw-r--r--net-wireless/wepdecrypt/wepdecrypt-0.8-r2.ebuild30
1 files changed, 13 insertions, 17 deletions
diff --git a/net-wireless/wepdecrypt/wepdecrypt-0.8-r2.ebuild b/net-wireless/wepdecrypt/wepdecrypt-0.8-r2.ebuild
index 473c8f2a2f0b..e08f59101bbd 100644
--- a/net-wireless/wepdecrypt/wepdecrypt-0.8-r2.ebuild
+++ b/net-wireless/wepdecrypt/wepdecrypt-0.8-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
inherit eutils
@@ -15,30 +15,26 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="X"
RDEPEND="
- dev-libs/openssl
+ dev-libs/openssl:=
net-libs/libpcap
sys-libs/zlib
X? ( x11-libs/fltk:1 )"
DEPEND="${RDEPEND}"
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-build.patch \
- "${FILESDIR}"/${P}-fltk.patch
-
- #Fix buffer size wrt bug 340148.
- epatch "${FILESDIR}/${P}-buffer.patch"
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+ "${FILESDIR}/${P}-fltk.patch"
+ "${FILESDIR}/${P}-buffer.patch" # bug#340148.
+ "${FILESDIR}/${P}-dyn.patch"
+)
- epatch "${FILESDIR}/${P}-dyn.patch"
+src_prepare() {
+ default
- #Fix respect for jobserver
sed -i 's/make/$(MAKE)/g' Makefile || die "Sed failed"
}
src_configure() {
- # build system is broken and --enabled-gui doesn't work
- local myconf=""
- ! use X && myconf="--disable-gui"
-
- econf ${myconf}
+ econf \
+ $(use X || echo --disable-gui)
}