summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-print/epson-inkjet-printer-escpr')
-rw-r--r--net-print/epson-inkjet-printer-escpr/Manifest3
-rw-r--r--net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.2.15.ebuild (renamed from net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.2.9-r1.ebuild)5
-rw-r--r--net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.8.6.ebuild51
-rw-r--r--net-print/epson-inkjet-printer-escpr/files/1.8.6-warnings.patch53
-rw-r--r--net-print/epson-inkjet-printer-escpr/files/gcc-no-implicit-function-declaration-1.2.patch89
5 files changed, 198 insertions, 3 deletions
diff --git a/net-print/epson-inkjet-printer-escpr/Manifest b/net-print/epson-inkjet-printer-escpr/Manifest
index b911f5172313..0bd802946455 100644
--- a/net-print/epson-inkjet-printer-escpr/Manifest
+++ b/net-print/epson-inkjet-printer-escpr/Manifest
@@ -1,2 +1,3 @@
DIST epson-inkjet-printer-escpr-1.8.5-1.tar.gz 5666905 BLAKE2B 549c948709993779b5615b501038fdceb6c3d6f173709b8cf99459346fff89923bdbe1babe34ee98eed4e1ebbd7a4b5962ddbc9cec9711aa15ff2056fec3d436 SHA512 4117b1efe903e4f506bbc67c45079f1d467ff6527691308734e55d32feeda3ec44b2dd85361e0243114f924eef04a91b0a5e86b5008f0a32ef323989b3d2896f
-DIST epson-inkjet-printer-escpr2-1.2.9-1.tar.gz 5367737 BLAKE2B 6868569a6bed622e2f50619a36ffb0a0f7e834fd8a794ae3bc906d971db26b0c86386c9545190ec384027d0b8e8f62ddda6cb24f1e3f60b9c535a1eeddff4332 SHA512 70ff744d42fac4c79d2994648763b0b3970ee5463a7a310a0721a63735d536cb9a0499c894289d946b30e6f564f9bf60aa61801580ab6635af211d50867921a1
+DIST epson-inkjet-printer-escpr-1.8.6-1.tar.gz 5715741 BLAKE2B 0da5e0af022bf2ce42ef94631c984b8308562bcb8f1f47a8f50b77be09326a80e9495ddaf02becdf72e78e50041f73cdd558c96d72046600452de50bc68f1bc8 SHA512 d0040c99793ba33e54ec5f0137f3b672628f089a6cd792916c24fc5edab75702561dade91eb63cd4b3b8e898f7b4647c899ca425e1449a401c7ff562f8cc0f1e
+DIST epson-inkjet-printer-escpr2-1.2.15-1.tar.gz 5560479 BLAKE2B 8180fe06df8175ec31044b0eec2a125b9567c11a827343401a07e59e8bd93e689617b9b29364374f1d6ba6d6bca320d6615f601791c59e966d3a4d63f7adbeb0 SHA512 62cd5161f65f8ca6f8c1a8bb755e06eb147d4a06b5f796a8068ed9235b3abf38e6ccb10e82bdd93fddc085b90a7f9332e024ba09679aa08490a05735c0372653
diff --git a/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.2.9-r1.ebuild b/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.2.15.ebuild
index ee7aecc88746..7af630931f56 100644
--- a/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.2.9-r1.ebuild
+++ b/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.2.15.ebuild
@@ -7,7 +7,7 @@ MY_P="${PN}2-${PV}"
DESCRIPTION="Epson Inkjet Printer Driver 2 (ESC/P-R) for Linux"
HOMEPAGE="https://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
-SRC_URI="https://download3.ebz.epson.net/dsc/f/03/00/15/33/96/607198a4f064daa9e7931913eaf27f3a58125f2b/${MY_P}-1.tar.gz"
+SRC_URI="https://download3.ebz.epson.net/dsc/f/03/00/16/06/85/fddc1d5996d0cab4dceea35852a2e430fb124993/${MY_P}-1.tar.gz"
S="${WORKDIR}/${MY_P}"
LICENSE="EPSON LGPL-2.1+"
SLOT="2"
@@ -19,7 +19,8 @@ DEPEND="net-print/cups"
RDEPEND="${DEPEND}"
PATCHES=(
- "${FILESDIR}/${PN}-${SLOT}-gcc14.patch"
+ #"${FILESDIR}/gcc-no-implicit-function-declaration-${PV}.patch"
+ "${FILESDIR}/gcc-no-implicit-function-declaration-$(ver_cut 1-2 ${PV}).patch"
)
src_configure() {
diff --git a/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.8.6.ebuild b/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.8.6.ebuild
new file mode 100644
index 000000000000..1bb1bb81960c
--- /dev/null
+++ b/net-print/epson-inkjet-printer-escpr/epson-inkjet-printer-escpr-1.8.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools edos2unix
+
+DESCRIPTION="Epson Inkjet Printer Driver (ESC/P-R)"
+HOMEPAGE="https://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+
+# https://support.epson.net/linux/Printer/LSB_distribution_pages/en/escpr.php
+# Use the "source package for arm CPU" to get a tarball instead of an srpm.
+SRC_URI="https://download3.ebz.epson.net/dsc/f/03/00/16/21/81/74d098a47c3a616713079c9cd5904b468bb33dea/${P}-1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+DEPEND="net-print/cups"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-warnings.patch"
+ "${FILESDIR}/${PN}-1.7.7-fnocommon.patch"
+ "${FILESDIR}/${PN}-1.8-missing-include.patch"
+)
+
+src_prepare() {
+ local f
+ for f in $(find ./ -type f || die); do
+ edos2unix "${f}"
+ done
+
+ eautoreconf
+ default
+}
+
+src_configure() {
+ econf --disable-shared
+
+ # Makefile calls ls to generate a file list which is included in Makefile.am
+ # Set the collation to C to avoid automake being called automatically
+ unset LC_ALL
+ export LC_COLLATE=C
+}
+
+src_install() {
+ emake -C ppd DESTDIR="${D}" install
+ emake -C src DESTDIR="${D}" install
+ einstalldocs
+}
diff --git a/net-print/epson-inkjet-printer-escpr/files/1.8.6-warnings.patch b/net-print/epson-inkjet-printer-escpr/files/1.8.6-warnings.patch
new file mode 100644
index 000000000000..6e83ed6e1404
--- /dev/null
+++ b/net-print/epson-inkjet-printer-escpr/files/1.8.6-warnings.patch
@@ -0,0 +1,53 @@
+--- a/lib/epson-escpr-api.h 2024-10-30 12:42:07.278862232 -0400
++++ b/lib/epson-escpr-api.h 2024-10-30 12:43:46.975989499 -0400
+@@ -111,6 +111,10 @@ extern EPS_ERR_CODE epsGetUsersizeRange
+ /*** -------------------------------------------------------------------------------*/
+ extern EPS_ERR_CODE epsMakeMainteCmd (EPS_INT32, EPS_UINT8*, EPS_UINT32* );
+
++extern EPS_ERR_CODE SetupJobAttrib (const EPS_JOB_ATTRIB* );
++extern EPS_ERR_CODE SendStartJob (EPS_BOOL );
++extern EPS_ERR_CODE PrintBand (const EPS_UINT8*, EPS_UINT32, EPS_UINT32* );
++
+ #ifdef __cplusplus
+ }
+ #endif
+--- a/src/filter.c 2024-10-30 12:44:02.992729085 -0400
++++ b/src/filter.c 2024-10-30 12:44:49.836274137 -0400
+@@ -32,7 +32,9 @@
+
+ #include "epson-protocol.h"
+ #include "epson-escpr-api.h"
++#include "epson-escpr-services.h"
+ #include "epson-escpr-mem.h"
++#include "epson-escpage.h"
+
+ #include "err.h"
+ #include "mem.h"
+@@ -42,6 +44,7 @@
+ #include "optBase.h"
+ #include "linux_cmn.h"
+ #include "custompage.h"
++#include "xfifo.h"
+
+ #define WIDTH_BYTES(bits) (((bits) + 31) / 32 * 4)
+
+--- a/src/mem.c 2024-10-30 12:42:31.732309679 -0400
++++ b/src/mem.c 2024-10-30 12:43:15.375844801 -0400
+@@ -22,6 +22,7 @@
+ #endif
+
+ #include <stdlib.h>
++#include "err.h"
+ #include "mem.h"
+
+ void *
+--- a/src/wrapper.c 2024-10-30 12:48:35.673934604 -0400
++++ b/src/wrapper.c 2024-10-30 12:49:00.237373816 -0400
+@@ -35,6 +35,7 @@
+ #include <signal.h>
+
+ #include "libprtX.h"
++#include "custompage.h"
+
+ #define WIDTH_BYTES(bits) (((bits) + 31) / 32 * 4)
+
diff --git a/net-print/epson-inkjet-printer-escpr/files/gcc-no-implicit-function-declaration-1.2.patch b/net-print/epson-inkjet-printer-escpr/files/gcc-no-implicit-function-declaration-1.2.patch
new file mode 100644
index 000000000000..ab244ddbe71b
--- /dev/null
+++ b/net-print/epson-inkjet-printer-escpr/files/gcc-no-implicit-function-declaration-1.2.patch
@@ -0,0 +1,89 @@
+From 70b13d5be6d9ca55c0a9ec0dd401c9401922b1b7 Mon Sep 17 00:00:00 2001
+From: Aleix Quintana Alsius <kinta@communia.org>
+Date: Fri, 31 May 2024 23:51:51 +0200
+Subject: [PATCH] reroll update x86-64 patch
+
+---
+ src/filter.c | 12 +++++++++---
+ src/mem.c | 1 +
+ src/wrapper.c | 1 +
+ 3 files changed, 11 insertions(+), 3 deletions(-)
+
+diff --git a/src/filter.c b/src/filter.c
+index d53e091..5bb2a5f 100644
+--- a/src/filter.c
++++ b/src/filter.c
+@@ -39,6 +39,7 @@
+ #include "epson-escpr-api.h"
+ #include "epson-escpr-services.h"
+ #include "epson-escpr-mem.h"
++#include "epson-escpr-services.h"
+
+ #include "err.h"
+ #include "mem.h"
+@@ -48,6 +49,11 @@
+ #include "optBase.h"
+ #include "linux_cmn.h"
+ #include "custompage.h"
++#include "xfifo.h"
++
++extern EPS_ERR_CODE SetupJobAttrib (const EPS_JOB_ATTRIB*);
++extern EPS_ERR_CODE SendStartJob ();
++extern EPS_ERR_CODE PrintBand (const EPS_UINT8*, EPS_UINT32, EPS_UINT32*);
+
+ #define WIDTH_BYTES(bits) (((bits) + 31) / 32 * 4)
+
+@@ -453,7 +459,7 @@ main (int argc, char *argv[])
+ }
+
+ printJob.jobStatus = EPS_STATUS_ESTABLISHED;
+- int printHeight = 0;
++ EPS_UINT32 printHeight = 0;
+ ///////////////////////////////////////////////////////////////////////////////////////////////////////////
+
+ print_area_x = printJob.printableAreaWidth;
+@@ -632,7 +638,7 @@ main (int argc, char *argv[])
+ memcpy(rever_buf + k*3, startpage + pos + (bandBmp.widthBytes - 6) - k*3, 3);
+ }
+ }
+- PrintBand (rever_buf, bandBmp.widthBytes, &printHeight);
++ PrintBand ((const EPS_UINT8 *)rever_buf, bandBmp.widthBytes, &printHeight);
+ pos -= bandBmp.widthBytes;
+ }
+
+@@ -925,7 +931,7 @@ set_pips_parameter (filter_option_t *filter_opt_p, EPS_OPT *printOpt)
+
+ /* Get number of pages */
+ char page_num;
+- read (STDIN_FILENO, &page_num, 1);
++ (void)read (STDIN_FILENO, &page_num, 1);
+ debug_msg("total pages = %d\n", page_num);
+
+ /* Others */
+diff --git a/src/mem.c b/src/mem.c
+index f53f2bc..d6c945a 100644
+--- a/src/mem.c
++++ b/src/mem.c
+@@ -23,6 +23,7 @@
+
+ #include <stdlib.h>
+ #include "mem.h"
++#include "err.h"
+
+ void *
+ mem_malloc (unsigned int size, bool_t crit)
+diff --git a/src/wrapper.c b/src/wrapper.c
+index 1fa6daa..bfd567d 100644
+--- a/src/wrapper.c
++++ b/src/wrapper.c
+@@ -33,6 +33,7 @@
+ /* added 22-04-2004 */
+ #include <signal.h>
+
++#include "custompage.h"
+ #include "libprtX.h"
+
+ #define WIDTH_BYTES(bits) (((bits) + 31) / 32 * 4)
+--
+2.45.1
+