summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail/postfix-logwatch/postfix-logwatch-1.40.03.ebuild')
-rw-r--r--net-mail/postfix-logwatch/postfix-logwatch-1.40.03.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-mail/postfix-logwatch/postfix-logwatch-1.40.03.ebuild b/net-mail/postfix-logwatch/postfix-logwatch-1.40.03.ebuild
new file mode 100644
index 000000000000..99d064ad9cab
--- /dev/null
+++ b/net-mail/postfix-logwatch/postfix-logwatch-1.40.03.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A log analyzer for postfix"
+HOMEPAGE="http://logreporters.sourceforge.net/"
+SRC_URI="mirror://sourceforge/logreporters/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="dev-lang/perl"
+
+src_prepare() {
+ # Replace the default config file location with ours.
+ local cfg_default='/usr/local/etc/${progname_prefix}-logwatch.conf'
+ local cfg_gentoo='/etc/${progname_prefix}-logwatch.conf';
+ sed -i "s~${cfg_default}~${cfg_gentoo}~" ${PN} \
+ || die 'failed to update the default config location'
+}
+
+src_compile() {
+ # The default make target just outputs instructions. We don't want
+ # the user to see these, so we avoid the default emake.
+ :
+}
+
+src_install() {
+ dodoc Bugs Changes README ${PN}.conf-topn
+ doman ${PN}.1
+ dobin ${PN}
+ insinto /etc
+ doins ${PN}.conf
+}