summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nmap/files')
-rw-r--r--net-analyzer/nmap/files/nmap-4.75-nolua.patch10
-rw-r--r--net-analyzer/nmap/files/nmap-5.10_beta1-string.patch11
-rw-r--r--net-analyzer/nmap/files/nmap-5.21-python.patch21
-rw-r--r--net-analyzer/nmap/files/nmap-6.01-make.patch20
-rw-r--r--net-analyzer/nmap/files/nmap-6.25-liblua-ar.patch20
-rw-r--r--net-analyzer/nmap/files/nmap-6.46-uninstaller.patch19
-rw-r--r--net-analyzer/nmap/files/nmap-6.47-ncat-lua.patch11
-rw-r--r--net-analyzer/nmap/files/nmap-6.47-no-FORTIFY_SOURCE.patch77
-rw-r--r--net-analyzer/nmap/files/nmap-6.47-no-libnl.patch70
-rw-r--r--net-analyzer/nmap/files/nmap-6.49-no-FORTIFY_SOURCE.patch71
-rw-r--r--net-analyzer/nmap/files/nmap-no-FORTIFY_SOURCE.patch77
11 files changed, 407 insertions, 0 deletions
diff --git a/net-analyzer/nmap/files/nmap-4.75-nolua.patch b/net-analyzer/nmap/files/nmap-4.75-nolua.patch
new file mode 100644
index 000000000000..30bb1e0c8669
--- /dev/null
+++ b/net-analyzer/nmap/files/nmap-4.75-nolua.patch
@@ -0,0 +1,10 @@
+diff -Naur nmap-4.75-orig/Makefile.in nmap-4.75/Makefile.in
+--- nmap-4.75-orig/Makefile.in 2008-09-05 07:32:06.000000000 +0200
++++ nmap-4.75/Makefile.in 2008-09-09 16:34:38.000000000 +0200
+@@ -258,5 +258,5 @@
+ ./config.status --recheck
+
+ makefile.dep:
+- $(CXX) -MM $(CPPFLAGS) $(SRCS) > $@
++ $(CXX) -MM $(CPPFLAGS) $(CXXFLAGS) $(SRCS) > $@
+ include makefile.dep
diff --git a/net-analyzer/nmap/files/nmap-5.10_beta1-string.patch b/net-analyzer/nmap/files/nmap-5.10_beta1-string.patch
new file mode 100644
index 000000000000..df29db3782d5
--- /dev/null
+++ b/net-analyzer/nmap/files/nmap-5.10_beta1-string.patch
@@ -0,0 +1,11 @@
+--- nmap-5.10BETA1/Target.h.org 2009-12-08 08:21:59.000000000 +0100
++++ nmap-5.10BETA1/Target.h 2009-12-08 08:22:02.000000000 +0100
+@@ -99,6 +99,8 @@
+
+ #ifndef NOLUA
+ #include "nse_main.h"
++#else
++#include <string>
+ #endif
+
+ #include "portreasons.h"
diff --git a/net-analyzer/nmap/files/nmap-5.21-python.patch b/net-analyzer/nmap/files/nmap-5.21-python.patch
new file mode 100644
index 000000000000..aa0d4f9db953
--- /dev/null
+++ b/net-analyzer/nmap/files/nmap-5.21-python.patch
@@ -0,0 +1,21 @@
+diff -Naurp nmap-5.21-orig/Makefile.in nmap-5.21/Makefile.in
+--- nmap-5.21-orig/Makefile.in 2010-01-31 09:53:53.000000000 +0100
++++ nmap-5.21/Makefile.in 2010-01-31 09:54:48.000000000 +0100
+@@ -253,7 +253,7 @@ build-zenmap: $(ZENMAPDIR)/setup.py $(ZE
+
+ install-zenmap: $(ZENMAPDIR)/setup.py
+ $(INSTALL) -d $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1
+- cd $(ZENMAPDIR) && $(PYTHON) setup.py --quiet install --prefix "$(prefix)" --force $(if $(DESTDIR),--root "$(DESTDIR)")
++ cd $(ZENMAPDIR) && $(PYTHON) setup.py --quiet install --prefix "$(prefix)" --force $(if $(DESTDIR),--root "$(DESTDIR)") --no-compile
+ $(INSTALL) -c -m 644 docs/zenmap.1 $(DESTDIR)$(mandir)/man1/
+ # Create a symlink from nmapfe to zenmap if nmapfe doesn't exist or is
+ # already a link.
+@@ -267,7 +267,7 @@ build-ndiff:
+ cd $(NDIFFDIR) && $(PYTHON) setup.py build $(if $(DESTDIR),--executable "$(DEFAULT_PYTHON_PATH)")
+
+ install-ndiff:
+- cd $(NDIFFDIR) && $(PYTHON) setup.py install --prefix "$(prefix)" $(if $(DESTDIR),--root "$(DESTDIR)")
++ cd $(NDIFFDIR) && $(PYTHON) setup.py install --prefix "$(prefix)" $(if $(DESTDIR),--root "$(DESTDIR)") --no-compile
+
+ NSE_FILES = scripts/script.db scripts/*.nse
+ NSE_LIB_LUA_FILES = nselib/*.lua
diff --git a/net-analyzer/nmap/files/nmap-6.01-make.patch b/net-analyzer/nmap/files/nmap-6.01-make.patch
new file mode 100644
index 000000000000..2711b3168b2e
--- /dev/null
+++ b/net-analyzer/nmap/files/nmap-6.01-make.patch
@@ -0,0 +1,20 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -119,6 +119,8 @@
+ rm -f $@
+ $(CXX) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
+
++$(NBASEDIR)/libnbase.a: nbase_build
++
+ build-%: %/Makefile
+ cd $* && $(MAKE)
+
+@@ -152,7 +154,7 @@
+ liblinear_build: $(LIBLINEARDIR)/Makefile
+ @echo Compiling liblinear; cd $(LIBLINEARDIR) && $(MAKE) liblinear.a CC="$(CC)" CXX="$(CXX)" CFLAGS="$(CFLAGS)"
+
+-build-nmap-update: nmap-update/default_channel.h
++build-nmap-update: nbase_build nmap-update/default_channel.h
+
+ #$(LIBPCAPDIR)/Makefile:
+ # @echo Configuring libpcap; cd $(LIBPCAPDIR); ./configure
diff --git a/net-analyzer/nmap/files/nmap-6.25-liblua-ar.patch b/net-analyzer/nmap/files/nmap-6.25-liblua-ar.patch
new file mode 100644
index 000000000000..5aa9fa7f631c
--- /dev/null
+++ b/net-analyzer/nmap/files/nmap-6.25-liblua-ar.patch
@@ -0,0 +1,20 @@
+--- a/liblua/Makefile
++++ b/liblua/Makefile
+@@ -11,7 +11,7 @@
+ LDFLAGS= $(SYSLDFLAGS) $(MYLDFLAGS)
+ LIBS= -lm $(SYSLIBS) $(MYLIBS)
+
+-AR= ar rcu
++AR= ar
+ RANLIB= ranlib
+ RM= rm -f
+
+@@ -56,7 +56,7 @@
+ a: $(ALL_A)
+
+ $(LUA_A): $(BASE_O)
+- $(AR) $@ $(BASE_O)
++ $(AR) rcu $@ $(BASE_O)
+ $(RANLIB) $@
+
+ $(LUA_T): $(LUA_O) $(LUA_A)
diff --git a/net-analyzer/nmap/files/nmap-6.46-uninstaller.patch b/net-analyzer/nmap/files/nmap-6.46-uninstaller.patch
new file mode 100644
index 000000000000..6b43f8f5a069
--- /dev/null
+++ b/net-analyzer/nmap/files/nmap-6.46-uninstaller.patch
@@ -0,0 +1,19 @@
+--- a/zenmap/setup.py
++++ b/zenmap/setup.py
+@@ -245,7 +245,6 @@
+ self.set_perms()
+ self.set_modules_path()
+ self.fix_paths()
+- self.create_uninstaller()
+ self.write_installed_files()
+
+ def get_installed_files(self):
+@@ -263,8 +262,6 @@
+ os.path.join(self.install_data, data_dir)):
+ for dir in dirs:
+ installed_files.append(os.path.join(dirpath, dir))
+- installed_files.append(
+- os.path.join(self.install_scripts, "uninstall_" + APP_NAME))
+ return installed_files
+
+ def create_uninstaller(self):
diff --git a/net-analyzer/nmap/files/nmap-6.47-ncat-lua.patch b/net-analyzer/nmap/files/nmap-6.47-ncat-lua.patch
new file mode 100644
index 000000000000..27df06b9b710
--- /dev/null
+++ b/net-analyzer/nmap/files/nmap-6.47-ncat-lua.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -145,7 +145,7 @@
+ @echo Compiling libnetutil;
+ cd libnetutil && $(MAKE)
+
+-ncat_build: $(NCATDIR)/Makefile nbase_build nsock_build $(NCATDIR)/ncat.h @PCAP_BUILD@
++ncat_build: $(NCATDIR)/Makefile nbase_build nsock_build @LUA_BUILD@ $(NCATDIR)/ncat.h @PCAP_BUILD@
+ cd $(NCATDIR) && $(MAKE)
+
+ lua_build: $(LIBLUADIR)/Makefile
diff --git a/net-analyzer/nmap/files/nmap-6.47-no-FORTIFY_SOURCE.patch b/net-analyzer/nmap/files/nmap-6.47-no-FORTIFY_SOURCE.patch
new file mode 100644
index 000000000000..9b2993f59ea4
--- /dev/null
+++ b/net-analyzer/nmap/files/nmap-6.47-no-FORTIFY_SOURCE.patch
@@ -0,0 +1,77 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -40,7 +40,7 @@
+ # http://gcc.gnu.org/ml/gcc-patches/2004-09/msg02055.html
+ # Level 1 only makes changes that don't affect "conforming" programs,
+ # while level 2 enforces additional restrictions.
+-DEFS += -D_FORTIFY_SOURCE=2
++#DEFS += -D_FORTIFY_SOURCE=2
+ # For mtrace debugging -- see MTRACE define in main.cc for instructions
+ # Should only be enabled during debugging and not in any real release.
+ # DEFS += -DMTRACE=1
+--- a/nsock/src/Makefile.in
++++ b/nsock/src/Makefile.in
+@@ -13,7 +13,7 @@
+ CCOPT =
+ DEFS = @DEFS@ -DNSOCK_VERSION=\"$(NSOCK_VERSION)\"
+ # With GCC, add extra security checks to source code.
+-DEFS += -D_FORTIFY_SOURCE=2
++#DEFS += -D_FORTIFY_SOURCE=2
+ INCLS = -I../include
+ CFLAGS = @CFLAGS@ $(CCOPT)
+ # CFLAGS = -g -Wall $(DEFS) $(INCLS)
+--- a/nping/Makefile.in
++++ b/nping/Makefile.in
+@@ -37,7 +37,7 @@
+ # http://gcc.gnu.org/ml/gcc-patches/2004-09/msg02055.html
+ # Level 1 only makes changes that don't affect "conforming" programs,
+ # while level 2 enforces additional restrictions.
+-DEFS += -D_FORTIFY_SOURCE=2
++#DEFS += -D_FORTIFY_SOURCE=2
+ # For mtrace debugging -- see MTRACE define in main.cc for instructions
+ # Should only be enabled during debugging and not in any real release.
+ # DEFS += -DMTRACE=1
+--- a/libnetutil/Makefile.in
++++ b/libnetutil/Makefile.in
+@@ -5,7 +5,7 @@
+ CXXFLAGS = @CXXFLAGS@
+ CPPFLAGS = @CPPFLAGS@ $(DEFS)
+ DEFS = @DEFS@
+-DEFS += -D_FORTIFY_SOURCE=2
++#DEFS += -D_FORTIFY_SOURCE=2
+ AR = ar
+ RANLIB = @RANLIB@
+
+--- a/ncat/Makefile.in
++++ b/ncat/Makefile.in
+@@ -52,7 +52,7 @@
+ LIBS = @LIBS@
+ DEFS = @DEFS@ -DNCAT_DATADIR="\"$(pkgdatadir)\""
+ # With GCC, add extra security checks to source code.
+-DEFS += -D_FORTIFY_SOURCE=2
++#DEFS += -D_FORTIFY_SOURCE=2
+ INCLS = -I. -I.. -I../nsock/include/ -I$(NBASEDIR)
+ RM = rm -f
+ STRIP = @STRIP@
+--- a/nbase/Makefile.in
++++ b/nbase/Makefile.in
+@@ -11,7 +11,7 @@
+ CCOPT =
+ DEFS = @DEFS@
+ # With GCC, add extra security checks to source code.
+-DEFS += -D_FORTIFY_SOURCE=2
++#DEFS += -D_FORTIFY_SOURCE=2
+ CPPFLAGS = @CPPFLAGS@
+ CFLAGS = @CFLAGS@ $(CCOPT) $(GLIB_CFLAGS) $(DEFS) $(INCLS)
+ STATIC =
+--- a/nmap-update/Makefile.in
++++ b/nmap-update/Makefile.in
+@@ -10,7 +10,7 @@
+ CPPFLAGS = @CPPFLAGS@ $(DEFS) -I$(NBASEDIR)
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@ $(NBASELIB)
+-DEFS = @DEFS@ -D_FORTIFY_SOURCE=2
++DEFS = @DEFS@
+
+ INSTALL = @INSTALL@
+ STRIP = @STRIP@
diff --git a/net-analyzer/nmap/files/nmap-6.47-no-libnl.patch b/net-analyzer/nmap/files/nmap-6.47-no-libnl.patch
new file mode 100644
index 000000000000..0e0c6b70beff
--- /dev/null
+++ b/net-analyzer/nmap/files/nmap-6.47-no-libnl.patch
@@ -0,0 +1,70 @@
+nping does not call anything nl_* related so it should not link against libnl (bug #529244)
+Patching configure.ac would be best but eautoreconf does not handle the subdirs very well.
+
+--- a/nping/configure
++++ b/nping/configure
+@@ -4865,64 +4865,6 @@
+ fi
+
+
+-# libpcap can require libnl
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing nl_handle_alloc" >&5
+-$as_echo_n "checking for library containing nl_handle_alloc... " >&6; }
+-if ${ac_cv_search_nl_handle_alloc+:} false; then :
+- $as_echo_n "(cached) " >&6
+-else
+- ac_func_search_save_LIBS=$LIBS
+-cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+-/* end confdefs.h. */
+-
+-/* Override any GCC internal prototype to avoid an error.
+- Use char because int might match the return type of a GCC
+- builtin and then its argument prototype would still apply. */
+-#ifdef __cplusplus
+-extern "C"
+-#endif
+-char nl_handle_alloc ();
+-int
+-main ()
+-{
+-return nl_handle_alloc ();
+- ;
+- return 0;
+-}
+-_ACEOF
+-for ac_lib in '' nl; do
+- if test -z "$ac_lib"; then
+- ac_res="none required"
+- else
+- ac_res=-l$ac_lib
+- LIBS="-l$ac_lib $ac_func_search_save_LIBS"
+- fi
+- if ac_fn_c_try_link "$LINENO"; then :
+- ac_cv_search_nl_handle_alloc=$ac_res
+-fi
+-rm -f core conftest.err conftest.$ac_objext \
+- conftest$ac_exeext
+- if ${ac_cv_search_nl_handle_alloc+:} false; then :
+- break
+-fi
+-done
+-if ${ac_cv_search_nl_handle_alloc+:} false; then :
+-
+-else
+- ac_cv_search_nl_handle_alloc=no
+-fi
+-rm conftest.$ac_ext
+-LIBS=$ac_func_search_save_LIBS
+-fi
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_search_nl_handle_alloc" >&5
+-$as_echo "$ac_cv_search_nl_handle_alloc" >&6; }
+-ac_res=$ac_cv_search_nl_handle_alloc
+-if test "$ac_res" != no; then :
+- test "$ac_res" = "none required" || LIBS="$ac_res $LIBS"
+-
+-fi
+-
+-
+ # We test whether they specified openssl desires explicitly
+ use_openssl="yes"
+ specialssldir=""
diff --git a/net-analyzer/nmap/files/nmap-6.49-no-FORTIFY_SOURCE.patch b/net-analyzer/nmap/files/nmap-6.49-no-FORTIFY_SOURCE.patch
new file mode 100644
index 000000000000..383975493be9
--- /dev/null
+++ b/net-analyzer/nmap/files/nmap-6.49-no-FORTIFY_SOURCE.patch
@@ -0,0 +1,71 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -41,7 +41,6 @@
+ # http://gcc.gnu.org/ml/gcc-patches/2004-09/msg02055.html
+ # Level 1 only makes changes that don't affect "conforming" programs,
+ # while level 2 enforces additional restrictions.
+-DEFS += -D_FORTIFY_SOURCE=2
+ # For mtrace debugging -- see MTRACE define in main.cc for instructions
+ # Should only be enabled during debugging and not in any real release.
+ # DEFS += -DMTRACE=1
+--- a/nsock/src/Makefile.in
++++ b/nsock/src/Makefile.in
+@@ -13,7 +13,6 @@
+ CCOPT =
+ DEFS = @DEFS@ -DNSOCK_VERSION=\"$(NSOCK_VERSION)\"
+ # With GCC, add extra security checks to source code.
+-DEFS += -D_FORTIFY_SOURCE=2
+ INCLS = -I../include
+ CFLAGS = @CFLAGS@ $(CCOPT)
+ # CFLAGS = -g -Wall $(DEFS) $(INCLS)
+--- a/nping/Makefile.in
++++ b/nping/Makefile.in
+@@ -38,7 +38,6 @@
+ # http://gcc.gnu.org/ml/gcc-patches/2004-09/msg02055.html
+ # Level 1 only makes changes that don't affect "conforming" programs,
+ # while level 2 enforces additional restrictions.
+-DEFS += -D_FORTIFY_SOURCE=2
+ # For mtrace debugging -- see MTRACE define in main.cc for instructions
+ # Should only be enabled during debugging and not in any real release.
+ # DEFS += -DMTRACE=1
+--- a/libnetutil/Makefile.in
++++ b/libnetutil/Makefile.in
+@@ -5,7 +5,6 @@
+ CXXFLAGS = @CXXFLAGS@
+ CPPFLAGS = @CPPFLAGS@ $(DEFS)
+ DEFS = @DEFS@
+-DEFS += -D_FORTIFY_SOURCE=2
+ AR = ar
+ RANLIB = @RANLIB@
+
+--- a/ncat/Makefile.in
++++ b/ncat/Makefile.in
+@@ -53,7 +53,6 @@
+ LIBS = @LIBS@
+ DEFS = @DEFS@ -DNCAT_DATADIR="\"$(pkgdatadir)\""
+ # With GCC, add extra security checks to source code.
+-DEFS += -D_FORTIFY_SOURCE=2
+ INCLS = -I. -I.. -I../nsock/include/ -I$(NBASEDIR)
+ RM = rm -f
+ STRIP = @STRIP@
+--- a/nbase/Makefile.in
++++ b/nbase/Makefile.in
+@@ -12,7 +12,6 @@
+ CCOPT =
+ DEFS = @DEFS@
+ # With GCC, add extra security checks to source code.
+-DEFS += -D_FORTIFY_SOURCE=2
+ CPPFLAGS = @CPPFLAGS@
+ CFLAGS = @CFLAGS@ $(CCOPT) $(GLIB_CFLAGS) $(DEFS) $(INCLS)
+ STATIC =
+--- a/nmap-update/Makefile.in
++++ b/nmap-update/Makefile.in
+@@ -11,7 +11,7 @@
+ CPPFLAGS = @CPPFLAGS@ $(DEFS) -I$(NBASEDIR)
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@ $(NBASELIB)
+-DEFS = @DEFS@ -D_FORTIFY_SOURCE=2
++DEFS = @DEFS@
+ APR_LIBS = @APR_LIBS@
+ SVN_LIBS = @SVN_LIBS@
+
diff --git a/net-analyzer/nmap/files/nmap-no-FORTIFY_SOURCE.patch b/net-analyzer/nmap/files/nmap-no-FORTIFY_SOURCE.patch
new file mode 100644
index 000000000000..5f79238d19a3
--- /dev/null
+++ b/net-analyzer/nmap/files/nmap-no-FORTIFY_SOURCE.patch
@@ -0,0 +1,77 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -40,7 +40,7 @@
+ # http://gcc.gnu.org/ml/gcc-patches/2004-09/msg02055.html
+ # Level 1 only makes changes that don't affect "conforming" programs,
+ # while level 2 enforces additional restrictions.
+-DEFS += -D_FORTIFY_SOURCE=2
++#DEFS += -D_FORTIFY_SOURCE=2
+ # For mtrace debugging -- see MTRACE define in main.cc for instructions
+ # Should only be enabled during debugging and not in any real release.
+ # DEFS += -DMTRACE=1
+--- a/nsock/src/Makefile.in
++++ b/nsock/src/Makefile.in
+@@ -13,7 +13,7 @@
+ CCOPT =
+ DEFS = @DEFS@ -DNSOCK_VERSION=\"$(NSOCK_VERSION)\"
+ # With GCC, add extra security checks to source code.
+-DEFS += -D_FORTIFY_SOURCE=2
++#DEFS += -D_FORTIFY_SOURCE=2
+ INCLS = -I../include
+ CFLAGS = @CFLAGS@ $(CCOPT)
+ # CFLAGS = -g -Wall $(DEFS) $(INCLS)
+--- a/nping/Makefile.in
++++ b/nping/Makefile.in
+@@ -37,7 +37,7 @@
+ # http://gcc.gnu.org/ml/gcc-patches/2004-09/msg02055.html
+ # Level 1 only makes changes that don't affect "conforming" programs,
+ # while level 2 enforces additional restrictions.
+-DEFS += -D_FORTIFY_SOURCE=2
++#DEFS += -D_FORTIFY_SOURCE=2
+ # For mtrace debugging -- see MTRACE define in main.cc for instructions
+ # Should only be enabled during debugging and not in any real release.
+ # DEFS += -DMTRACE=1
+--- a/libnetutil/Makefile.in
++++ b/libnetutil/Makefile.in
+@@ -5,7 +5,7 @@
+ CXXFLAGS = @CXXFLAGS@
+ CPPFLAGS = @CPPFLAGS@ $(DEFS)
+ DEFS = @DEFS@
+-DEFS += -D_FORTIFY_SOURCE=2
++#DEFS += -D_FORTIFY_SOURCE=2
+ AR = ar
+ RANLIB = @RANLIB@
+
+--- a/ncat/Makefile.in
++++ b/ncat/Makefile.in
+@@ -52,7 +52,7 @@
+ LIBS = @LIBS@
+ DEFS = @DEFS@ -DNCAT_DATADIR="\"$(pkgdatadir)\""
+ # With GCC, add extra security checks to source code.
+-DEFS += -D_FORTIFY_SOURCE=2
++#DEFS += -D_FORTIFY_SOURCE=2
+ INCLS = -I. -I.. -I../nsock/include/ -I$(NBASEDIR)
+ RM = rm -f
+ STRIP = @STRIP@
+--- a/nbase/Makefile.in
++++ b/nbase/Makefile.in
+@@ -11,7 +11,7 @@
+ CCOPT =
+ DEFS = @DEFS@
+ # With GCC, add extra security checks to source code.
+-DEFS += -D_FORTIFY_SOURCE=2
++#DEFS += -D_FORTIFY_SOURCE=2
+ CPPFLAGS = @CPPFLAGS@
+ CFLAGS = @CFLAGS@ $(CCOPT) $(GLIB_CFLAGS) $(DEFS) $(INCLS)
+ STATIC =
+--- a/nmap-update/Makefile.in
++++ b/nmap-update/Makefile.in
+@@ -10,7 +10,7 @@
+ CPPFLAGS = @CPPFLAGS@ $(DEFS) -I$(NBASEDIR)
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@ $(NBASELIB)
+-DEFS = @DEFS@ -D_FORTIFY_SOURCE=2
++DEFS = @DEFS@
+ APR_LIBS = @APR_LIBS@
+ SVN_LIBS = @SVN_LIBS@
+