summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/ifstatus')
-rw-r--r--net-analyzer/ifstatus/Manifest1
-rw-r--r--net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc43.patch10
-rw-r--r--net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch22
-rw-r--r--net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild40
-rw-r--r--net-analyzer/ifstatus/metadata.xml8
5 files changed, 81 insertions, 0 deletions
diff --git a/net-analyzer/ifstatus/Manifest b/net-analyzer/ifstatus/Manifest
new file mode 100644
index 000000000000..c2625e628c23
--- /dev/null
+++ b/net-analyzer/ifstatus/Manifest
@@ -0,0 +1 @@
+DIST ifstatus-v1.1.0.tar.gz 25233 SHA256 0ca8a8655a1edf07698efbd5e1d4adc962dbb1bfb078b4899062e89bb05eac10 SHA512 2660310be7186067315414218e3d3d269499e391c7ffa12022ac53a0456ddbe0f7d5562b788fe6b2569b7d0eba7acf5699e0386769a91606a3e14b51239a2766 WHIRLPOOL 7aebc62d229160a07a28e876d2d7daa6847ed16d6c6b0f457de70d85584afce36f6e4903befb383720426f6ee20def4d1d02245fabf8671a6df367517d2a648b
diff --git a/net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc43.patch b/net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc43.patch
new file mode 100644
index 000000000000..27111d7576f4
--- /dev/null
+++ b/net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc43.patch
@@ -0,0 +1,10 @@
+--- a/Main.h
++++ b/Main.h
+@@ -38,6 +38,7 @@
+ #include <unistd.h>
+ #include <string.h>
+ #include <curses.h>
++#include <stdlib.h>
+
+ #include <sys/time.h>
+ #include <sys/types.h>
diff --git a/net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch b/net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch
new file mode 100644
index 000000000000..e2c14e6add71
--- /dev/null
+++ b/net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch
@@ -0,0 +1,22 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,9 +1,7 @@
+ # Makefile for IFStatus
+ # Gabriel Montenegro
+
+-GCC = g++
+-LDFLAGS = -lncurses
+-CFLAGS = -O2 -Wall
++LDLIBS = $(shell $(PKG_CONFIG) --libs ncurses)
+
+ BIN = ifstatus
+ OBJ = BorderDecorator.o\
+@@ -30,7 +28,7 @@
+ all : ifstatus printdone
+
+ ifstatus : $(OBJ)
+- $(GCC) $(CFLAGS) $(LDFLAGS) $^ -o $@
++ $(LINK.cc) $^ $(LDLIBS) -o $@
+
+ printdone:
+ @if [ -e "./${BIN}" ]; then echo "Compiled.."; else echo "Error compiling!"; fi
diff --git a/net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild b/net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..f5cad000f1d8
--- /dev/null
+++ b/net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+KEYWORDS="amd64 arm ~ppc x86"
+
+DESCRIPTION="A simple CLI program for displaying network statistics in real time"
+HOMEPAGE="http://ifstatus.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-v${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND=">=sys-libs/ncurses-4.2"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+ epatch "${FILESDIR}/${P}-tinfo.patch"
+ tc-export CXX PKG_CONFIG
+}
+
+src_install() {
+ dobin ifstatus
+ dodoc AUTHORS README
+}
+
+pkg_postinst() {
+ elog "You may want to configure ~/.ifstatus/ifstatus.cfg"
+ elog "before running ifstatus. For example, you may add"
+ elog "Interfaces = eth0 there. Read the README file for"
+ elog "more information."
+}
diff --git a/net-analyzer/ifstatus/metadata.xml b/net-analyzer/ifstatus/metadata.xml
new file mode 100644
index 000000000000..0bda9893d463
--- /dev/null
+++ b/net-analyzer/ifstatus/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <upstream>
+ <remote-id type="sourceforge">ifstatus</remote-id>
+ </upstream>
+</pkgmetadata>