summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/dosdetector')
-rw-r--r--net-analyzer/dosdetector/Manifest1
-rw-r--r--net-analyzer/dosdetector/dosdetector-20060621.ebuild21
-rw-r--r--net-analyzer/dosdetector/files/dosdetector-20060621-isdigit.patch10
-rw-r--r--net-analyzer/dosdetector/metadata.xml5
4 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/dosdetector/Manifest b/net-analyzer/dosdetector/Manifest
new file mode 100644
index 000000000000..16d4bd54b9d6
--- /dev/null
+++ b/net-analyzer/dosdetector/Manifest
@@ -0,0 +1 @@
+DIST dosdetector-20060621.tar.gz 164768 SHA256 664b9c94dc225e1e604c2791ed5fa2f3e1924908f81e92a3a16578db0b4aa77f SHA512 30b6980920920a05668165a1c3dcbd07a94f964367d5f48ca443e017806cfcce85a11ad57183d3cc29ac06e8a1ef122227187f6cacd237fe327db4a768b992f6 WHIRLPOOL 0626779c2e1c3a2fccaf2ad12a2ca9d0a267dc456c3acc426623fd7cb5e9ef09f771c554f754eeaf81638664316c8b1024655de310da32c9a029a0b4b4b4e930
diff --git a/net-analyzer/dosdetector/dosdetector-20060621.ebuild b/net-analyzer/dosdetector/dosdetector-20060621.ebuild
new file mode 100644
index 000000000000..ada4ceb9c162
--- /dev/null
+++ b/net-analyzer/dosdetector/dosdetector-20060621.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Tool to analyze and detect suspicious traffic from IP and alert about it"
+HOMEPAGE="http://dark-zone.eu/resources/unix/dosdetector/"
+SRC_URI="http://dark-zone.eu/resources/unix/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-isdigit.patch
+}
diff --git a/net-analyzer/dosdetector/files/dosdetector-20060621-isdigit.patch b/net-analyzer/dosdetector/files/dosdetector-20060621-isdigit.patch
new file mode 100644
index 000000000000..11cd3170ded9
--- /dev/null
+++ b/net-analyzer/dosdetector/files/dosdetector-20060621-isdigit.patch
@@ -0,0 +1,10 @@
+--- a/include/dos.h
++++ b/include/dos.h
+@@ -26,6 +26,7 @@
+ #include <net/ppp_defs.h>
+ #include <sys/ioctl.h>
+ #include <time.h>
++#include <ctype.h> /* isdigit() */
+
+ /*
+ #define DEBUG_TREE 1
diff --git a/net-analyzer/dosdetector/metadata.xml b/net-analyzer/dosdetector/metadata.xml
new file mode 100644
index 000000000000..03aa50bab7e3
--- /dev/null
+++ b/net-analyzer/dosdetector/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>