summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/redoflacs/redoflacs-0.15.ebuild')
-rw-r--r--media-sound/redoflacs/redoflacs-0.15.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/redoflacs/redoflacs-0.15.ebuild b/media-sound/redoflacs/redoflacs-0.15.ebuild
new file mode 100644
index 000000000000..bf796c971d96
--- /dev/null
+++ b/media-sound/redoflacs/redoflacs-0.15.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit vcs-snapshot
+
+DESCRIPTION="Bash commandline flac verifier, organizer, analyzer"
+HOMEPAGE="https://github.com/sirjaren/redoflacs"
+SRC_URI="https://github.com/sirjaren/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ app-shells/bash
+ media-libs/flac
+ sys-apps/coreutils
+ sys-apps/findutils"
+
+src_install() {
+ newbin redoFlacs.sh redoflacs
+}
+
+pkg_postinst() {
+ elog "This script makes use of optional programs if installed:"
+ elog " media-sound/sox -> support for creating spectrograms"
+ elog " media-libs/libpng -> needed by media-sound/sox"
+}