summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/openal/files/openal-1.17.0-jackfix.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/media-libs/openal/files/openal-1.17.0-jackfix.patch b/media-libs/openal/files/openal-1.17.0-jackfix.patch
new file mode 100644
index 000000000000..6b41478c6ada
--- /dev/null
+++ b/media-libs/openal/files/openal-1.17.0-jackfix.patch
@@ -0,0 +1,11 @@
+--- openal-1.17.0/CMakeLists.txt
++++ openal-1.17.0/CMakeLists.txt
+@@ -924,7 +924,7 @@
+ SET(HAVE_JACK 1)
+ SET(BACKENDS "${BACKENDS} JACK${IS_LINKED},")
+ SET(ALC_OBJS ${ALC_OBJS} Alc/backends/jack.c)
+- ADD_BACKEND_LIBS(${PULSEAUDIO_LIBRARIES})
++ ADD_BACKEND_LIBS(${JACK_LIBRARIES})
+ IF(CMAKE_VERSION VERSION_LESS "2.8.8")
+ INCLUDE_DIRECTORIES(${JACK_INCLUDE_DIRS})
+ ENDIF()